summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-06-30 11:25:37 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-06-30 13:53:09 +0200
commit3d368c0b6476f39a94eed012eaadc81d6bddceae (patch)
tree1f2525932a78dfd85d7dd1687822848fb245f6a4
parentfe38fa6bc2c088b70c79dbb41e043d7b321ec91a (diff)
apalis-tk1: lvds-tegra124: disable lvds by default
Disable LVDS output in favour of primary HDMI one on Apalis TK1. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
new file mode 100644
index 0000000..0b778d6
--- /dev/null
+++ b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Disable LVDS output in favour of primary HDMI one on Apalis TK1"
+LICENSE = "PD"
+
+SRC_URI = " \
+ file://COPYING \
+"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+ mkdir -p ${sysconfdir}/xdg/lxsession/LXDE
+ echo "${bindir}/xrandr --output LVDS-0 --off" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
+}
+
+pkg_postrm_${PN}() {
+ sed -i /xrandr.*output.*LVDS.*off/d ${sysconfdir}/xdg/lxsession/LXDE/autostart || true
+}