summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-08-09 16:06:41 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-29 06:16:59 +0200
commitbb294ceafd2878acc6978e976f2dd0ee00d0c3a8 (patch)
tree8d784922f803c6bb0fe4de073cd9c9ce8298580f
parenta30a2d5809f3ca58781bd6439c297a2832b80d8a (diff)
layer.conf: add initial
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--conf/layer.conf18
1 files changed, 18 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..25867fa
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,18 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "toradex-tegra-layer"
+BBFILE_PATTERN_toradex-tegra-layer = "^${LAYERDIR}/"
+BBFILE_PRIORITY_toradex-tegra-layer = "90"
+
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# Add layer-specific bb files too
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"