summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-01-11 14:49:25 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-03-14 14:26:29 +0100
commite7e8f80cdb41c5ac04a3a250c5de283072a5bfc3 (patch)
treebb12537868f16aec981f38459ce0c933990af081
parent34135bd38177fb56945c329e55b75634891ac856 (diff)
trdx-nv-binaries: drop DEPENDS and ignore build-deps warning
As we inject binary only drivers drop the DEPENDS and skip the checks if all referenced shared objects have been built as a dependency. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes/trdx-nv-binaries/trdx-nv-binaries.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes/trdx-nv-binaries/trdx-nv-binaries.bb b/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
index ef1af59..03fb8d7 100644
--- a/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
+++ b/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
@@ -6,7 +6,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "(tegra)"
PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2"
-DEPENDS = "virtual/xserver libxv gstreamer libpcre alsa-lib gst-plugins-base"
# the khronos headers are taken from here: https://www.khronos.org/registry/khronos_headers.tgz
# this tarball changes from time to time breaking the receipe, thus it is provided with the recipe
@@ -77,8 +76,8 @@ FILES_${PN}-nv-gstapps += " \
#no gnu_hash in NVIDIA binaries, skip QA dev-so for this package
#we have symlinks ending in .so, skip QA ldflags for this package
#inhibit warnings about files being stripped
-INSANE_SKIP_${PN} = "dev-so ldflags already-stripped textrel"
-INSANE_SKIP_${PN}-nv-gstapps = "dev-so ldflags already-stripped textrel file-rdeps"
+INSANE_SKIP_${PN} = "build-deps dev-so ldflags already-stripped textrel"
+INSANE_SKIP_${PN}-nv-gstapps = "build-deps dev-so ldflags already-stripped textrel file-rdeps"
do_patch () {
mkdir -p OpenMAX/il