summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-04-20 14:02:01 +0200
committerStefan Agner <stefan.agner@toradex.com>2018-06-18 09:20:44 +0200
commitdf78aaf49a754e5f70343bd45661661714a7d02a (patch)
tree9099a23954c29215673d279f8fa693b244f4c4d9
parent7da6da579b7d90b7ca6560c880bd3f58ecb73df2 (diff)
u-boot-toradex-fw-utils_git.bb: fix fw_setenv on apalis-tk1-mainline
The eMMC unlocking was missing which lead to the following error message: Write error on /dev/mmcblk0boot0: Operation not permitted Error: can't write fw_env to flash Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index d113524..4bac731 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -68,6 +68,10 @@ do_install_append_tegra124() {
install_unlock_emmc
}
+do_install_append_tegra124m() {
+ install_unlock_emmc
+}
+
pkg_postinst_${PN}_colibri-t20 () {
# can't do this offline
if [ "x$D" != "x" ]; then