summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-01-26 19:07:22 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 12:09:11 +0200
commitc724da634301598ba36acb7ae1933b5caf7184a8 (patch)
treeb60787963cbf3d5ad01fb20071b71eff83dfb9d3
parente04e355523a00c5d6b2872b2398144f54b667381 (diff)
linux: remove bashism from do_configure
pushd and popd are not posix compliant. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_4.9.bb4
-rw-r--r--recipes-kernel/linux/linux-toradex_3.10.40.bb5
-rw-r--r--recipes-kernel/linux/linux-toradex_git.bb4
3 files changed, 7 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline_4.9.bb b/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
index f0ff5fe..b04f29a 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
@@ -39,7 +39,7 @@ config_script () {
}
do_configure_prepend () {
- pushd ${S}
+ cd ${S}
export KBUILD_OUTPUT=${B}
oe_runmake ${KERNEL_DEFCONFIG}
@@ -50,7 +50,7 @@ do_configure_prepend () {
sed -i -e /CONFIG_LOCALVERSION/d ${B}/.config
echo "CONFIG_LOCALVERSION=\"${LOCALVERSION}\"" >> ${B}/.config
- popd
+ cd - > /dev/null
}
do_uboot_mkimage_prepend() {
diff --git a/recipes-kernel/linux/linux-toradex_3.10.40.bb b/recipes-kernel/linux/linux-toradex_3.10.40.bb
index db18ea6..9c9467d 100644
--- a/recipes-kernel/linux/linux-toradex_3.10.40.bb
+++ b/recipes-kernel/linux/linux-toradex_3.10.40.bb
@@ -34,7 +34,7 @@ do_configure_prepend () {
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
DEFCONFIG="`echo ${MACHINE} | sed -e 's/$/_defconfig/'`"
- pushd ${S}
+ cd ${S}
export KBUILD_OUTPUT=${B}
oe_runmake $DEFCONFIG
@@ -48,7 +48,8 @@ do_configure_prepend () {
#Add GIT revision to the local version
head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
printf "%s%s" +g $head > ${S}/.scmversion
- popd
+
+ cd - > /dev/null
}
do_uboot_mkimage_prepend() {
diff --git a/recipes-kernel/linux/linux-toradex_git.bb b/recipes-kernel/linux/linux-toradex_git.bb
index a4eb184..9830cd7 100644
--- a/recipes-kernel/linux/linux-toradex_git.bb
+++ b/recipes-kernel/linux/linux-toradex_git.bb
@@ -28,7 +28,7 @@ do_configure_prepend () {
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
- pushd ${S}
+ cd ${S}
export KBUILD_OUTPUT=${B}
oe_runmake $DEFCONFIG
@@ -43,7 +43,7 @@ do_configure_prepend () {
head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
printf "%s%s" +g $head > ${S}/.scmversion
- popd
+ cd - > /dev/null
}
do_uboot_mkimage_prepend () {