summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-11-27 10:14:51 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-11-29 17:48:18 +0100
commit10ef6699e156c6bb4ddf76456e1f414d2be4241f (patch)
treecd7dd5127bc38bbb5028f1b8699f402eebf42ad4
parentcb0e3087308711972997529b30323e9e96a7115c (diff)
u-boot-toradex: move binary, image and symlink to machine configuration
Move UBOOT_BINARY, UBOOT_IMAGE and UBOOT_SYMLINK definitions to machine configuration re-used by the Toradex Easy Installer U-Boot recipe. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Dominik Sliwa <dominik.sliwa@toradex.com>
-rw-r--r--conf/machine/apalis-tk1-mainline.conf5
-rw-r--r--conf/machine/apalis-tk1.conf5
-rw-r--r--conf/machine/include/tegra-base.inc5
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb5
4 files changed, 15 insertions, 5 deletions
diff --git a/conf/machine/apalis-tk1-mainline.conf b/conf/machine/apalis-tk1-mainline.conf
index 029af6a..6423189 100644
--- a/conf/machine/apalis-tk1-mainline.conf
+++ b/conf/machine/apalis-tk1-mainline.conf
@@ -24,6 +24,11 @@ UBOOT_LOADADDRESS = "${UBOOT_ENTRYPOINT}"
# The payload offsets are given in number of 512 byte blocks.
OFFSET_BOOTROM_PAYLOAD = "0"
+# require u-boot-dtb-tegra.bin to be used
+UBOOT_IMAGE = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
+
PREFERRED_PROVIDER_lxde-icon-theme_apalis-tk1-mainline = "lxde-icon-theme"
PREFERRED_PROVIDER_lxsession-lite_apalis-tk1-mainline = "lxsession"
PREFERRED_PROVIDER_virtual/psplash = "psplash-angstrom"
diff --git a/conf/machine/apalis-tk1.conf b/conf/machine/apalis-tk1.conf
index 02c65b1..d466a2d 100644
--- a/conf/machine/apalis-tk1.conf
+++ b/conf/machine/apalis-tk1.conf
@@ -23,6 +23,11 @@ UBOOT_LOADADDRESS = "${UBOOT_ENTRYPOINT}"
# The payload offsets are given in number of 512 byte blocks.
OFFSET_BOOTROM_PAYLOAD = "0"
+# require u-boot-dtb-tegra.bin to be used
+UBOOT_IMAGE = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
+
PREFERRED_PROVIDER_lxde-icon-theme_apalis-tk1 = "lxde-icon-theme"
PREFERRED_PROVIDER_lxsession-lite_apalis-tk1 = "lxsession"
PREFERRED_PROVIDER_virtual/psplash = "psplash-angstrom"
diff --git a/conf/machine/include/tegra-base.inc b/conf/machine/include/tegra-base.inc
index 145f572..5a3b199 100644
--- a/conf/machine/include/tegra-base.inc
+++ b/conf/machine/include/tegra-base.inc
@@ -19,6 +19,11 @@ RDEPENDS_kernel-base = ""
PREFERRED_PROVIDER_u-boot = "u-boot-toradex"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex"
+# require u-boot-dtb-tegra.bin to be used
+UBOOT_IMAGE = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
+
PREFERRED_PROVIDER_virtual/mesa = "mesa"
PREFERRED_PROVIDER_virtual/egl = "tdx-nv-binaries"
PREFERRED_PROVIDER_virtual/libgles1 = "tdx-nv-binaries"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index b8f1928..b86430f 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -37,11 +37,6 @@ SRC_URI_append_apalis-tk1-mainline = " \
PV = "2016.11"
PR = "${TDX_VER_INT}+gitr${SRCPV}"
-# require u-boot-dtb-tegra.bin to be used
-UBOOT_IMAGE = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
-UBOOT_BINARY = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
-UBOOT_SYMLINK = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
-
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_deploy_append_apalis-tk1() {