summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-08-15 18:11:34 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-08-15 18:11:34 +0200
commitfed17a27bb8dcaefd90b400602df3d19c018c4b9 (patch)
treef28ad96890b141c2238b204116148d3257ea7a5e
parent5739551f9517b4b1af153f81b2e13decd0265d3d (diff)
L4T R15, oe-core Image V2.0Beta1
-rw-r--r--conf/machine/colibri-t20.conf24
-rw-r--r--recipes-bsp/alsa-state/alsa-state.bbappend3
-rw-r--r--recipes-bsp/alsa-state/alsa-state/colibri-t20/asound.state922
-rw-r--r--recipes-bsp/alsa-state/alsa-state/gaga1
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.06.bbappend4
-rw-r--r--recipes-kernel/linux/linux-colibri-t20_git.bb5
-rw-r--r--recipes-lxde/lxpanel/lxpanel_0.5.8.bbappend4
-rw-r--r--recipes/trdx-nv-binaries/files/nvsamples-oe.patch51
-rw-r--r--recipes/trdx-nv-binaries/nvsamples.bb47
-rw-r--r--recipes/trdx-nv-binaries/trdx-nv-binaries.bb3
-rw-r--r--recipes/xorg-xserver/files/crash-hack.patch11
-rw-r--r--recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend6
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend4
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend4
14 files changed, 1059 insertions, 30 deletions
diff --git a/conf/machine/colibri-t20.conf b/conf/machine/colibri-t20.conf
index 1dcb93e..3c6a1b1 100644
--- a/conf/machine/colibri-t20.conf
+++ b/conf/machine/colibri-t20.conf
@@ -22,28 +22,8 @@ MACHINE_GUI_CLASS = "bigscreen"
PREFERRED_PROVIDER_lxde-icon-theme_colibri-t20 = "lxde-icon-theme"
PREFERRED_PROVIDER_lxsession-lite_colibri-t20 = "lxsession"
-#PREFERRED_PROVIDER_gdbserver_colibri-t20 = "gdbserver"
-#PREFERRED_PROVIDER_libgobject-2.0_colibri-t20 = "glib-2.0"
-#PREFERRED_PROVIDER_libgmodule-2.0_colibri-t20 = "glib-2.0"
-#PREFERRED_PROVIDER_libgthread-2.0_colibri-t20 = "glib-2.0"
-#PREFERRED_PROVIDER_libgio-2.0_colibri-t20 = "glib-2.0"
-#PREFERRED_VERSION_libgobject-2.0_colibri-t20 = "2.30.1"
-#PREFERRED_VERSION_libgmodule-2.0_colibri-t20 = "2.30.1"
-#PREFERRED_VERSION_libgthread-2.0_colibri-t20 = "2.30.1"
-#PREFERRED_VERSION_libgio-2.0_colibri-t20 = "2.30.1"
-
-#PREFERRED_VERSION_samba_colibri-t20 = "3.6.1"
-#PREFERRED_VERSION_glib-2.0_colibri-t20 = "2.30.1"
-#PREFERRED_VERSION_glib-2.0-native_colibri-t20 = "2.30.1"
-#PREFERRED_VERSION_gtk+_colibri-t20 = "2.24.8"
-#PREFERRED_VERSION_gtk+-native_colibri-t20 = "2.24.8"
-#PREFERRED_VERSION_pango_colibri-t20 = "1.29.4"
-#PREFERRED_VERSION_pango-native_colibri-t20 = "1.29.4"
-
-#ANGSTROM_GCC_VERSION_colibri-t20 = "4.4.4"
-#fix for csl 4.4.1 toolchain not beeing recent enough
-#PREFERRED_VERSION_eglibc ?= "2.10"
-#PREFERRED_VERSION_eglibc-initial ?= "2.10"
+PREFERRED_PROVIDER_virtual/psplash = "psplash-angstrom"
+PREFERRED_PROVIDER_psplash-support = "psplash-angstrom"
MACHINE_FEATURES = "kernel26 screen usbgadget usbhost vfat ext2 alsa touchscreen ethernet"
EXTRA_IMAGEDEPENDS += "u-boot"
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend
new file mode 100644
index 0000000..2065b80
--- /dev/null
+++ b/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -0,0 +1,3 @@
+PRINC = "6"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/alsa-state/:"
diff --git a/recipes-bsp/alsa-state/alsa-state/colibri-t20/asound.state b/recipes-bsp/alsa-state/alsa-state/colibri-t20/asound.state
new file mode 100644
index 0000000..7d61d15
--- /dev/null
+++ b/recipes-bsp/alsa-state/alsa-state/colibri-t20/asound.state
@@ -0,0 +1,922 @@
+state.colibrit20wm971 {
+ control.1 {
+ iface MIXER
+ name 'Speaker Playback Volume'
+ value.0 24
+ value.1 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ }
+ }
+ control.2 {
+ iface MIXER
+ name 'Speaker Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.3 {
+ iface MIXER
+ name 'Headphone Playback Volume'
+ value.0 24
+ value.1 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ }
+ }
+ control.4 {
+ iface MIXER
+ name 'Headphone Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.5 {
+ iface MIXER
+ name 'PCM Playback Volume'
+ value.0 24
+ value.1 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ }
+ }
+ control.6 {
+ iface MIXER
+ name 'Speaker Playback ZC Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.7 {
+ iface MIXER
+ name 'Speaker Playback Invert Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.8 {
+ iface MIXER
+ name 'Headphone Playback ZC Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.9 {
+ iface MIXER
+ name 'Mono Playback ZC Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.10 {
+ iface MIXER
+ name 'Mono Playback Volume'
+ value 24
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 31'
+ }
+ }
+ control.11 {
+ iface MIXER
+ name 'Mono Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.12 {
+ iface MIXER
+ name 'ALC Target Volume'
+ value 11
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.13 {
+ iface MIXER
+ name 'ALC Hold Time'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.14 {
+ iface MIXER
+ name 'ALC Decay Time'
+ value 3
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.15 {
+ iface MIXER
+ name 'ALC Attack Time'
+ value 2
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.16 {
+ iface MIXER
+ name 'ALC Function'
+ value None
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 None
+ item.1 Left
+ item.2 Right
+ item.3 Stereo
+ }
+ }
+ control.17 {
+ iface MIXER
+ name 'ALC Max Volume'
+ value 7
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.18 {
+ iface MIXER
+ name 'ALC ZC Timeout'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 3'
+ }
+ }
+ control.19 {
+ iface MIXER
+ name 'ALC ZC Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.20 {
+ iface MIXER
+ name 'ALC NG Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.21 {
+ iface MIXER
+ name 'ALC NG Type'
+ value 'Constant Gain'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Constant Gain'
+ item.1 Mute
+ }
+ }
+ control.22 {
+ iface MIXER
+ name 'ALC NG Threshold'
+ value 31
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 31'
+ }
+ }
+ control.23 {
+ iface MIXER
+ name 'Mic Headphone Volume'
+ value 4
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.24 {
+ iface MIXER
+ name 'ALC Headphone Volume'
+ value 5
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.25 {
+ iface MIXER
+ name 'Out3 Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.26 {
+ iface MIXER
+ name 'Out3 ZC Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.27 {
+ iface MIXER
+ name 'Out3 Volume'
+ value 31
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 31'
+ }
+ }
+ control.28 {
+ iface MIXER
+ name 'PCBeep Bypass Headphone Volume'
+ value 5
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.29 {
+ iface MIXER
+ name 'PCBeep Bypass Speaker Volume'
+ value 5
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.30 {
+ iface MIXER
+ name 'PCBeep Bypass Phone Volume'
+ value 5
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.31 {
+ iface MIXER
+ name 'Aux Playback Headphone Volume'
+ value 5
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.32 {
+ iface MIXER
+ name 'Aux Playback Speaker Volume'
+ value 5
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.33 {
+ iface MIXER
+ name 'Aux Playback Phone Volume'
+ value 5
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 7'
+ }
+ }
+ control.34 {
+ iface MIXER
+ name 'Phone Volume'
+ value 7
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.35 {
+ iface MIXER
+ name 'Line Capture Volume'
+ value.0 23
+ value.1 23
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ }
+ }
+ control.36 {
+ iface MIXER
+ name 'Capture 20dB Boost Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.37 {
+ iface MIXER
+ name 'Capture to Phone 20dB Boost Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.38 {
+ iface MIXER
+ name '3D Upper Cut-off Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.39 {
+ iface MIXER
+ name '3D Lower Cut-off Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.40 {
+ iface MIXER
+ name '3D Playback Volume'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.41 {
+ iface MIXER
+ name 'Bass Control'
+ value 'Linear Control'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Linear Control'
+ item.1 'Adaptive Boost'
+ }
+ }
+ control.42 {
+ iface MIXER
+ name 'Bass Cut-off Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.43 {
+ iface MIXER
+ name 'Tone Cut-off Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.44 {
+ iface MIXER
+ name 'Playback Attenuate (-6dB) Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.45 {
+ iface MIXER
+ name 'Bass Volume'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.46 {
+ iface MIXER
+ name 'Treble Volume'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 15'
+ }
+ }
+ control.47 {
+ iface MIXER
+ name 'Capture ADC Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.48 {
+ iface MIXER
+ name 'Capture Volume Steps'
+ value.0 '+1.5dB Steps'
+ value.1 '+1.5dB Steps'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 2
+ item.0 '+1.5dB Steps'
+ item.1 '+0.75dB Steps'
+ }
+ }
+ control.49 {
+ iface MIXER
+ name 'Capture Volume'
+ value.0 48
+ value.1 48
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 63'
+ }
+ }
+ control.50 {
+ iface MIXER
+ name 'Capture ZC Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.51 {
+ iface MIXER
+ name 'Mic 1 Volume'
+ value 23
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 31'
+ }
+ }
+ control.52 {
+ iface MIXER
+ name 'Mic 2 Volume'
+ value 23
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 31'
+ }
+ }
+ control.53 {
+ iface MIXER
+ name 'Mic 20dB Boost Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.54 {
+ iface MIXER
+ name 'Speaker Mixer PCBeep Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.55 {
+ iface MIXER
+ name 'Speaker Mixer Aux Playback Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.56 {
+ iface MIXER
+ name 'Speaker Mixer Phone Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.57 {
+ iface MIXER
+ name 'Speaker Mixer Line Bypass Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.58 {
+ iface MIXER
+ name 'Speaker Mixer PCM Playback Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.59 {
+ iface MIXER
+ name 'Phone Mixer PCBeep Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.60 {
+ iface MIXER
+ name 'Phone Mixer Aux Playback Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.61 {
+ iface MIXER
+ name 'Phone Mixer Line Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.62 {
+ iface MIXER
+ name 'Phone Mixer PCM Playback Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.63 {
+ iface MIXER
+ name 'Phone Mixer Mic 1 Sidetone Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.64 {
+ iface MIXER
+ name 'Phone Mixer Mic 2 Sidetone Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.65 {
+ iface MIXER
+ name 'Right HP Mixer PCBeep Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.66 {
+ iface MIXER
+ name 'Right HP Mixer Aux Playback Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.67 {
+ iface MIXER
+ name 'Right HP Mixer Phone Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.68 {
+ iface MIXER
+ name 'Right HP Mixer Line Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.69 {
+ iface MIXER
+ name 'Right HP Mixer PCM Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.70 {
+ iface MIXER
+ name 'Right HP Mixer Mic Sidetone Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.71 {
+ iface MIXER
+ name 'Left HP Mixer PCBeep Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.72 {
+ iface MIXER
+ name 'Left HP Mixer Aux Playback Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.73 {
+ iface MIXER
+ name 'Left HP Mixer Phone Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.74 {
+ iface MIXER
+ name 'Left HP Mixer Line Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.75 {
+ iface MIXER
+ name 'Left HP Mixer PCM Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.76 {
+ iface MIXER
+ name 'Left HP Mixer Mic Sidetone Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.77 {
+ iface MIXER
+ name 'Differential Source'
+ value Mic
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Mic
+ item.1 Line
+ }
+ }
+ control.78 {
+ iface MIXER
+ name 'Mic Select Source'
+ value 'Mic 1'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Mic 1'
+ item.1 Differential
+ item.2 'Mic 2'
+ item.3 Stereo
+ }
+ }
+ control.79 {
+ iface MIXER
+ name 'Right Capture Select'
+ value Mic
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Mic
+ item.1 NC
+ item.2 NC
+ item.3 'Speaker Mixer'
+ item.4 Line
+ item.5 'Headphone Mixer'
+ item.6 'Phone Mixer'
+ item.7 Phone
+ }
+ }
+ control.80 {
+ iface MIXER
+ name 'Left Capture Select'
+ value Mic
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Mic
+ item.1 NC
+ item.2 NC
+ item.3 'Speaker Mixer'
+ item.4 Line
+ item.5 'Headphone Mixer'
+ item.6 'Phone Mixer'
+ item.7 Phone
+ }
+ }
+ control.81 {
+ iface MIXER
+ name 'Capture Phone Mux'
+ value Mute
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Stereo
+ item.1 Left
+ item.2 Right
+ item.3 Mute
+ }
+ }
+ control.82 {
+ iface MIXER
+ name 'Speaker Mux'
+ value 'Speaker Mix'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Speaker Mix'
+ item.1 'Headphone Mix'
+ }
+ }
+ control.83 {
+ iface MIXER
+ name 'Out3 Mux'
+ value Left
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Left
+ item.1 VREF
+ item.2 'Left + Right'
+ item.3 Mono
+ }
+ }
+ control.84 {
+ iface MIXER
+ name 'ALC Sidetone Mux'
+ value None
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 Stereo
+ item.1 Left
+ item.2 Right
+ item.3 None
+ }
+ }
+}
diff --git a/recipes-bsp/alsa-state/alsa-state/gaga b/recipes-bsp/alsa-state/alsa-state/gaga
new file mode 100644
index 0000000..6c604cf
--- /dev/null
+++ b/recipes-bsp/alsa-state/alsa-state/gaga
@@ -0,0 +1 @@
+hu \ No newline at end of file
diff --git a/recipes-bsp/u-boot/u-boot_2011.06.bbappend b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
index ec7b4f6..27c3c61 100644
--- a/recipes-bsp/u-boot/u-boot_2011.06.bbappend
+++ b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
@@ -34,8 +34,8 @@ PV_colibri-t30 = "${PR}+gitr${SRCREV}"
# internal SVN #####################################################################################################################
S = "${WORKDIR}/bootloader/u-boot"
-SRCREV_COLIBRI = "320"
-SRC_URI_COLIBRI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=bootloader/u-boot;rev=${SRCREV_COLIBRI};proto=http \
+SRCREV_COLIBRI = "321"
+SRC_URI_COLIBRI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=bootloader/u-boot;rev=${SRCREV_COLIBRI};protocol=http \
"
#####################################################################################################################
diff --git a/recipes-kernel/linux/linux-colibri-t20_git.bb b/recipes-kernel/linux/linux-colibri-t20_git.bb
index d3c0d7d..a461544 100644
--- a/recipes-kernel/linux/linux-colibri-t20_git.bb
+++ b/recipes-kernel/linux/linux-colibri-t20_git.bb
@@ -7,7 +7,10 @@ LINUX_VERSION ?= "3.1.10"
#L4T R15 first run
#SRCREV = "4f48c4961b86b4df1bcb4b1b535bc1c3d158b5af"
#L4T R15, optimized config, bcm4329 warnings removed
-SRCREV = "b562b12b12ba303d5ceca17b347d8c506e18f7f4"
+#SRCREV = "b562b12b12ba303d5ceca17b347d8c506e18f7f4"
+#Nand timings for 1.1, asix driver update, asix driver patch autodetach
+SRCREV = "4dec0ae6f55768ba0acef97ff2c67f7d5d4663fe"
+
PV = "${LINUX_VERSION}+gitr${SRCREV}"
PR = "V2.0b1"
diff --git a/recipes-lxde/lxpanel/lxpanel_0.5.8.bbappend b/recipes-lxde/lxpanel/lxpanel_0.5.8.bbappend
new file mode 100644
index 0000000..5c21d6a
--- /dev/null
+++ b/recipes-lxde/lxpanel/lxpanel_0.5.8.bbappend
@@ -0,0 +1,4 @@
+PRINC = "1"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
diff --git a/recipes/trdx-nv-binaries/files/nvsamples-oe.patch b/recipes/trdx-nv-binaries/files/nvsamples-oe.patch
new file mode 100644
index 0000000..001c162
--- /dev/null
+++ b/recipes/trdx-nv-binaries/files/nvsamples-oe.patch
@@ -0,0 +1,51 @@
+diff -Naur nvsamples-1.0-r0.orig/nvsamples/make/nvdefs.mk nvsamples-1.0-r0/nvsamples/make/nvdefs.mk
+--- nvsamples/make/nvdefs.mk.orig 2011-12-07 10:22:49.000000000 +0100
++++ nvsamples/make/nvdefs.mk 2012-07-07 12:37:13.000000000 +0200
+@@ -1,4 +1,4 @@
+-NV_TOPDIR = $(HOME)/nvsamples
++NV_TOPDIR = $(WORKDIR)/nvsamples
+ NV_PLATFORM_DIR = $(NV_TOPDIR)
+ NV_KERNDIR = $(NV_TOPDIR)/../kernel
+
+@@ -42,17 +42,13 @@
+ NV_PLATFORM_CPPFLAGS += -DKD
+ endif
+
+-NV_PLATFORM_LDFLAGS =
++NV_PLATFORM_LDFLAGS = -L/usr/X11R6.4/lib -lX11 -lICE -lSM
+
+ NV_PLATFORM_SDK_INC_DIR = $(NV_TOPDIR)/include
+ NV_PLATFORM_SDK_LIB_DIR = $(NV_TOPDIR)/lib-target
+-ROOTFS_LIB_DIR = $(NV_TOPDIR)/../T20_LinuxImageV1.0Beta4/rootfs/usr/lib
+
+ NV_PLATFORM_SDK_INC = -I$(NV_PLATFORM_SDK_INC_DIR)
+-NV_PLATFORM_SDK_LIB = -L$(NV_PLATFORM_SDK_LIB_DIR) \
+- -L$(ROOTFS_LIB_DIR) \
+- -Xlinker -rpath-link \
+- -Xlinker $(ROOTFS_LIB_DIR)
++NV_PLATFORM_SDK_LIB = -L$(NV_PLATFORM_SDK_LIB_DIR)
+ NV_PLATFORM_OPT = -Os -O2
+ NV_PLATFORM_MATHLIB = -lm
+ NV_PLATFORM_THREADLIB = -lpthread
+@@ -80,13 +76,13 @@
+
+ # compiler utilities
+
+-CROSSBIN = $(NV_TOPDIR)/../arm-2009q3/bin/arm-none-linux-gnueabi-
+-CC = $(CROSSBIN)gcc
+-CXX = $(CROSSBIN)g++
+-LD = $(CROSSBIN)gcc
+-AR = $(CROSSBIN)ar
+-RANLIB = $(CROSSBIN)ranlib
+-STRIP = $(CROSSBIN)strip
++CROSSBIN = arm-angstrom-linux-gnueabi-
++CC ?= $(CROSSBIN)gcc
++CXX ?= $(CROSSBIN)g++
++LD = $(CC)
++AR ?= $(CROSSBIN)ar
++RANLIB ?= $(CROSSBIN)ranlib
++STRIP ?= $(CROSSBIN)strip
+
+ NV_CGDIR = $(NV_TOPDIR)/utils/Cg
+ HEXIFY = $(NV_CGDIR)/hexify.pl
+Datei nvsamples-1.0-r0.orig/pseudo/pseudo.socket ist ein socket wÀhrend Datei nvsamples-1.0-r0/pseudo/pseudo.socket ein socket ist.
diff --git a/recipes/trdx-nv-binaries/nvsamples.bb b/recipes/trdx-nv-binaries/nvsamples.bb
new file mode 100644
index 0000000..d24b82e
--- /dev/null
+++ b/recipes/trdx-nv-binaries/nvsamples.bb
@@ -0,0 +1,47 @@
+SECTION = "graphical/utils"
+DESCRIPTION = "Nvidia samples for OpenGL ES, OpenGL ES headers"
+LICENSE = "CLOSED"
+DEPENDS = "trdx-nv-binaries"
+RDEPENDS = "trdx-nv-binaries"
+
+PR = "r0"
+
+SRC_URI = "http://developer.toradex.com/files/toradex-dev/uploads/media/Colibri/Linux/Samples/nvsamples.tar.bz2 \
+ file://nvsamples-oe.patch \
+"
+
+S = "${WORKDIR}/nvsamples"
+
+SRC_URI[md5sum] = "240b0beb0056dde2e6ac1538dc8b6684"
+SRC_URI[sha256sum] = "2638beea80fd85fdc5f9443e6959c210e275e627f662266cd404ce7c68b0806d"
+
+#no gnu_hash in NVIDIA binaries, skip QA for this package
+INSANE_SKIP_${PN} = "dev-so ldflags"
+
+FILES_${PN} += " \
+ /home/root/textures/* \
+"
+
+do_compile () {
+ cd ${S}/samples/opengles2
+ oe_runmake clean
+ oe_runmake WORKDIR=${WORKDIR}
+}
+
+do_install () {
+# install the sample code
+ install -d ${D}${bindir}
+ install -d ${D}/home/root/textures
+ install -m 0755 ${S}/samples/opengles2/ctree/ctree ${D}${bindir}
+ install -m 0644 ${S}/samples/opengles2/ctree/textures/* ${D}/home/root/textures
+ install -m 0755 ${S}/samples/opengles2/bubble/bubble ${D}${bindir}
+ install -m 0644 ${S}/samples/opengles2/bubble/textures/* ${D}/home/root/textures
+ install -m 0755 ${S}/samples/opengles2/gears/gears ${D}${bindir}
+
+# export OpenGL ES headers
+ for dir in EGL GLES2 KD KHR OpenMAX/il OpenMAX/ilclient
+ do
+ install -d ${D}${includedir}/$dir
+ install -m 0644 ${S}/include/$dir/* ${D}${includedir}/$dir
+ done
+} \ No newline at end of file
diff --git a/recipes/trdx-nv-binaries/trdx-nv-binaries.bb b/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
index a9aa513..ee9c8e1 100644
--- a/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
+++ b/recipes/trdx-nv-binaries/trdx-nv-binaries.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "binary files from Nvidia along with there configuration"
LICENSE = "CLOSED"
-PR = "r3"
+PR = "r4"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -49,6 +49,7 @@ do_install_colibri-t20 () {
install -m 0644 ${WORKDIR}/mimeapps.list ${D}//home/root/.local/share/applications/
install -m 0644 ${WORKDIR}/nvgstplayer.desktop ${D}/home/root/.local/share/applications/
ln -s libpcre.so.0.0.1 ${D}/usr/lib/libpcre.so.3
+ ln -s libpcreposix.so.0.0.0 ${D}/usr/lib/libpcreposix.so.3
ln -s tegra_drv.abi11.so ${D}/usr/lib/xorg/modules/drivers/tegra_drv.so
ln -s libGLESv2.so ${D}/usr/lib//libGLESv2.so.2
ln -s libEGL.so ${D}/usr/lib/libEGL.so.1
diff --git a/recipes/xorg-xserver/files/crash-hack.patch b/recipes/xorg-xserver/files/crash-hack.patch
new file mode 100644
index 0000000..0053a10
--- /dev/null
+++ b/recipes/xorg-xserver/files/crash-hack.patch
@@ -0,0 +1,11 @@
+--- xorg-server-1.11.2/miext/damage/damage.c~ 2011-04-24 06:54:03.000000000 +0200
++++ xorg-server-1.11.2/miext/damage/damage.c 2012-07-27 12:12:00.012473812 +0200
+@@ -596,6 +596,8 @@
+ ScreenPtr pScreen = pDst->pDrawable->pScreen;
+ PictureScreenPtr ps = GetPictureScreen(pScreen);
+ damageScrPriv(pScreen);
++ //ugly hack, the xserver crashes when gtk programs use some fancy font rendering, this prevents this
++ maskFormat = 0;
+
+ if (checkPictureDamage (pDst))
+ {
diff --git a/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend
index 1615df3..883a3c2 100644
--- a/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/recipes/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -1,5 +1,3 @@
-PRINC = "2"
-
-THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
-FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+PRINC = "3"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend b/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend
new file mode 100644
index 0000000..77e6079
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.10.1.bbappend
@@ -0,0 +1,4 @@
+# Ugly temporary hack to have Xserver not segfaulting
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://xserver-instrumented.patch;pnum=2"
diff --git a/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
new file mode 100644
index 0000000..44ae424
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -0,0 +1,4 @@
+# Ugly temporary hack to have Xserver not segfaulting
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://crash-hack.patch"