summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-03-06 08:25:54 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-06-30 21:43:57 +0200
commit0dcd3213ce45ffe7c461922d38f60246d882f058 (patch)
treebf05c619d5887ef073f5e3f777133e94078d9837
parent081c48a19c473ad9b55e3efc8b4923714ed24cf4 (diff)
libcryptopp: update to 5.6.4
- License has changed - For target builds a versioned shared object is now created Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch39
-rw-r--r--recipes-support/libcryptopp/libcryptopp-5.6.4/0001-Fix-cross-compilation.patch41
-rw-r--r--recipes-support/libcryptopp/libcryptopp-5.6.4/makefile_fix_destdir.patch (renamed from recipes-support/libcryptopp/libcryptopp-5.6.3/makefile_fix_destdir.patch)0
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.4.bb (renamed from recipes-support/libcryptopp/libcryptopp_5.6.3.bb)32
4 files changed, 56 insertions, 56 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch b/recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch
deleted file mode 100644
index d69e12d..0000000
--- a/recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 1306eabf258f0e9ce8586b7816406a21683d529d Mon Sep 17 00:00:00 2001
-From: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-Date: Wed, 8 Jun 2016 14:23:29 +0200
-Subject: [PATCH] Fix cross compilation
-
-Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
----
- GNUmakefile | 15 ---------------
- 1 file changed, 15 deletions(-)
-
-diff --git a/GNUmakefile b/GNUmakefile
-index 3bc76a4..f71d990 100755
---- a/GNUmakefile
-+++ b/GNUmakefile
-@@ -73,21 +73,6 @@ ifneq ($(IS_X86_64),0)
- endif
- endif
-
--# Guard use of -march=native
--ifeq ($(GCC_COMPILER),0)
-- CXXFLAGS += -march=native
--else ifneq ($(GCC42_OR_LATER),0)
-- CXXFLAGS += -march=native
--else
-- # GCC 3.3 and "unknown option -march="
-- # GCC 4.1 compiler crash with -march=native.
-- ifneq ($(IS_X86_64),0)
-- CXXFLAGS += -m64
-- else
-- CXXFLAGS += -m32
-- endif # X86/X32/X64
--endif
--
- # Aligned access required at -O3 for GCC due to vectorization (circa 08/2008). Expect other compilers to do the same.
- UNALIGNED_ACCESS := $(shell $(EGREP) -c "^[[:space:]]*//[[:space:]]*\#[[:space:]]*define[[:space:]]*CRYPTOPP_NO_UNALIGNED_DATA_ACCESS" config.h)
- ifeq ($(findstring -O3,$(CXXFLAGS)),-O3)
---
-2.5.5
-
diff --git a/recipes-support/libcryptopp/libcryptopp-5.6.4/0001-Fix-cross-compilation.patch b/recipes-support/libcryptopp/libcryptopp-5.6.4/0001-Fix-cross-compilation.patch
new file mode 100644
index 0000000..f40c8b3
--- /dev/null
+++ b/recipes-support/libcryptopp/libcryptopp-5.6.4/0001-Fix-cross-compilation.patch
@@ -0,0 +1,41 @@
+From 896f33dc459a7c699a1f4061e5fcca3555e135a0 Mon Sep 17 00:00:00 2001
+From: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+Date: Wed, 8 Jun 2016 14:23:29 +0200
+Subject: [PATCH] Fix cross compilation
+
+Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+---
+ GNUmakefile | 17 -----------------
+ 1 file changed, 17 deletions(-)
+
+diff --git a/GNUmakefile b/GNUmakefile
+index 4de9d10..d053e94 100755
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -125,23 +125,6 @@ ifeq ($(IS_X86)$(IS_X32)$(IS_CYGWIN)$(IS_MINGW)$(SUN_COMPILER),00000)
+ endif
+ endif
+
+-# Guard use of -march=native
+-ifeq ($(GCC42_OR_LATER)$(IS_NETBSD),10)
+- CXXFLAGS += -march=native
+-else ifneq ($(CLANG_COMPILER)$(INTEL_COMPILER),00)
+- CXXFLAGS += -march=native
+-else
+- # GCC 3.3 and "unknown option -march="
+- # Ubuntu GCC 4.1 compiler crash with -march=native
+- # NetBSD GCC 4.8 compiler and "bad value (native) for -march= switch"
+- # Sun compiler is handled below
+- ifeq ($(SUN_COMPILER)$(IS_X64),01)
+- CXXFLAGS += -m64
+- else ifeq ($(SUN_COMPILER)$(IS_X86),01)
+- CXXFLAGS += -m32
+- endif # X86/X32/X64
+-endif
+-
+ # Aligned access required for -O3 and above due to vectorization
+ UNALIGNED_ACCESS := $(shell $(EGREP) -c "^[[:space:]]*//[[:space:]]*\#[[:space:]]*define[[:space:]]*CRYPTOPP_NO_UNALIGNED_DATA_ACCESS" config.h)
+ ifneq ($(UNALIGNED_ACCESS),0)
+--
+2.6.6
+
diff --git a/recipes-support/libcryptopp/libcryptopp-5.6.3/makefile_fix_destdir.patch b/recipes-support/libcryptopp/libcryptopp-5.6.4/makefile_fix_destdir.patch
index 9d57fe3..9d57fe3 100644
--- a/recipes-support/libcryptopp/libcryptopp-5.6.3/makefile_fix_destdir.patch
+++ b/recipes-support/libcryptopp/libcryptopp-5.6.4/makefile_fix_destdir.patch
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.3.bb b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
index 9b7b67e..89514e6 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.3.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.4.bb
@@ -3,8 +3,8 @@ HOMEPAGE = "http://www.cryptopp.com/wiki/Main_Page"
BUGTRACKER = "http://sourceforge.net/apps/trac/cryptopp/"
SECTION = "libs"
-LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://License.txt;md5=48e7e415ea7fcc35278d8e7dc8e70b5d"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://License.txt;md5=deb6d182b0f7f8a866c42941b9f014c4"
BBCLASSEXTEND = "native nativesdk"
@@ -12,11 +12,11 @@ PR = "r1"
PVSHORT = "${@'${PV}'.replace('.','')}"
SRC_URI = " \
- https://sourceforge.net/projects/cryptopp/files/cryptopp/5.6.3/cryptopp563.zip;subdir=libcryptopp-${PV} \
+ https://sourceforge.net/projects/cryptopp/files/cryptopp/5.6.4/cryptopp564.zip;subdir=libcryptopp-${PV} \
file://0001-Fix-cross-compilation.patch \
"
-SRC_URI[md5sum] = "3c5b70e2ec98b7a24988734446242d07"
-SRC_URI[sha256sum] = "9390670a14170dd0f48a6b6b06f74269ef4b056d4718a1a329f6f6069dc957c9"
+SRC_URI[md5sum] = "4ee7e5cdd4a45a14756c169eaf2a77fc"
+SRC_URI[sha256sum] = "be430377b05c15971d5ccb6e44b4d95470f561024ed6d701fe3da3a188c84ad7"
inherit autotools-brokensep pkgconfig
@@ -24,6 +24,7 @@ PACKAGES_prepend = "${PN}-test "
EXTRA_OECONF = "--libdir=${base_libdir}"
TARGET_CC_ARCH += "${LDFLAGS}"
+export PREFIX="${prefix}"
#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32'"
@@ -34,17 +35,14 @@ do_compile() {
oe_runmake all libcryptopp.so
}
-do_install_prepend() {
- export PREFIX=${D}${prefix}
-}
-
-do_install_append() {
- if [ -f "${D}/usr/lib/libcryptopp.so" ] && [ ! -e "${D}/usr/lib/libcryptopp.so.${PV}" ]
- then
- mv ${D}/usr/lib/libcryptopp.so ${D}/usr/lib/libcryptopp.so.${PV}
- ln -fs libcryptopp.so.${PV} ${D}/usr/lib/libcryptopp.so.5
- ln -fs libcryptopp.so.${PV} ${D}/usr/lib/libcryptopp.so
- fi
+# do not provide the shared object file, so we force to link statically for host tools
+do_compile_class-native() {
+ sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
+ export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
+ oe_runmake all
}
-FILES_${PN}-test = "${bindir}"
+FILES_${PN}-test = " \
+ ${bindir} \
+ ${datadir}/cryptopp \
+"