summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-07-11 17:51:23 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-07-22 11:22:11 +0200
commit4ec07ea80566b957d5c693a33742282841c541d5 (patch)
tree4ae924ef52f3ff726eb7659baadbe3476a40a136
parentbd4f06ba3f4ca20a6301de1e220692c22e38a87b (diff)
linux-driver-package: fix commit rework to allow building for SysV
commit 8691ba636cb2 allowed to also use SysV init. However, if only systemd is configured in DISTRO_FEATURES the content of /etc/init.d is deleted after the install step. This results in the scripts nv and nvfb not being present. Fix this by installing them additionally in /usr/bin so that the systemd service can call them. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/binary-drivers/linux-driver-package/nv.service5
-rw-r--r--recipes-bsp/binary-drivers/linux-driver-package/nvfb.service4
-rw-r--r--recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend4
3 files changed, 8 insertions, 5 deletions
diff --git a/recipes-bsp/binary-drivers/linux-driver-package/nv.service b/recipes-bsp/binary-drivers/linux-driver-package/nv.service
index 3fab9b2..c6fa901 100644
--- a/recipes-bsp/binary-drivers/linux-driver-package/nv.service
+++ b/recipes-bsp/binary-drivers/linux-driver-package/nv.service
@@ -13,6 +13,5 @@ IgnoreSIGPIPE=no
KillMode=process
GuessMainPID=no
RemainAfterExit=yes
-ExecStart=/etc/init.d/nv start
-ExecStop=/etc/init.d/nv stop
-
+ExecStart=/usr/bin/nv start
+ExecStop=/usr/bin/nv stop
diff --git a/recipes-bsp/binary-drivers/linux-driver-package/nvfb.service b/recipes-bsp/binary-drivers/linux-driver-package/nvfb.service
index 4d923da..deb8d97 100644
--- a/recipes-bsp/binary-drivers/linux-driver-package/nvfb.service
+++ b/recipes-bsp/binary-drivers/linux-driver-package/nvfb.service
@@ -13,5 +13,5 @@ IgnoreSIGPIPE=no
KillMode=process
GuessMainPID=no
RemainAfterExit=yes
-ExecStart=/etc/init.d/nvfb start
-ExecStop=/etc/init.d/nvfb stop
+ExecStart=/usr/bin/nvfb start
+ExecStop=/usr/bin/nvfb stop
diff --git a/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend b/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
index 73fa967..6757da0 100644
--- a/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
+++ b/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
@@ -15,6 +15,8 @@ do_install_append_apalis-tk1 () {
install -d ${D}${systemd_unitdir}/system/
install -m 0755 ${WORKDIR}/nvfb.service ${D}${systemd_unitdir}/system
install -m 0755 ${WORKDIR}/nv.service ${D}${systemd_unitdir}/system
+ install -m 0755 ${WORKDIR}/nv ${D}${bindir}
+ install -m 0755 ${WORKDIR}/nvfb ${D}${bindir}
}
# deploy additional binaries from the nv_gst_apps tarball
@@ -57,10 +59,12 @@ FILES_${PN}-nvgstapps = " \
"
FILES_${PN}-boot += " \
+ ${bindir}/nv \
${systemd_unitdir}/system/nv.service \
"
FILES_${PN}-firstboot += "\
+ ${bindir}/nvfb \
${systemd_unitdir}/system/nvfb.service \
"