summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2020-04-10 05:01:19 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2020-04-10 06:02:59 +0200
commit5d206eb3265bc6bc96442ffcd1cc4ce1f80f0714 (patch)
tree1a64e1ca1e4c078439bf9f625258e0d63e45218c
parent222ccc53f8cfdebfdea88540077a98fef54d2a45 (diff)
linux-driver-package: fix direct-loading firmware
Debugging reveals that it is really also expecting certain firmware at the original path: [ 134.878913] firmware tegra12x!vic03_ucode.bin: firmware: requesting tegra12x/vic03_ucode.bin So make a symbolic link rather then copying them. Without older systemd's firmware usermode helper fallback in place using an alternative file name leads to a very long timeout. Fix this by linking the alternative nameed firmware to the one tried first. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rwxr-xr-xrecipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb b/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb
index 61de820..3111684 100755
--- a/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb
+++ b/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb
@@ -57,7 +57,8 @@ do_patch () {
do_install () {
tar xjf ${WORKDIR}/Linux_for_Tegra/nv_tegra/nvidia_drivers.tbz2 -C ${D}
- mv ${D}/lib/firmware/tegra12x ${D}/lib/firmware/gk20a
+ ln -sf tegra12x ${D}/lib/firmware/gk20a
+ ln -sf nvavp_vid_ucode_alt.bin ${D}/lib/firmware/nvavp_vid_ucode.bin
cp -r ${WORKDIR}/tegra_xusb_firmware ${D}/lib/firmware/
ln -sf ./libcuda.so.1.1 ${D}/usr/lib/arm-linux-gnueabihf/tegra/libcuda.so
ln -sf ./arm-linux-gnueabihf/tegra/libcuda.so ${D}/usr/lib/libcuda.so