summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-07-11 14:40:25 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-07-11 14:40:25 +0200
commit14fde516a98208b79ac0800506cc8f36b4f33cb8 (patch)
treeaa44a62d5f74b055b5f3f0a3d409d469feec8e1d
parent321e339c05970ada2bd4816556dca24ad0dbb692 (diff)
linux-toradex_3.10.40: add cflags for kernel modules
In the thud setups modules no longer load because they seem to be compiled with pic by default. E.g. at runtime: [ 9.302483] apalis_tk1_k20: Unknown symbol _GLOBAL_OFFSET_TABLE_ (err 0) Adding -fno-pic makes them load again. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex_3.10.40.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_3.10.40.bb b/recipes-kernel/linux/linux-toradex_3.10.40.bb
index 0b37ca3..21bdf74 100644
--- a/recipes-kernel/linux/linux-toradex_3.10.40.bb
+++ b/recipes-kernel/linux/linux-toradex_3.10.40.bb
@@ -22,6 +22,10 @@ SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRAN
COMPATIBLE_MACHINE = "apalis-tk1"
+# since thud modules no longer load without this
+# [ 9.302483] apalis_tk1_k20: Unknown symbol _GLOBAL_OFFSET_TABLE_ (err 0)
+KERNEL_EXTRA_ARGS_append = "CFLAGS_MODULE=-fno-pic"
+
# One possibiltiy for changes to the defconfig:
config_script () {
# #example change to the .config