summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-12-02 15:12:16 +0000
committerStefan Agner <stefan.agner@toradex.com>2019-12-18 10:25:21 +0000
commit649945f4dab44737709281047d0472d5588227ae (patch)
tree911569c0f26218c1a588c6df71b2870dcdc81f93
parentd92e9cac231e6737efbef067ac503e9e772ae29b (diff)
linux-toradex-mainline: use new versioning
Use toradex-kernel-localversion class to implement the new versioning scheme for U-Boot. Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_4.14.bb15
1 files changed, 4 insertions, 11 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline_4.14.bb b/recipes-kernel/linux/linux-toradex-mainline_4.14.bb
index 5983641..7b26b7f 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_4.14.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_4.14.bb
@@ -6,12 +6,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-toradex-mainline-4.14:"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-inherit kernel siteinfo
+inherit kernel siteinfo toradex-kernel-localversion
-LINUX_VERSION ?= "4.14.155"
+# git hash not available since tarball from kernel.org is used
+SCMVERSION = "n"
-LOCALVERSION = "-${PR}"
-PR = "${TDX_VER_ITEM}"
+LINUX_VERSION ?= "4.14.155"
PV = "${LINUX_VERSION}"
S = "${WORKDIR}/linux-${PV}"
@@ -91,16 +91,9 @@ do_configure_prepend () {
#maybe change some configuration
config_script
- #Add Toradex BSP Version as LOCALVERSION
- sed -i -e /CONFIG_LOCALVERSION/d ${B}/.config
- echo "CONFIG_LOCALVERSION=\"${LOCALVERSION}\"" >> ${B}/.config
-
cd - > /dev/null
}
do_uboot_mkimage_prepend() {
cd ${B}
}
-
-# defaults
-TDX_VER_ITEM ??= "0"