summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-03-18 13:21:47 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 12:14:28 +0200
commita50963e7aed46f48d78c34c5d123031727982ca8 (patch)
tree93d67830ab4c67c95e6907a321ea6860e7bc5f1b
parentb717933ad06d3dd20d129e4ff350b1a20b81b895 (diff)
meta-toradex-tegra: cleanup whitespace use
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend8
-rw-r--r--lxde-layer/recipes-lxde/lxterminal/lxterminal_%.bbappend4
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb5
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb2
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb4
-rw-r--r--recipes-bsp/tegrarcm/tegrarcm.bb4
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb13
-rw-r--r--recipes-bsp/trdx-k20-fw/trdx-k20-fw_1.0.bb2
-rw-r--r--recipes-bsp/trdx-nv-binaries/nvsamples.bb9
-rw-r--r--recipes-bsp/trdx-nv-binaries/trdx-nv-binaries.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb13
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb2
-rw-r--r--recipes-core/hdmi-hotplug/hdmi-hotplug.bb4
-rw-r--r--recipes-graphics/drm/libdrm_%.bbappend18
-rw-r--r--recipes-graphics/eglinfo/eglinfo-x11_%.bbappend4
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend14
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend10
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg-1.14.7.inc6
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb13
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_4.9.bb29
-rw-r--r--recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb24
-rw-r--r--recipes-multimedia/libgstomx/libgstomx_21.5.0.bb24
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.3.bb7
23 files changed, 110 insertions, 115 deletions
diff --git a/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend b/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
index 9d5211a..9a1dac6 100644
--- a/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
+++ b/jetson-tk1/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
@@ -1,8 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-driver-package:"
-SRC_URI_append_apalis-tk1 = " file://xorg.conf \
- file://nvfb.service \
- file://nv.service"
+SRC_URI_append_apalis-tk1 = " \
+ file://xorg.conf \
+ file://nvfb.service \
+ file://nv.service \
+"
inherit systemd
do_install_append_apalis-tk1 () {
diff --git a/lxde-layer/recipes-lxde/lxterminal/lxterminal_%.bbappend b/lxde-layer/recipes-lxde/lxterminal/lxterminal_%.bbappend
index 7d023d3..da44c99 100644
--- a/lxde-layer/recipes-lxde/lxterminal/lxterminal_%.bbappend
+++ b/lxde-layer/recipes-lxde/lxterminal/lxterminal_%.bbappend
@@ -1,5 +1,3 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += " \
- file://0001-lxterminal.c-fix-garbled-titlebar.patch \
-"
+SRC_URI += " file://0001-lxterminal.c-fix-garbled-titlebar.patch"
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index c22735a..ee94a00 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -8,12 +8,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
BBCLASSEXTEND = "native nativesdk"
-SRC_URI = "git://github.com/NVIDIA/cbootimage.git \
- "
+SRC_URI = "git://github.com/NVIDIA/cbootimage.git"
SRCREV = "a64c3f12b1b048096d90c44db74d3d110cea6fff"
PV = "1.7"
-EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
#we want cbootimage binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -m32' 'BUILDDIR=${S}'"
diff --git a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
index fdef5fa..7632bb9 100644
--- a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
+++ b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
@@ -1,7 +1,7 @@
SUMMARY = "Scripts to enable the LVDS converter on Apalis T30"
LICENSE = "PD"
-SRC_URI = " \
+SRC_URI = " \
file://lvds-dual-channel.sh \
file://lvds-single-channel.sh \
file://COPYING \
diff --git a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
index 99a2e59..7b0ef3b 100644
--- a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
+++ b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
@@ -1,9 +1,7 @@
SUMMARY = "Configure LVDS output as extended mode in favour of primary HDMI one on Apalis TK1"
LICENSE = "PD"
-SRC_URI = " \
- file://COPYING \
-"
+SRC_URI = "file://COPYING"
LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7dd"
diff --git a/recipes-bsp/tegrarcm/tegrarcm.bb b/recipes-bsp/tegrarcm/tegrarcm.bb
index 66b949a..186593c 100644
--- a/recipes-bsp/tegrarcm/tegrarcm.bb
+++ b/recipes-bsp/tegrarcm/tegrarcm.bb
@@ -16,9 +16,9 @@ SRC_URI = " \
SRCREV = "ec1eeac53420de6b34e814ebd28e92099b257487"
PV = "1.7+"
-EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+EXTRA_OEMAKE = 'PREFIX="${prefix}" LIBDIR="${libdir}"'
-LDFLAGS_append=" -static-libstdc++"
+LDFLAGS_append = " -static-libstdc++"
#we want tegrarcm binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
EXTRA_OEMAKE_class-native = "CC='${CC} -m32' CXX='${CXX} -m32 -I${includedir}/cryptopp'"
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
index 5642bbd..4e1dba4 100644
--- a/recipes-bsp/tegrastats/tegrastats.bb
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -3,9 +3,11 @@ DESCRIPTION = "NVIDIAS tegrastats in a commandline version and one with output t
LICENSE = "CLOSED"
PR = "r3"
-SRC_URI = "file://tegrastats \
- file://tegrastats-gtk \
- file://Tegrastats-gtk.desktop "
+SRC_URI = " \
+ file://tegrastats \
+ file://tegrastats-gtk \
+ file://Tegrastats-gtk.desktop \
+"
S = "${WORKDIR}"
@@ -24,8 +26,9 @@ do_install() {
}
FILES_${PN}-gtk = " \
- ${bindir}/tegrastats-gtk \
- /home/root/Desktop/Tegra* "
+ ${bindir}/tegrastats-gtk \
+ /home/root/Desktop/Tegra* \
+"
FILES_${PN} = "${bindir}/tegrastats"
diff --git a/recipes-bsp/trdx-k20-fw/trdx-k20-fw_1.0.bb b/recipes-bsp/trdx-k20-fw/trdx-k20-fw_1.0.bb
index 70ccc60..eee4b64 100644
--- a/recipes-bsp/trdx-k20-fw/trdx-k20-fw_1.0.bb
+++ b/recipes-bsp/trdx-k20-fw/trdx-k20-fw_1.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Toradex Apalis TK1 K20 MCU Firmware"
HOMEPAGE = "https://developer.toradex.com/"
LICENSE = "GPLv2"
-SRC_URI = " file://apalis-tk1-k20.bin"
+SRC_URI = "file://apalis-tk1-k20.bin"
LIC_FILES_CHKSUM = "file://LICENCE;md5=f711eb988c2634cf4f4184914b8174cf"
diff --git a/recipes-bsp/trdx-nv-binaries/nvsamples.bb b/recipes-bsp/trdx-nv-binaries/nvsamples.bb
index b6fb46c..1b309ea 100644
--- a/recipes-bsp/trdx-nv-binaries/nvsamples.bb
+++ b/recipes-bsp/trdx-nv-binaries/nvsamples.bb
@@ -7,10 +7,11 @@ PR = "r1"
PARALLEL_MAKE = ""
-SRC_URI = "http://developer.toradex.com/files/toradex-dev/uploads/media/Colibri/Linux/Samples/nvsamples.tar.bz2 \
- file://nvsamples-oe.patch \
- file://nvsamples-no-binary-shaders.patch \
- file://nvsamples-hardfp.patch \
+SRC_URI = " \
+ http://developer.toradex.com/files/toradex-dev/uploads/media/Colibri/Linux/Samples/nvsamples.tar.bz2 \
+ file://nvsamples-oe.patch \
+ file://nvsamples-no-binary-shaders.patch \
+ file://nvsamples-hardfp.patch \
"
S = "${WORKDIR}/nvsamples"
diff --git a/recipes-bsp/trdx-nv-binaries/trdx-nv-binaries.bb b/recipes-bsp/trdx-nv-binaries/trdx-nv-binaries.bb
index cb41156..cd5f668 100644
--- a/recipes-bsp/trdx-nv-binaries/trdx-nv-binaries.bb
+++ b/recipes-bsp/trdx-nv-binaries/trdx-nv-binaries.bb
@@ -9,7 +9,7 @@ PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2"
# the khronos headers are taken from here: https://www.khronos.org/registry/khronos_headers.tgz
# this tarball changes from time to time breaking the receipe, thus it is provided with the recipe
-SRC_COMMON = " \
+SRC_COMMON = " \
file://aplay.desktop \
file://egl.pc \
file://eglplatform.h \
@@ -21,13 +21,13 @@ SRC_COMMON = " \
https://www.khronos.org/registry/omxil/api/1.1.2/OpenMAX_IL_1_1_2_Header.zip;name=openmax-h;unpack=no \
"
-SRC_URI_tegra2 = " \
+SRC_URI_tegra2 = " \
http://developer.download.nvidia.com/mobile/tegra/l4t/r16.5.0/ventana_release_armhf/Tegra20_Linux-codecs_R16.5_armhf.tbz2;name=t20codecs \
http://developer.download.nvidia.com/mobile/tegra/l4t/r16.5.0/ventana_release_armhf/Tegra20_Linux_R16.5_armhf.tbz2;name=t20drivers \
${SRC_COMMON} \
"
-SRC_URI_tegra3 = " \
+SRC_URI_tegra3 = " \
http://developer.download.nvidia.com/mobile/tegra/l4t/r16.5.0/cardhu_release_armhf/Tegra30_Linux-codecs_R16.5_armhf.tbz2;name=t30codecs \
http://developer.download.nvidia.com/mobile/tegra/l4t/r16.5.0/cardhu_release_armhf/Tegra30_Linux_R16.5_armhf.tbz2;name=t30drivers \
http://developer.toradex.com/files/toradex-dev/uploads/media/Colibri/Linux/Extra/libgstomx.so;name=libgstomx \
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 94e56c0..1fe0fee 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -13,17 +13,16 @@ DEFAULT_PREFERENCE_colibri-t20 = "1"
DEFAULT_PREFERENCE_colibri-t30 = "1"
FILESPATHPKG =. "git:"
-S="${WORKDIR}/git"
+
# This revision is based on upstream "v2016.11"
SRCREV = "cedf55d098b4b0af2815c92ee40576a4c899fcfb"
SRCBRANCH = "2016.11-toradex-next"
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
- file://fw_env.config \
-"
-SRC_URI_append_tegra3 = " file://fw_unlock_mmc.sh \
-"
-SRC_URI_append_tegra124 = " file://fw_unlock_mmc.sh \
+SRC_URI = " \
+ git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
+ file://fw_env.config \
"
+SRC_URI_append_tegra3 = " file://fw_unlock_mmc.sh"
+SRC_URI_append_tegra124 = " file://fw_unlock_mmc.sh"
PV = "v2016.11-v2.7b1+git${SRCPV}"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index 6238e96..e86f26a 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -14,7 +14,7 @@ DEFAULT_PREFERENCE_colibri-t20 = "1"
DEFAULT_PREFERENCE_colibri-t30 = "1"
FILESPATHPKG =. "git:"
-S="${WORKDIR}/git"
+S = "${WORKDIR}/git"
# This revision is based on upstream "v2016.11"
SRCREV = "cedf55d098b4b0af2815c92ee40576a4c899fcfb"
SRCBRANCH = "2016.11-toradex-next"
diff --git a/recipes-core/hdmi-hotplug/hdmi-hotplug.bb b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
index bc18e21..5c75d52 100644
--- a/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
+++ b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
@@ -9,9 +9,7 @@ PR = "r1"
PACKAGE_ARCH = "all"
-SRC_URI = " \
- file://hdmi.rules \
-"
+SRC_URI = "file://hdmi.rules"
do_install() {
install -d ${D}/${sysconfdir}/udev/rules.d
diff --git a/recipes-graphics/drm/libdrm_%.bbappend b/recipes-graphics/drm/libdrm_%.bbappend
index c035f18..8eee5e2 100644
--- a/recipes-graphics/drm/libdrm_%.bbappend
+++ b/recipes-graphics/drm/libdrm_%.bbappend
@@ -1,16 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "\
- file://0001-Add-drmModeAddFB2WithModifiers-which-takes-format-mo.patch \
- file://0001-sync-kernel-UAPI.patch \
- "
-PACKAGES += "\
- ${PN}-tegra \
- \
- "
+SRC_URI += " \
+ file://0001-Add-drmModeAddFB2WithModifiers-which-takes-format-mo.patch \
+ file://0001-sync-kernel-UAPI.patch \
+"
+PACKAGES += " ${PN}-tegra"
FILES_${PN}-tegra = "${libdir}/libdrm_tegra.so.*"
-EXTRA_OECONF_append += "\
- --enable-tegra-experimental-api \
- "
-
+EXTRA_OECONF_append += " --enable-tegra-experimental-api"
diff --git a/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
index c8b8985..38f2969 100644
--- a/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
+++ b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
@@ -8,6 +8,4 @@ EGLINFO_DEVICE_tegra = "generic"
SRCREV = "223817ee37988042db7873cfb5b2e899dfe35c10"
-SRC_URI_append_tegra = " \
- file://eglinfo.patch \
-"
+SRC_URI_append_tegra = " file://eglinfo.patch"
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index f9e039c..84d0dbe 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -31,13 +31,13 @@ EXTRA_OECONF_append_tegra124m = " --enable-texture-float --without-dri-drivers -
DRIDRIVERS_tegra124m = " "
GALLIUMDRIVERS_tegra124m = "tegra"
-SRC_URI_append_tegra124m = "\
- file://0001-gallium-add-renderonly-library.patch \
- file://0004-gallium-add-tegra-support.patch \
- file://0005-tegra-open-card1-instead-of-renderD128.patch \
- file://0006-HACK-make-DRI-work-under-X.patch \
- file://0008-remove-dependency-on-libdrm_tegra.patch \
- "
+SRC_URI_append_tegra124m = " \
+ file://0001-gallium-add-renderonly-library.patch \
+ file://0004-gallium-add-tegra-support.patch \
+ file://0005-tegra-open-card1-instead-of-renderD128.patch \
+ file://0006-HACK-make-DRI-work-under-X.patch \
+ file://0008-remove-dependency-on-libdrm_tegra.patch \
+"
PACKAGE_ARCH_tegra124m = "${MACHINE_ARCH}"
PE_tegra124m = "99"
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index cb57c9b..a5c01b1 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -5,8 +5,8 @@ PACKAGE_ARCH_tegra124m = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE_tegra124m = "(apalis-tk1-mainline)"
SRC_URI_append_tegra124m = "\
- file://0001-compositor-drm-Add-new-gbm-struct-to-allow-for-a-sep.patch \
- file://0002-compositor-drm-Add-support-for-Tegra-Jetson-TK1.patch \
- file://0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch \
- file://0004-use-name-based-detection-of-display-and-render-nodes.patch \
- "
+ file://0001-compositor-drm-Add-new-gbm-struct-to-allow-for-a-sep.patch \
+ file://0002-compositor-drm-Add-support-for-Tegra-Jetson-TK1.patch \
+ file://0003-Add-glFinish-to-DRM-backend-to-avoid-tearing.patch \
+ file://0004-use-name-based-detection-of-display-and-render-nodes.patch \
+"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg-1.14.7.inc b/recipes-graphics/xorg-xserver/xserver-xorg-1.14.7.inc
index e141582..5fe0a9f 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg-1.14.7.inc
+++ b/recipes-graphics/xorg-xserver/xserver-xorg-1.14.7.inc
@@ -16,8 +16,10 @@ PE = "2"
INC_PR = "r8"
XORG_PN = "xorg-server"
-SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
-SRC_URI += "file://macro_tweak.patch"
+SRC_URI = " \
+ ${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
+ file://macro_tweak.patch \
+"
S = "${WORKDIR}/${XORG_PN}-${PV}"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb
index 515e491..d7ffd7b 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.14.7.bb
@@ -5,12 +5,13 @@ COMPATIBLE_MACHINE = "(tegra2|tegra3)"
LIC_FILES_CHKSUM = "file://COPYING;md5=bc098b9774ed096943f6c37b5beeef13"
# Misc build failure for master HEAD
-SRC_URI += "file://crosscompile.patch \
- file://fix_open_max_preprocessor_error.patch \
- file://mips64-compiler.patch \
- file://aarch64.patch \
- file://xorg-CVE-2013-6424.patch \
- file://0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch \
+SRC_URI += "\
+ file://crosscompile.patch \
+ file://fix_open_max_preprocessor_error.patch \
+ file://mips64-compiler.patch \
+ file://aarch64.patch \
+ file://xorg-CVE-2013-6424.patch \
+ file://0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch \
"
SRC_URI_append_tegra = " file://Revert_Use_new_pixman_glyph_cache_t_API_that_will_be_in_pixman0.28.0.patch"
diff --git a/recipes-kernel/linux/linux-toradex-mainline_4.9.bb b/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
index b04f29a..c3316a0 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_4.9.bb
@@ -15,20 +15,21 @@ PR = "v2.7b1"
PV = "${LINUX_VERSION}"
S = "${WORKDIR}/linux-${PV}"
SRC_URI[md5sum] = "0a68ef3615c64bd5ee54a3320e46667d"
-SRC_URI = "https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${PV}.tar.xz \
- file://0001-toradex_apalis_tk1_t30-customize-defconfig.patch \
- file://0001-apalis-tk1-remove-spurious-new-lines.patch \
- file://0002-apalis-tk1-temp-alert-pull-up.patch \
- file://0003-apalis-tk1-optional-displayport-hot-plug-detect.patch \
- file://0004-apalis-tk1-adjust-pin-muxing-for-v1.1-hw.patch \
- file://0005-apalis-tk1-working-sd-card-detect-on-v1.1-hw.patch \
- file://0006-apalis-tk1-update-compatibility-comment.patch\
- file://0001-apalis_t30-tk1-fix-pcie-clock-and-reset-not-conformi.patch \
- file://0002-igb-integrate-tools-only-device-support.patch \
- file://0003-apalis_t30-tk1-igb-no-nvm-and-Ethernet-MAC-address-h.patch \
- file://0004-mmc-tegra-apalis-tk1-hack-to-make-sd1-functional.patch \
- file://0001-drm-tegra-add-tiling-FB-modifiers.patch \
- "
+SRC_URI = " \
+ https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${PV}.tar.xz \
+ file://0001-toradex_apalis_tk1_t30-customize-defconfig.patch \
+ file://0001-apalis-tk1-remove-spurious-new-lines.patch \
+ file://0002-apalis-tk1-temp-alert-pull-up.patch \
+ file://0003-apalis-tk1-optional-displayport-hot-plug-detect.patch \
+ file://0004-apalis-tk1-adjust-pin-muxing-for-v1.1-hw.patch \
+ file://0005-apalis-tk1-working-sd-card-detect-on-v1.1-hw.patch \
+ file://0006-apalis-tk1-update-compatibility-comment.patch\
+ file://0001-apalis_t30-tk1-fix-pcie-clock-and-reset-not-conformi.patch \
+ file://0002-igb-integrate-tools-only-device-support.patch \
+ file://0003-apalis_t30-tk1-igb-no-nvm-and-Ethernet-MAC-address-h.patch \
+ file://0004-mmc-tegra-apalis-tk1-hack-to-make-sd1-functional.patch \
+ file://0001-drm-tegra-add-tiling-FB-modifiers.patch \
+"
COMPATIBLE_MACHINE = "(apalis-tk1-mainline|apalis-t30-mainline)"
KERNEL_EXTRA_ARGS = " LOADADDR=0x80008000 "
diff --git a/recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb b/recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb
index 0469b07..7ae88d4 100644
--- a/recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb
+++ b/recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb
@@ -4,10 +4,10 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d"
SRC_URI = " \
- http://developer.download.nvidia.com/embedded/L4T/r21_Release_v5.0/source/gstegl_src.tbz2 \
- file://0001-rename-gstegl-to-gstnvegl.patch \
- file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
- file://0001-pkg-config-files-fix-qa-error.patch \
+ http://developer.download.nvidia.com/embedded/L4T/r21_Release_v5.0/source/gstegl_src.tbz2 \
+ file://0001-rename-gstegl-to-gstnvegl.patch \
+ file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
+ file://0001-pkg-config-files-fix-qa-error.patch \
"
SRC_URI[md5sum] = "8a08b88f2faa807d94d1939ddcb93b22"
@@ -24,16 +24,16 @@ DEPENDS += " libffi glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base libpcre libx
DEPENDS += " virtual/egl virtual/mesa virtual/libgles2 wayland gdbm drm "
FILES_${PN}-dbg = " \
- /usr/src/debug/* \
- /usr/lib/gstreamer-1.0/.debug/* \
- /usr/lib/.debug/* \
+ /usr/src/debug/* \
+ /usr/lib/gstreamer-1.0/.debug/* \
+ /usr/lib/.debug/* \
"
FILES_${PN} = " \
- /usr/lib/gstreamer-1.0/libgstnveglglessink.so \
- /usr/lib/gstreamer-1.0/libgstnveglglessink.la \
- /usr/lib/libgstnvegl-1.0.so \
- /usr/lib/libgstnvegl-1.0.so.0 \
- /usr/lib/libgstnvegl-1.0.so.0.203.0 \
+ /usr/lib/gstreamer-1.0/libgstnveglglessink.so \
+ /usr/lib/gstreamer-1.0/libgstnveglglessink.la \
+ /usr/lib/libgstnvegl-1.0.so \
+ /usr/lib/libgstnvegl-1.0.so.0 \
+ /usr/lib/libgstnvegl-1.0.so.0.203.0 \
"
diff --git a/recipes-multimedia/libgstomx/libgstomx_21.5.0.bb b/recipes-multimedia/libgstomx/libgstomx_21.5.0.bb
index cef62da..d2c2740 100644
--- a/recipes-multimedia/libgstomx/libgstomx_21.5.0.bb
+++ b/recipes-multimedia/libgstomx/libgstomx_21.5.0.bb
@@ -4,8 +4,8 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = " \
- http://developer.download.nvidia.com/embedded/L4T/r21_Release_v5.0/source/gstomx1_src.tbz2 \
- file://gstomx.patch \
+ http://developer.download.nvidia.com/embedded/L4T/r21_Release_v5.0/source/gstomx1_src.tbz2 \
+ file://gstomx.patch \
"
SRC_URI[md5sum] = "d5714a9533b210b30ef0e97e28ebc77d"
@@ -24,19 +24,19 @@ CXXFLAGS += " -I${S}/omx/openmax "
CFLAGS += " -I${S}/omx/openmax "
do_configure_prepend() {
- export NOCONFIGURE="true"
- export GST_EGL_LIBS="-lgstnvegl-1.0 -lEGL -lX11 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0"
- export GST_EGL_CFLAGS="-I${STAGING_INCDIR}/libdrm "
-# export GST_EGL_CFLAGS="-pthread -I${STAGING_INCDIR}/gstreamer-1.0 -I${STAGING_INCDIR}/libdrm -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
+ export NOCONFIGURE="true"
+ export GST_EGL_LIBS="-lgstnvegl-1.0 -lEGL -lX11 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0"
+ export GST_EGL_CFLAGS="-I${STAGING_INCDIR}/libdrm "
+# export GST_EGL_CFLAGS="-pthread -I${STAGING_INCDIR}/gstreamer-1.0 -I${STAGING_INCDIR}/libdrm -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
}
FILES_${PN}-dbg = " \
- /usr/src/debug/* \
- /usr/lib/gstreamer-1.0/.debug/* \
- /usr/lib/.debug/* \
+ /usr/src/debug/* \
+ /usr/lib/gstreamer-1.0/.debug/* \
+ /usr/lib/.debug/* \
"
FILES_${PN} = " \
- /usr/lib/gstreamer-1.0/libgstomx.la \
- /usr/lib/gstreamer-1.0/libgstomx.so \
- "
+ /usr/lib/gstreamer-1.0/libgstomx.la \
+ /usr/lib/gstreamer-1.0/libgstomx.so \
+"
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.3.bb b/recipes-support/libcryptopp/libcryptopp_5.6.3.bb
index 03d24ba..d31abae 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.3.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.3.bb
@@ -11,9 +11,10 @@ BBCLASSEXTEND = "native nativesdk"
PR = "r1"
PVSHORT = "${@'${PV}'.replace('.','')}"
-SRC_URI = "https://sourceforge.net/projects/cryptopp/files/cryptopp/5.6.3/cryptopp563.zip;subdir=libcryptopp-${PV} \
- file://0001-Fix-cross-compilation.patch \
- "
+SRC_URI = " \
+ https://sourceforge.net/projects/cryptopp/files/cryptopp/5.6.3/cryptopp563.zip;subdir=libcryptopp-${PV} \
+ file://0001-Fix-cross-compilation.patch \
+"
SRC_URI[md5sum] = "3c5b70e2ec98b7a24988734446242d07"
SRC_URI[sha256sum] = "9390670a14170dd0f48a6b6b06f74269ef4b056d4718a1a329f6f6069dc957c9"