summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2020-04-10 05:01:19 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-01 13:35:35 +0200
commitd87cf806ccbfbe6d521e12a1b9fe790a3b8e77ff (patch)
treeda153505cf72b79da2d7ec5c6d6c9c288f762d0f
parente388f8d61d258406409cc2468fe7835c793516f1 (diff)
linux-driver-package: fix direct-loading firmware
Debugging reveals that it is really also expecting certain firmware at the original path: [ 134.878913] firmware tegra12x!vic03_ucode.bin: firmware: requesting tegra12x/vic03_ucode.bin So make a symbolic link rather then copying them. Without older systemd's firmware usermode helper fallback in place using an alternative file name leads to a very long timeout. Fix this by linking the alternative nameed firmware to the one tried first. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> (cherry picked from commit 5d206eb3265bc6bc96442ffcd1cc4ce1f80f0714) (cherry picked from commit 71f68117693bfd479774aac42412a18fdf77a2e8)
-rwxr-xr-xrecipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb b/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb
index e84c381..f64d009 100755
--- a/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb
+++ b/recipes-bsp/binary-drivers/linux-driver-package_21.7.0.bb
@@ -81,7 +81,8 @@ do_patch () {
do_install () {
tar xjf ${WORKDIR}/Linux_for_Tegra/nv_tegra/nvidia_drivers.tbz2 -C ${D}
- mv ${D}/lib/firmware/tegra12x ${D}/lib/firmware/gk20a
+ ln -sf tegra12x ${D}/lib/firmware/gk20a
+ ln -sf nvavp_vid_ucode_alt.bin ${D}/lib/firmware/nvavp_vid_ucode.bin
mv ${D}/usr/lib/arm-linux-gnueabihf/tegra/lib* ${D}/usr/lib/
mv ${D}/usr/lib/arm-linux-gnueabihf/tegra-egl/lib* ${D}/usr/lib/
rm -rf ${D}/usr/lib/arm-linux-gnueabihf/tegra ${D}/usr/lib/arm-linux-gnueabihf/tegra-egl