summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-10-26 14:13:54 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-10-26 14:13:54 +0200
commitf50fa3498311efa9cacc6040b7f05e426942b590 (patch)
treefcd01f8e0771587f3b8f5317d1e356055481bee2
parent8cffe086618f4c5ae6edecfadd9c3fb271b1bd9b (diff)
perf: remove scripting from configuration
Latest Openembedded (Zeus) builds perf with python 3 which requires a 5.x kernel or a kernel patch. Remove scripting from the perf configuation to allow building against the 3.10 L4T kernel. While at it change all overrides to the CPU specific tegra124 override rather than using apalis-tk1. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-kernel/perf/perf.bbappend9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-kernel/perf/perf.bbappend b/recipes-kernel/perf/perf.bbappend
index f63e5cc..613619b 100644
--- a/recipes-kernel/perf/perf.bbappend
+++ b/recipes-kernel/perf/perf.bbappend
@@ -6,8 +6,13 @@ PERF_SRC_LEGACY_TEGRAS = "Makefile \
lib \
tools \
"
-PERF_SRC_apalis-tk1 = "${PERF_SRC_LEGACY_TEGRAS}"
+PERF_SRC_tegra124 = "${PERF_SRC_LEGACY_TEGRAS}"
-do_configure_prepend_apalis-tk1 () {
+do_configure_prepend_tegra124 () {
sed -i 's$I/usr/include/slang$I=/usr/include/slang$' tools/perf/Makefile
}
+
+# scripting is confiugred to use python3, however this requires a build
+# against a kernel of version 5.x and later or a patch to the kernel.
+# see also https://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/meta/recipes-kernel/perf?id=92469aad50b623afa423c19d82ed2e3c667c5e6a
+PACKAGECONFIG_remove_tegra124 = "scripting"