summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-02-19 15:46:27 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 12:10:59 +0200
commit6fa88dd203ee05281b5af802c7da63a94be3fe94 (patch)
treef4c8fe51eed112b14c8f3ca1b619379750dc240a /conf
parent408a7e274ae23cc311bda416dccb2bfe09576ffd (diff)
layer.conf: add layer dependencies
While at it clean-up and unify with other Toradex layers. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf9
1 files changed, 5 insertions, 4 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 25867fa..7200143 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,9 +1,8 @@
-# We have a conf and classes directory, add to BBPATH
+# We have a conf and classes directory, append to BBPATH
BBPATH .= ":${LAYERDIR}"
-# We have a recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "toradex-tegra-layer"
BBFILE_PATTERN_toradex-tegra-layer = "^${LAYERDIR}/"
@@ -16,3 +15,5 @@ BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
# Add layer-specific bb files too
BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
for layer in BBFILE_COLLECTIONS.split())}"
+
+LAYERDEPENDS_toradex-tegra-layer = "core"