summaryrefslogtreecommitdiff
path: root/recipes-bsp/cbootimage
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-11-11 00:13:16 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-11-13 07:55:23 +0100
commit136eb6096cf64a8aa66af50e383c4916bd3c59ca (patch)
treec622886d8e2ed82c3e2599d7cffbe55937459fce /recipes-bsp/cbootimage
parentdff31b1934bb5ea0bfb7e87591105c37d21d6f84 (diff)
cbootimage/imx-loader/mtd-utils/tegrarcm: fix 32-bit build of our bsp/devtools
Diffstat (limited to 'recipes-bsp/cbootimage')
-rw-r--r--recipes-bsp/cbootimage/cbootimage.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/cbootimage/cbootimage.bb b/recipes-bsp/cbootimage/cbootimage.bb
index 9cf6705..66e5594 100644
--- a/recipes-bsp/cbootimage/cbootimage.bb
+++ b/recipes-bsp/cbootimage/cbootimage.bb
@@ -15,6 +15,9 @@ PV = "1.4"
EXTRA_OEMAKE='PREFIX="${prefix}" LIBDIR="${libdir}"'
+#we want cbootimage binary to run on a 32-bit architecture, on x86_64 this requires the 32-bit compatibility libs
+EXTRA_OEMAKE_class-native = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -m32' 'BUILDDIR=${S}'"
+
S = "${WORKDIR}/git"
inherit autotools