summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-10-30 10:40:16 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-10-30 10:40:16 +0100
commitab85aef5a2e84b05e0e8e07fa73cb5cf8e8b3fbe (patch)
tree203d3f2297f7ba1c43e44adea928487a03594399 /recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
parent5afb32dc6e43ff7d60f1cfceaaf702fef39a1ba1 (diff)
apalis/colibri_imx6/t30: u-boot-fw-utils: update fw_printenv/setenv
Introduce/update postinst code to dynamically adjust fw_env.config and fw_unlock_mmc.sh shell profile extension script to cope with our new unified eMMC layout: boot area partition 1 aka primary eMMC boot sector: with U-Boot boot loader and the U-Boot environment before the configblock at the end of that boot area partition
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 959860d..0f65b22 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -18,7 +18,8 @@ SRCREV = "06ee8db6422e02337242e43b8573359443db59ea"
SRCBRANCH = "2015.04-toradex"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
- file://fw_unlock_mmc.sh \
+"
+SRC_URI_append_tegra3 = " file://fw_unlock_mmc.sh \
"
PV_apalis-t30 = "${PR}+gitr${SRCREV}"
@@ -65,11 +66,11 @@ pkg_postinst_${PN}_tegra3 () {
if [ "x$D" != "x" ]; then
exit 1
fi
- # Environment in eMMC, at the end of 2nd "boot sector"
- DISK="mmcblk0boot1"
+ # Environment in eMMC, before the configblock at the end of 1st "boot sector"
+ DISK="mmcblk0boot0"
DISK_SIZE=`cat /sys/block/$DISK/size`
CONFIG_ENV_SIZE=8192 # 0x2000
- CONFIG_ENV_OFFSET=`expr $DISK_SIZE \* 512 - $CONFIG_ENV_SIZE`
+ CONFIG_ENV_OFFSET=`expr $DISK_SIZE \* 512 - $CONFIG_ENV_SIZE - 512`
printf "/dev/%s\t0x%X\t0x%X\n" $DISK $CONFIG_ENV_OFFSET $CONFIG_ENV_SIZE >> "/etc/fw_env.config"
}