summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-07-10 15:56:59 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-07-10 20:43:43 +0200
commit4ac3c7e979e8671df712d2cfd30b1966d09f479d (patch)
tree031b8ce97fd7837b82f325e97f10e1fc1cb061fe /recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb
parent057c3d173949d803c150ffe14338554845fec63c (diff)
u-boot-toradex: update to 2019.07 based
Update to a 2019.07 based U-Boot. Use the openembedded master recipes for u-boot_2019.07 as a base. While at it append -tk1 to PN to have a name different from the u-boot recipe name for our NXP based SoM and set the prefered provider accordingly. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb b/recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb
new file mode 100644
index 0000000..b32b28c
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-tk1_2019.07.bb
@@ -0,0 +1,34 @@
+require u-boot-toradex-common-tk1.inc
+require recipes-bsp/u-boot/u-boot.inc
+require recipes-bsp/u-boot/u-boot-toradex-initial-env.inc
+
+DEPENDS += "bc-native dtc-native"
+DEPENDS_append_apalis-tk1 = " cbootimage-native"
+DEPENDS_append_apalis-tk1-mainline = " cbootimage-native"
+
+COMPATIBLE_MACHINE = "(apalis-tk1)"
+
+SRC_URI_append_apalis-tk1 = " \
+ file://apalis-tk1.img.cfg \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+SRC_URI_append_apalis-tk1-mainline = " \
+ file://apalis-tk1.img.cfg \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_deploy_append_apalis-tk1() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}
+do_deploy_append_apalis-tk1-mainline() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}
+