summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_git.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-03-29 12:28:59 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-01 10:11:35 +0200
commit03b5ed469ab79143a365123ae0c227fc847200e3 (patch)
treec3de15210e7280377d0cef12d77560314e06e6fa /recipes-bsp/u-boot/u-boot-toradex_git.bb
parent8614992ce3180814bcd80ff2061b8626ba0604cf (diff)
u-boot: convert bbappend to a bb
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
new file mode 100644
index 0000000..b3e06d2
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -0,0 +1,58 @@
+require recipes-bsp/u-boot/u-boot.inc
+
+PROVIDES = "u-boot"
+DEPENDS += "dtc-native"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
+
+COMPATIBLE_MACHINE_colibri-t20 = "colibri-t20"
+COMPATIBLE_MACHINE_colibri-t30 = "colibri-t30"
+COMPATIBLE_MACHINE_apalis-t30 = "apalis-t30"
+
+DEFAULT_PREFERENCE_colibri-t20 = "1"
+DEFAULT_PREFERENCE_colibri-t30 = "1"
+DEFAULT_PREFERENCE_apalis-t30 = "1"
+
+FILESPATHPKG =. "git:"
+S="${WORKDIR}/git"
+SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
+SRC_URI_COLIBRI += "file://u-boot-dont-build-standalone.patch"
+# This revision is based on upstream "v2011.06"
+SRCREV_COLIBRI = "ccd521c4681a5850bbec1feec140eeaec33936b0"
+
+PV_colibri-t20 = "${PR}+gitr${SRCREV}"
+PV_colibri-t30 = "${PR}+gitr${SRCREV}"
+PV_apalis-t30 = "${PR}+gitr${SRCREV}"
+
+SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
+SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI}"
+SRC_URI_apalis-t30 = "${SRC_URI_COLIBRI}"
+
+SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
+SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
+SRCREV_apalis-t30 = "${SRCREV_COLIBRI}"
+
+# override the solution passed in from u-boot.inc as we want to set additional flags
+EXTRA_OEMAKE_colibri-t20 = "CROSS_COMPILE=${TARGET_PREFIX}"
+EXTRA_OEMAKE_colibri-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
+EXTRA_OEMAKE_apalis-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+# colibri-t20: build additionally a u-boot binary which uses/stores its environment on an T20 external sd or mmc card
+SPL_BINARY_colibri-t20 = "u-boot-hsmmc.bin"
+SPL_IMAGE_colibri-t20 = "u-boot-hsmmc-${MACHINE}-${PV}-${PR}.bin"
+SPL_SYMLINK_colibri-t20 = "u-boot-hsmmc-${MACHINE}.bin"
+do_compile_append_colibri-t20() {
+ # keep u-boot-nand
+ mv u-boot.bin u-boot-nand.bin
+ oe_runmake colibri_t20_sdboot_config
+ oe_runmake ${UBOOT_MAKE_TARGET}
+ mv u-boot.bin u-boot-hsmmc.bin
+ mv u-boot-nand.bin u-boot.bin
+}
+
+#do_install_append() {
+#}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"