summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_git.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:20:23 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:20:23 +0100
commit0693128b309ade187ada49800ef3f7de1ffa1c8f (patch)
treee8d8e69de46b1777526ec2fa07eeb1d1f8adc961 /recipes-bsp/u-boot/u-boot-toradex_git.bb
parent0e67f8b60bec10bc4e428f0d4559373eb4cc4b69 (diff)
apalis/colibri_t30: latest u-boot git migrated to cbootimage/tegrarcm
Use latest U-Boot from git. Migrate to using cbootimage and tegrarcm.
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb28
1 files changed, 18 insertions, 10 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index ceb5199..4651b85 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -4,8 +4,9 @@ PROVIDES = "u-boot"
DEPENDS += "dtc-native"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+LIC_FILES_CHKSUM_colibri-t20 = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
+LIC_FILES_CHKSUM_tegra3 = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30)"
@@ -15,27 +16,34 @@ DEFAULT_PREFERENCE_apalis-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
-SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-# This revision is based on upstream "v2011.06"
-SRCREV_COLIBRI = "278ca22a59e3df4dd1e1494e8920a01c172118af"
+SRC_URI_T20 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
+SRC_URI_T30 = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=2014.10-toradex"
+# This revision is based on upstream "v2014.10"
+SRCREV_T20 = "278ca22a59e3df4dd1e1494e8920a01c172118af"
+SRCREV_T30 = "67c3a4aee6c0af124ce779aed1be70c7a92d0916"
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
PV_colibri-t30 = "${PR}+gitr${SRCREV}"
PV_apalis-t30 = "${PR}+gitr${SRCREV}"
-SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
-SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI}"
-SRC_URI_apalis-t30 = "${SRC_URI_COLIBRI}"
+SRC_URI_colibri-t20 = "${SRC_URI_T20}"
+SRC_URI_colibri-t30 = "${SRC_URI_T30}"
+SRC_URI_apalis-t30 = "${SRC_URI_T30}"
-SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
-SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
-SRCREV_apalis-t30 = "${SRCREV_COLIBRI}"
+SRCREV_colibri-t20 = "${SRCREV_T20}"
+SRCREV_colibri-t30 = "${SRCREV_T30}"
+SRCREV_apalis-t30 = "${SRCREV_T30}"
# override the solution passed in from u-boot.inc as we want to set additional flags
EXTRA_OEMAKE_colibri-t20 = "CROSS_COMPILE=${TARGET_PREFIX}"
EXTRA_OEMAKE_colibri-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
EXTRA_OEMAKE_apalis-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
+# apalis/colibri-t30: require u-boot-dtb-tegra.bin to be used
+UBOOT_IMAGE_tegra3 = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
+UBOOT_BINARY_tegra3 = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
+UBOOT_SYMLINK_tegra3 = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
+
# colibri-t20: build additionally a u-boot binary which uses/stores its environment on an T20 external sd or mmc card
SPL_BINARY_colibri-t20 = "u-boot-hsmmc.bin"
SPL_IMAGE_colibri-t20 = "u-boot-hsmmc-${MACHINE}-${PV}-${PR}.bin"