summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_git.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-10-03 02:55:21 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-10-05 02:26:20 +0200
commit9a94e068d24d143ea5c4ef66c4e81e156e0c405d (patch)
tree525de992dc61893a5af1579a5c4a5e337e80fa23 /recipes-bsp/u-boot/u-boot-toradex_git.bb
parentda8cdb00dcc73ce9cb6809b6732a6a1153accbf5 (diff)
u-boot-toradex: apalis-tk1/apalis-tk1-mainline: generate cbootimage
Generate cbootimage already during build as required for Toradex Easy Installer BSP package. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Dominik Sliwa <dominik.sliwa@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index 37a623b..e684d80 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -4,6 +4,8 @@ inherit tegra-u-boot-localversion
PROVIDES = "u-boot virtual/bootloader"
DEPENDS += "dtc-native"
+DEPENDS_append_apalis-tk1 = " cbootimage-native"
+DEPENDS_append_apalis-tk1-mainline = " cbootimage-native"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
@@ -21,6 +23,14 @@ S = "${WORKDIR}/git"
SRCREV = "1b121c6ab548a9af0a27876e9eaa0c654c1dc3e1"
SRCBRANCH = "2016.11-toradex"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+SRC_URI_append_apalis-tk1 = " \
+ file://apalis-tk1.img.cfg \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+SRC_URI_append_apalis-tk1-mainline = " \
+ file://apalis-tk1.img.cfg \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
PV = "2016.11"
PR = "${TDX_VER_INT}+gitr${SRCPV}"
@@ -31,3 +41,16 @@ UBOOT_BINARY = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
UBOOT_SYMLINK = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_deploy_append_apalis-tk1() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}
+do_deploy_append_apalis-tk1-mainline() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}