summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_git.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-04-20 14:05:51 +0200
committerStefan Agner <stefan.agner@toradex.com>2018-06-18 09:21:27 +0200
commit5a5f979b5a717fef333d0835e4431e4cf9221cc1 (patch)
treea5248685f0681abfae63c1649819dc72537df287 /recipes-bsp/u-boot/u-boot-toradex_git.bb
parentdf78aaf49a754e5f70343bd45661661714a7d02a (diff)
u-boot-toradex: apalis-t30: generate cbootimage
Generate cbootimage already during build as required for Toradex Easy Installer BSP package. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index 364b48a..66d18c0 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -5,6 +5,7 @@ inherit tegra-u-boot-localversion
PROVIDES = "u-boot virtual/bootloader"
DEPENDS += "dtc-native"
+DEPENDS_append_apalis-t30 = " cbootimage-native"
DEPENDS_append_apalis-tk1 = " cbootimage-native"
DEPENDS_append_apalis-tk1-mainline = " cbootimage-native"
@@ -26,6 +27,10 @@ SRCBRANCH = "2016.11-toradex"
SRCREV_use-head-next = "${AUTOREV}"
SRCBRANCH_use-head-next = "2016.11-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+SRC_URI_append_apalis-t30 = " \
+ file://apalis_t30.img.cfg \
+ file://Apalis_T30_2GB_800Mhz.bct \
+"
SRC_URI_append_apalis-tk1 = " \
file://apalis-tk1.img.cfg \
file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
@@ -40,6 +45,12 @@ PR = "${TDX_VER_ITEM}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+do_deploy_append_apalis-t30() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/Apalis_T30_2GB_800Mhz.bct .
+ cbootimage -s tegra30 ${WORKDIR}/apalis_t30.img.cfg apalis_t30.img
+ rm Apalis_T30_2GB_800Mhz.bct
+}
do_deploy_append_apalis-tk1() {
cd ${DEPLOYDIR}
cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .