summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-06-16 21:57:14 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 12:03:36 +0100
commitb572cd2665b235d77ae5b26fecdb61742d652867 (patch)
tree523d7dc38b89086ef593c2ee9096555d20cb8953 /recipes-bsp
parentbb307f1bf2637879b306cfa4abb1a637b3ad83d6 (diff)
u-boot: fix compile
fix errors due to missing uint* types. Move to u-boot git. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/files/0001-fw_env.c-include-stdint.h-unconditionally.patch37
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/files/0001-fw_env.c-include-stdint.h-unconditionally.patch b/recipes-bsp/u-boot/files/0001-fw_env.c-include-stdint.h-unconditionally.patch
new file mode 100644
index 0000000..ae1524d
--- /dev/null
+++ b/recipes-bsp/u-boot/files/0001-fw_env.c-include-stdint.h-unconditionally.patch
@@ -0,0 +1,37 @@
+From a7a2fd28dc4180f1cbadf6038b67337ae6fdee34 Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Thu, 26 May 2016 14:01:35 +0200
+Subject: [PATCH] fw_env.c: include stdint.h unconditionally
+
+later builds fail with
+| tools/env/fw_env.c:52:2: error: unknown type name 'uint8_t'
+| uint8_t mtd_type; /* type of the MTD device */
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ tools/env/fw_env.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/env/fw_env.c b/tools/env/fw_env.c
+index 1173eea..edc5090 100644
+--- a/tools/env/fw_env.c
++++ b/tools/env/fw_env.c
+@@ -15,6 +15,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <stddef.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+@@ -22,7 +23,6 @@
+ #include <unistd.h>
+
+ #ifdef MTD_OLD
+-# include <stdint.h>
+ # include <linux/mtd/mtd.h>
+ #else
+ # define __user /* nothing */
+--
+2.6.6
+
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 3e776fb..a750d1e 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -19,6 +19,7 @@ SRCREV = "95b2e908c6aecaefccbad3f3fa808f8ffe1b3a92"
SRCBRANCH = "2015.04-toradex"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
+ file://0001-fw_env.c-include-stdint.h-unconditionally.patch \
"
SRC_URI_append_tegra3 = " file://fw_unlock_mmc.sh \
"