summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-12-08 13:45:04 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 12:03:36 +0100
commiteaa2c4cec1bc0eaa6497409a05eec6c5660cdf43 (patch)
treea31c90dbc56db5dcb49d41d5ea1e031c3f1365e4 /recipes-bsp
parent9af5385bcc1181990ef08c31b330ce46693d8fda (diff)
tegrastats: address bitbake warnings
TK1 silence warning for hash-style not gnu Allow debug package, as for TK1 we have an unstripped binary Add to RDEPENDS for tegrastats-gtk WARNING: tegrastats-1.0-r3 ...tegrastats-gtk contained in package tegrastats-gtk requires libatk-1.0.so.0... [file-rdeps] WARNING: tegrastats-1.0-r3 ...tegrastats: Files/directories were installed but not shipped in any package: WARNING: tegrastats-1.0-r3 ...No GNU_HASH in the elf binary: '...packages-split/tegrastats/usr/bin/tegrastats' [ldflags] WARNING: tegrastats-1.0-r3 ...tegrastats-gtk contained in package tegrastats-gtk requires libpangocairo-1.0.so.0... [file-rdeps] Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
index 9795c47..e49ec72 100644
--- a/recipes-bsp/tegrastats/tegrastats.bb
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "NVIDIAS tegrastats in a commandline version and one with output t
LICENSE = "CLOSED"
PR = "r3"
-RDEPENDS_{PN}-gtk = "pango"
+RDEPENDS_{PN}-gtk = "pango libatk-1.0-0"
SRC_URI = "file://tegrastats \
file://tegrastats-gtk \
@@ -11,11 +11,12 @@ SRC_URI = "file://tegrastats \
S = "${WORKDIR}"
-PACKAGES = "${PN} ${PN}-gtk"
+PACKAGES_prepend = "${PN}-gtk "
# Inhibit warnings about files being stripped.
# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
WARN_QA_remove = "already-stripped build-deps"
+WARN_QA_remove_tegra124 = "already-stripped build-deps ldflags"
WARN_QA-gtk_remove = "already-stripped build-deps"
do_install() {
@@ -29,3 +30,5 @@ FILES_${PN}-gtk = " \
/home/root/Desktop/Tegra* "
FILES_${PN} = "${bindir}/tegrastats"
+
+PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"