summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-03-27 20:10:18 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 13:34:59 +0200
commit8668392b04aaa6ff995620ad0c61dd413d775b1d (patch)
tree9c0ea601af4af19d2acc471c13acb4e22243cf83 /recipes-bsp
parenta50963e7aed46f48d78c34c5d123031727982ca8 (diff)
u-boot: use the new version variables
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb5
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb4
2 files changed, 7 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 1fe0fee..ceabce3 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -5,6 +5,8 @@ SECTION = "bootloader"
PROVIDES = "u-boot-fw-utils"
DEPENDS = "mtd-utils"
+include conf/tdx_version.conf
+
COMPATIBLE_MACHINE = "(apalis-t30|apalis-tk1|colibri-t20|colibri-t30)"
DEFAULT_PREFERENCE_apalis-t30 = "1"
@@ -24,7 +26,8 @@ SRC_URI = " \
SRC_URI_append_tegra3 = " file://fw_unlock_mmc.sh"
SRC_URI_append_tegra124 = " file://fw_unlock_mmc.sh"
-PV = "v2016.11-v2.7b1+git${SRCPV}"
+PV = "2016.11"
+PR = "${TDX_VER_INT}-gitr${@d.getVar("SRCREV", False)[0:7]}"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index e86f26a..87e1c69 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -1,4 +1,5 @@
require recipes-bsp/u-boot/u-boot.inc
+include conf/tdx_version.conf
PROVIDES = "u-boot virtual/bootloader"
DEPENDS += "dtc-native"
@@ -20,7 +21,8 @@ SRCREV = "cedf55d098b4b0af2815c92ee40576a4c899fcfb"
SRCBRANCH = "2016.11-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
-PV = "v2016.11-v2.7b1+git${SRCPV}"
+PV = "2016.11"
+PR = "${TDX_VER_INT}-gitr${@d.getVar("SRCREV", False)[0:7]}"
# require u-boot-dtb-tegra.bin to be used
UBOOT_IMAGE = "u-boot-dtb-tegra-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"