summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-03-10 14:25:56 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-03-22 14:36:04 +0100
commitaf25c319b3f9730fc6129bddb11701f75c42165b (patch)
tree4968503909a7a5da3294deccae7bda2655d68a05 /recipes-bsp
parentbf6be419eb33d19a07d8db2c828cd9370803f840 (diff)
tdx-nv-binaries: add x11 dependencies to help dependent packages
As this recipe adds only binary drivers it does not need any DEPENDS to build. However adding depends prevents QA warnings which test the binaries for dependencies and, more importantly other recipe will get needed dependencies installed in their sysroot. e.g. lxqt-panel would fail because libdamage is not installed in its recipe specific sysroot. While at it use -p with mkdir to not fail even if the directory already exists from a previous (failed) run of bitbake. While at it move the libpcre* symlinks to the nv-gstapps packages where they are used and RDEPEND on the real libpcre* libraries. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/tdx-nv-binaries/tdx-nv-binaries.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/recipes-bsp/tdx-nv-binaries/tdx-nv-binaries.bb b/recipes-bsp/tdx-nv-binaries/tdx-nv-binaries.bb
index 28d6080..15ea303 100644
--- a/recipes-bsp/tdx-nv-binaries/tdx-nv-binaries.bb
+++ b/recipes-bsp/tdx-nv-binaries/tdx-nv-binaries.bb
@@ -6,7 +6,8 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "(tegra)"
PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2"
-DEPENDS = "gstreamer gst-plugins-base"
+DEPENDS = "gstreamer gst-plugins-base libpcre virtual/xserver virtual/libx11 libxdamage libxext libxfixes"
+RDEPENDS_${PN}-nv-gstapps = "libpcre libpcreposix"
# the khronos headers are taken from here: https://www.khronos.org/registry/khronos_headers.tgz
# this tarball changes from time to time breaking the receipe, thus it is provided with the recipe
@@ -85,14 +86,16 @@ FILES_${PN}-restricted-codecs += " \
"
FILES_${PN}-nv-gstapps += " \
/usr/bin/* \
+ /usr/lib/libpcre* \
/usr/share/doc/nv_gstapps/* \
"
-#no gnu_hash in NVIDIA binaries, skip QA dev-so for this package
-#we have symlinks ending in .so, skip QA ldflags for this package
+#no gnu_hash in NVIDIA binaries, skip QA ldflags
+#we have symlinks ending in .so, skip QA dev-so
+#the qa check is not able to follow the libpcre symlink, skip QA file-rdeps
#inhibit warnings about files being stripped
-INSANE_SKIP_${PN} = "build-deps dev-so ldflags already-stripped textrel"
-INSANE_SKIP_${PN}-nv-gstapps = "build-deps dev-so ldflags already-stripped textrel file-rdeps"
+INSANE_SKIP_${PN} = "dev-so ldflags already-stripped textrel"
+INSANE_SKIP_${PN}-nv-gstapps = "dev-so ldflags already-stripped textrel file-rdeps"
do_patch () {
mkdir -p OpenMAX/il
@@ -104,7 +107,7 @@ do_patch () {
do_compile () {
#unpack the different packages
#nvidia drivers
- mkdir nvidia_drivers
+ mkdir -p nvidia_drivers
tar -C nvidia_drivers -xjf ${WORKDIR}/Linux_for_Tegra/nv_tegra/nvidia_drivers.tbz2
tar -C nvidia_drivers -xjf ${WORKDIR}/Linux_for_Tegra/nv_tegra/config.tbz2
@@ -114,7 +117,7 @@ do_compile () {
cp ${WORKDIR}/Linux_for_Tegra/nv_tegra/nv_sample_apps/nv*.txt nvgstapps/usr/share/doc/nv_gstapps/
#restricted codecs
- mkdir restricted_codecs
+ mkdir -p restricted_codecs
tar -C restricted_codecs -xjf ${WORKDIR}/restricted_codecs.tbz2
}