summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-07-25 19:35:25 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-09-29 20:38:12 +0200
commitb5b84f3f8c67c53648fadb1052fd2382ae093119 (patch)
treeef216924bc3aa9f6dab7ce6b485b7f9987da6ede /recipes-bsp
parentec4488176149314797398f7793693d12f32fca1f (diff)
tegrastats: mv all files into recipes-bsp/tegrastats
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rwxr-xr-xrecipes-bsp/tegrastats/files/Tegrastats-gtk.desktop11
-rwxr-xr-xrecipes-bsp/tegrastats/files/apalis-tk1/tegrastatsbin0 -> 80941 bytes
-rwxr-xr-xrecipes-bsp/tegrastats/files/tegrastatsbin0 -> 19320 bytes
-rwxr-xr-xrecipes-bsp/tegrastats/files/tegrastats-gtkbin0 -> 15200 bytes
-rw-r--r--recipes-bsp/tegrastats/tegrastats.bb31
5 files changed, 42 insertions, 0 deletions
diff --git a/recipes-bsp/tegrastats/files/Tegrastats-gtk.desktop b/recipes-bsp/tegrastats/files/Tegrastats-gtk.desktop
new file mode 100755
index 0000000..5424c2a
--- /dev/null
+++ b/recipes-bsp/tegrastats/files/Tegrastats-gtk.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+
+[Desktop Entry]
+Version=1.0
+Type=Application
+Terminal=false
+Icon[C]=gnome-monitor.png
+Exec=/usr/bin/tegrastats-gtk
+Name[C]=Tegrastats-gtk
+Name=Tegrastats-gtk
+Icon=gnome-monitor.png
diff --git a/recipes-bsp/tegrastats/files/apalis-tk1/tegrastats b/recipes-bsp/tegrastats/files/apalis-tk1/tegrastats
new file mode 100755
index 0000000..22a42cf
--- /dev/null
+++ b/recipes-bsp/tegrastats/files/apalis-tk1/tegrastats
Binary files differ
diff --git a/recipes-bsp/tegrastats/files/tegrastats b/recipes-bsp/tegrastats/files/tegrastats
new file mode 100755
index 0000000..5f76593
--- /dev/null
+++ b/recipes-bsp/tegrastats/files/tegrastats
Binary files differ
diff --git a/recipes-bsp/tegrastats/files/tegrastats-gtk b/recipes-bsp/tegrastats/files/tegrastats-gtk
new file mode 100755
index 0000000..53d250d
--- /dev/null
+++ b/recipes-bsp/tegrastats/files/tegrastats-gtk
Binary files differ
diff --git a/recipes-bsp/tegrastats/tegrastats.bb b/recipes-bsp/tegrastats/tegrastats.bb
new file mode 100644
index 0000000..9795c47
--- /dev/null
+++ b/recipes-bsp/tegrastats/tegrastats.bb
@@ -0,0 +1,31 @@
+SUMMARY = "NVIDIAS tegrastats"
+DESCRIPTION = "NVIDIAS tegrastats in a commandline version and one with output to a gtk title bar, gives information about cpu use"
+LICENSE = "CLOSED"
+PR = "r3"
+
+RDEPENDS_{PN}-gtk = "pango"
+
+SRC_URI = "file://tegrastats \
+ file://tegrastats-gtk \
+ file://Tegrastats-gtk.desktop "
+
+S = "${WORKDIR}"
+
+PACKAGES = "${PN} ${PN}-gtk"
+
+# Inhibit warnings about files being stripped.
+# Inhibit warnings about missing DEPENDS, Files are provided in binary form"
+WARN_QA_remove = "already-stripped build-deps"
+WARN_QA-gtk_remove = "already-stripped build-deps"
+
+do_install() {
+ install -d ${D}${bindir}/ ${D}/home/root/Desktop/
+ install -m 0755 ${S}/tegrastats* ${D}${bindir}/
+ install -m 0755 ${S}/Tegrastats-gtk.desktop ${D}/home/root/Desktop/
+}
+
+FILES_${PN}-gtk = " \
+ ${bindir}/tegrastats-gtk \
+ /home/root/Desktop/Tegra* "
+
+FILES_${PN} = "${bindir}/tegrastats"