summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-04 11:46:12 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-04 11:46:12 +0200
commit36df082f125fdb623622c6defed03c112539cd1e (patch)
tree9d0b4dd6c94a42cf43320c3880313f1a4a86f11e /recipes-bsp
parent0830ab52006c43674294c942c3feb224cbb34606 (diff)
linux-driver-package: fix do rootfs
Assign the systemd service in the package providing them. Prevents the following do_rootfs error if linux-driver-package is installed but linux-driver-package-*boot is not: | WARNING: linux-driver-package.postinst returned 1, marking as unpacked only, configuration required on target. | ERROR: Postinstall scriptlets of ['linux-driver-package'] have failed. If the intention is to defer them to first boot, | then please place them into pkg_postinst_ontarget_${PN} (). This is caused by sytemctl trying to enable the not existing services nv.service and nvfb.service. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend b/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
index 90bc0ae..73fa967 100644
--- a/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
+++ b/recipes-bsp/binary-drivers/linux-driver-package_21.%.bbappend
@@ -96,4 +96,5 @@ do_install_append () {
install -m 0755 ${NV_SAMPLE}/usr/lib/arm-linux-gnueabihf/gstreamer-0.10/libnvgstjpeg.so ${D}${libdir}/gstreamer-0.10
}
-SYSTEMD_SERVICE_${PN} = "nvfb.service nv.service"
+SYSTEMD_SERVICE_${PN}-boot = "nv.service"
+SYSTEMD_SERVICE_${PN}-firstboot = "nvfb.service"