summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-10-03 02:55:21 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-10-05 02:26:20 +0200
commit9a94e068d24d143ea5c4ef66c4e81e156e0c405d (patch)
tree525de992dc61893a5af1579a5c4a5e337e80fa23 /recipes-bsp
parentda8cdb00dcc73ce9cb6809b6732a6a1153accbf5 (diff)
u-boot-toradex: apalis-tk1/apalis-tk1-mainline: generate cbootimage
Generate cbootimage already during build as required for Toradex Easy Installer BSP package. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Dominik Sliwa <dominik.sliwa@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/files/tegra124/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bctbin0 -> 8192 bytes
-rw-r--r--recipes-bsp/u-boot/files/tegra124/apalis-tk1.img.cfg22
-rw-r--r--recipes-bsp/u-boot/files/tegra124m/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bctbin0 -> 8192 bytes
-rw-r--r--recipes-bsp/u-boot/files/tegra124m/apalis-tk1.img.cfg22
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_git.bb23
5 files changed, 67 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/files/tegra124/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct b/recipes-bsp/u-boot/files/tegra124/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
new file mode 100644
index 0000000..556a40e
--- /dev/null
+++ b/recipes-bsp/u-boot/files/tegra124/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
Binary files differ
diff --git a/recipes-bsp/u-boot/files/tegra124/apalis-tk1.img.cfg b/recipes-bsp/u-boot/files/tegra124/apalis-tk1.img.cfg
new file mode 100644
index 0000000..b9d203c
--- /dev/null
+++ b/recipes-bsp/u-boot/files/tegra124/apalis-tk1.img.cfg
@@ -0,0 +1,22 @@
+# Copyright (C) 2016 Toradex, Inc.
+#
+# This software is provided 'as-is', without any express or implied
+# warranty. In no event will the authors be held liable for any damages
+# arising from the use of this software.
+#
+# Permission is granted to anyone to use this software for any purpose,
+# including commercial applications, and to alter it and redistribute it
+# freely, subject to the following restrictions:
+#
+# 1. The origin of this software must not be misrepresented; you must not
+# claim that you wrote the original software. If you use this software
+# in a product, an acknowledgment in the product documentation would be
+# appreciated but is not required.
+# 2. Altered source versions must be plainly marked as such, and must not be
+# misrepresented as being the original software.
+# 3. This notice may not be removed or altered from any source distribution.
+
+Version = 0x00400001;
+Bctcopy = 1;
+Bctfile = PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct;
+BootLoader = u-boot-dtb-tegra.bin,0x80108000,0x80108000,Complete;
diff --git a/recipes-bsp/u-boot/files/tegra124m/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct b/recipes-bsp/u-boot/files/tegra124m/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
new file mode 100644
index 0000000..556a40e
--- /dev/null
+++ b/recipes-bsp/u-boot/files/tegra124m/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
Binary files differ
diff --git a/recipes-bsp/u-boot/files/tegra124m/apalis-tk1.img.cfg b/recipes-bsp/u-boot/files/tegra124m/apalis-tk1.img.cfg
new file mode 100644
index 0000000..b9d203c
--- /dev/null
+++ b/recipes-bsp/u-boot/files/tegra124m/apalis-tk1.img.cfg
@@ -0,0 +1,22 @@
+# Copyright (C) 2016 Toradex, Inc.
+#
+# This software is provided 'as-is', without any express or implied
+# warranty. In no event will the authors be held liable for any damages
+# arising from the use of this software.
+#
+# Permission is granted to anyone to use this software for any purpose,
+# including commercial applications, and to alter it and redistribute it
+# freely, subject to the following restrictions:
+#
+# 1. The origin of this software must not be misrepresented; you must not
+# claim that you wrote the original software. If you use this software
+# in a product, an acknowledgment in the product documentation would be
+# appreciated but is not required.
+# 2. Altered source versions must be plainly marked as such, and must not be
+# misrepresented as being the original software.
+# 3. This notice may not be removed or altered from any source distribution.
+
+Version = 0x00400001;
+Bctcopy = 1;
+Bctfile = PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct;
+BootLoader = u-boot-dtb-tegra.bin,0x80108000,0x80108000,Complete;
diff --git a/recipes-bsp/u-boot/u-boot-toradex_git.bb b/recipes-bsp/u-boot/u-boot-toradex_git.bb
index 37a623b..e684d80 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_git.bb
@@ -4,6 +4,8 @@ inherit tegra-u-boot-localversion
PROVIDES = "u-boot virtual/bootloader"
DEPENDS += "dtc-native"
+DEPENDS_append_apalis-tk1 = " cbootimage-native"
+DEPENDS_append_apalis-tk1-mainline = " cbootimage-native"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
@@ -21,6 +23,14 @@ S = "${WORKDIR}/git"
SRCREV = "1b121c6ab548a9af0a27876e9eaa0c654c1dc3e1"
SRCBRANCH = "2016.11-toradex"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
+SRC_URI_append_apalis-tk1 = " \
+ file://apalis-tk1.img.cfg \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
+SRC_URI_append_apalis-tk1-mainline = " \
+ file://apalis-tk1.img.cfg \
+ file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
+"
PV = "2016.11"
PR = "${TDX_VER_INT}+gitr${SRCPV}"
@@ -31,3 +41,16 @@ UBOOT_BINARY = "u-boot-dtb-tegra.${UBOOT_SUFFIX}"
UBOOT_SYMLINK = "u-boot-dtb-tegra-${MACHINE}.${UBOOT_SUFFIX}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_deploy_append_apalis-tk1() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}
+do_deploy_append_apalis-tk1-mainline() {
+ cd ${DEPLOYDIR}
+ cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
+ cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
+ rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
+}