summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-09-19 12:32:47 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 18:53:16 +0100
commitab75942d98ca6cd07c73632bd56200740033f235 (patch)
tree7b50ca65dac9a796fe31358163d3fc8b4939a2b9 /recipes-bsp
parent01ab73979ba76c39f3a8f5aa7018b138fb64248e (diff)
pkg_postinst: move to the ontarget syntax
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb2
-rw-r--r--recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb6
3 files changed, 3 insertions, 7 deletions
diff --git a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
index fbcd276..3e81a4e 100644
--- a/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
+++ b/recipes-bsp/lvds-ctrl/lvds-ctrl_1.0.bb
@@ -15,7 +15,7 @@ do_install () {
install -m 0755 ${WORKDIR}/*.sh ${D}/${bindir}
}
-pkg_postinst_${PN}() {
+pkg_postinst_ontarget_${PN}() {
mkdir -p ${sysconfdir}/xdg/lxsession/LXDE
echo "${bindir}/lvds-single-channel-24bit-mode2.sh" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
}
diff --git a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
index 7b0ef3b..8cd1b8e 100644
--- a/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
+++ b/recipes-bsp/lvds-ctrl/lvds-tegra124_1.0.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING;md5=1c3a7fb45253c11c74434676d84fe7
ALLOW_EMPTY_${PN} = "1"
-pkg_postinst_${PN}() {
+pkg_postinst_ontarget_${PN}() {
mkdir -p ${sysconfdir}/xdg/lxsession/LXDE
echo "@xrandr --output HDMI-0 --auto --primary --output LVDS-0 --auto --right-of HDMI-0" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
echo "#@xrandr --output LVDS-0 --auto --primary --output HDMI-0 --auto --right-of LVDS-0" >> ${sysconfdir}/xdg/lxsession/LXDE/autostart
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index 097c711..5dba294 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -71,11 +71,7 @@ do_install_append_tegra124m() {
install_unlock_emmc
}
-pkg_postinst_${PN}_colibri-t20 () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
+pkg_postinst_ontarget_${PN}_colibri-t20 () {
grep u-boot-env /proc/mtd | awk '{print "/dev/" substr($1,0,4) " 0x00000000 0x00010000 0x" $3 " 1" >> "/etc/fw_env.config" }'
}