summaryrefslogtreecommitdiff
path: root/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-10-21 20:33:30 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-10-21 20:33:30 +0200
commit491b9879861573db507cf0429fcf5e2d75a2e265 (patch)
tree2c8b300b61c8d404edfff9fcfef631575aa7541c /recipes-core/hdmi-hotplug/hdmi-hotplug.bb
parent64becaba0c1d33fa2536fcf2a00ee9da93ec657e (diff)
hdmi: add udev rule to start an X output on hotplug
Diffstat (limited to 'recipes-core/hdmi-hotplug/hdmi-hotplug.bb')
-rw-r--r--recipes-core/hdmi-hotplug/hdmi-hotplug.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-core/hdmi-hotplug/hdmi-hotplug.bb b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
new file mode 100644
index 0000000..ee89956
--- /dev/null
+++ b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
@@ -0,0 +1,20 @@
+SECTION = "core"
+DESCRIPTION = "Use xrandr after a HDMI hotplug event has been detected to switch the display on"
+RDEPENDS_${PN} = ""
+# The license is meant for this recipe and the files it installs.
+# RNDIS is part of the kernel, udhcpd is part of busybox
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r1"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = " \
+ file://hdmi.rules \
+"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/hdmi.rules ${D}/${sysconfdir}/udev/rules.d/
+}