summaryrefslogtreecommitdiff
path: root/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
diff options
context:
space:
mode:
authorLeonardo Graboski Veiga <leogveiga@gmail.com>2017-03-29 10:34:21 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-10 09:11:43 +0200
commit80384c3824aa4c6d7a30dd74949b90b711006034 (patch)
tree3267f6c58e2c1a9435eb727e63631a4810a073df /recipes-core/hdmi-hotplug/hdmi-hotplug.bb
parent2716f83906094878e24b93c8ae1b7c6babbb5076 (diff)
hdmi-hotplug: fix issue for the apalis/colibri tegra modules
The hdmi.sh script, triggered by udev, export the DISPLAY environment variable and uses the Xauthority configuration file to enable xrandr to run. Also restarts LXDE after xrandr, adjusting the taskbar length to the new display width. Signed-off-by: Leonardo Graboski Veiga <leogveiga@gmail.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-core/hdmi-hotplug/hdmi-hotplug.bb')
-rw-r--r--recipes-core/hdmi-hotplug/hdmi-hotplug.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-core/hdmi-hotplug/hdmi-hotplug.bb b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
index 5c75d52..6147243 100644
--- a/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
+++ b/recipes-core/hdmi-hotplug/hdmi-hotplug.bb
@@ -9,9 +9,15 @@ PR = "r1"
PACKAGE_ARCH = "all"
-SRC_URI = "file://hdmi.rules"
+SRC_URI = " \
+ file://hdmi.rules \
+ file://hdmi.sh \
+"
do_install() {
install -d ${D}/${sysconfdir}/udev/rules.d
install -m 0644 ${WORKDIR}/hdmi.rules ${D}/${sysconfdir}/udev/rules.d/
+
+ install -d ${D}/${sysconfdir}/udev/scripts
+ install -m 0755 ${WORKDIR}/hdmi.sh ${D}/${sysconfdir}/udev/scripts/
}