summaryrefslogtreecommitdiff
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-12-12 14:32:02 +0100
committerMax Krummenacher <max.oss.09@gmail.com>2015-03-31 21:50:34 +0200
commitcaa84f685d4af72c5945c3cfa3ed25701357843b (patch)
treecbdd548724c43c393e9358107b5481ff1223f211 /recipes-graphics/mesa/mesa_%.bbappend
parent84edbcc21b84c3aaa2f47a906ac040905d5a11bc (diff)
mesa: remove egl, gles instead of using mesa-gl
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend36
1 files changed, 3 insertions, 33 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 9481604..23b9af6 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,38 +1,8 @@
# we use binary only EGL, GL ES1, GL ES2 drivers (package trdx-nv-binaries)
# adapted from meta-fsl-arm/recipes-graphics/mesa/
# FIXME: We may need to disable EGL, GL ES1 and GL ES2
-python __anonymous () {
- import re
+PACKAGECONFIG_remove_tegra = "egl gles"
- # SoC families to work on
- families = ['tegra']
- cur_soc_families = d.getVar('SOC_FAMILY', True)
- if cur_soc_families and \
- any(map(lambda x: x in cur_soc_families.split(':'), families)):
- # Remove egl gles1 and gles2 configure options
- extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
- take_out = ['--enable-egl', '--enable-gles1', '--enable-gles2']
- put_in = ['--disable-egl', '--disable-gles1', '--disable-gles2']
- pattern = re.compile("--with-egl-platforms")
- new_extra_oeconf = []
- for i in extra_oeconf:
- if i not in take_out and not pattern.match(i):
- new_extra_oeconf.append(i)
- for i in put_in:
- new_extra_oeconf.append(i)
+PROVIDES_remove_tegra = "virtual/libgles1 virtual/libgles2 virtual/egl"
- d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
-
- # Remove itens from provides
- provides = d.getVar('PROVIDES', True).split()
- take_out = ['virtual/libgles1', 'virtual/libgles2', 'virtual/egl']
- new_provides = []
- for i in provides:
- if i not in take_out:
- new_provides.append(i)
-
- d.setVar('PROVIDES', ' '.join(new_provides))
-
- # We are now machine specific
- d.setVar('PACKAGE_ARCH', d.getVar('MACHINE_ARCH'))
-}
+PACKAGE_ARCH = "${MACHINE_ARCH}"