summaryrefslogtreecommitdiff
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
authorDominik Sliwa <dominik.sliwa@toradex.com>2017-01-09 17:35:46 +0100
committerDominik Sliwa <dominik.sliwa@toradex.com>2017-01-11 21:59:33 +0100
commit6c22936df0c551961df61cc428e6590d2f8bbb6d (patch)
tree163ad22e51e402a02ac2fd98156f1db0f750d3a1 /recipes-graphics/mesa/mesa_%.bbappend
parentd54c4ca13c2976671fb2e91b774ae1a94039715a (diff)
apalis-tk1-mainline: Move GPU acceleration support to mesa
Instead of patching every app, let's patch mesa to pretend that we have a normal GPU. based on: github.com/Gnurou/mesa/commits/renderonly Signed-off-by: Dominik Sliwa <dominik.sliwa@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend24
1 files changed, 23 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 52b9e33..1865a1d 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -23,7 +23,29 @@ DEPENDS_remove = "${DEPENDS_REMOVE}"
#####
## Tegra TK1 mainline kernel
-PACKAGECONFIG_append_tegra124m = "dri3 egl gles gallium "
+PACKAGECONFIG_append_tegra124m = "dri3 egl gles gallium gbm "
+
+PE_tegra124m = "99"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+EXTRA_OECONF_append_tegra124m = " --enable-texture-float --without-dri-drivers --enable-glx --enable-osmesa --enable-debug"
+
+SRC_URI_append_tegra124m = "\
+ file://0001-gallium-add-renderonly-library.patch \
+ file://0004-gallium-add-tegra-support.patch \
+ file://0005-tegra-open-card1-instead-of-renderD128.patch \
+ file://0006-HACK-make-DRI-work-under-X.patch \
+ file://0008-remove-dependency-on-libdrm_tegra.patch \
+ "
+PACKAGE_ARCH_tegra124m = "${MACHINE_ARCH}"
+
+DRIDRIVERS_tegra124m = " "
+
+GALLIUMDRIVERS_tegra124m = "tegra"
+
+COMPATIBLE_MACHINE_tegra124m = "(apalis-tk1-mainline)"
+
# until meta-jetson-tk1 adds it through its bbappend:
DEPENDS_append_tegra124= " linux-driver-package "