summaryrefslogtreecommitdiff
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-09-29 22:30:42 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-09-29 23:08:21 +0200
commit8263c26d4eedaf903d8f47e583c025aba50de2de (patch)
treed190c8a6004671dc1dcb4519e374c65d9f2d97c8 /recipes-graphics/mesa/mesa_%.bbappend
parente48613aece9a1bef83888028aab75b8c36cda0ed (diff)
linux-driver-package, mesa: rework the recipe
Recent OE adds additional shared object checks which errors out on the way the binary Tegra drivers are injected. Rework the recipes, so that - mesa no longer PROVIDE any OpenGL shared objects and the binaries. - linux-driver-package now depends on mesa to install development headers - linux-driver-package PROVIDE and RPROVIDE the OpenGL shared objects. - linux-driver-package drops the additional arm-linux-gnueabihf/tegra path to the *.so* files. - the apalis-tk1 machine PREFERS linux-driver-package as the OpenGL provider. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend14
1 files changed, 9 insertions, 5 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index c34c789..b3f960f 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,13 +1,17 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
#####
# tegra tk1
-DEPENDS_append_tegra124= " linux-driver-package"
-SRC_URI_append_tegra124 = " file://0001-pkg-config-files-add-tegra-paths.patch"
-
PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
+PROVIDES_remove_tegra124 = "virtual/egl virtual/libgl virtual/libgles1 virtual/libgles2"
+
+do_install_append_tegra124 () {
+ rm ${D}${libdir}/libEGL.so*
+ rm ${D}${libdir}/libGL.so*
+ rm ${D}${libdir}/libGLESv1*.so*
+ rm ${D}${libdir}/libGLESv2.so*
+}
+
#####
## Tegra TK1 mainline kernel