summaryrefslogtreecommitdiff
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-06-23 00:29:25 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-06-30 13:28:28 +0200
commitb0cc8f27a09bc513fb42d308fff95d9b6cb35bfb (patch)
treee0b41b74f5c4eb1e14a5bb5e17121c28ef9dd52b /recipes-graphics/mesa
parent05daa9a61e701c3438744c38e6b1899bb7aa6ed7 (diff)
mesa: integrate apalis-tk1, work around watatuki's meta-jetson-tk1 flaw
Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa/apalis-tk1/tegra-path-add.pcp49
-rw-r--r--recipes-graphics/mesa/mesa/tegra-path-add.pcp0
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend12
3 files changed, 61 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa/apalis-tk1/tegra-path-add.pcp b/recipes-graphics/mesa/mesa/apalis-tk1/tegra-path-add.pcp
new file mode 100644
index 0000000..0d23203
--- /dev/null
+++ b/recipes-graphics/mesa/mesa/apalis-tk1/tegra-path-add.pcp
@@ -0,0 +1,49 @@
+diff --git a/usr/lib/pkgconfig/egl.pc b/usr/lib/pkgconfig/egl.pc
+index 1a817e5..a82163d 100644
+--- a/usr/lib/pkgconfig/egl.pc
++++ b/usr/lib/pkgconfig/egl.pc
+@@ -7,6 +7,6 @@ Name: egl
+ Description: Mesa EGL library
+ Requires.private: libdrm >= 2.4.38 x11 xext xdamage xfixes x11-xcb xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xxf86vm
+ Version: 10.6.3
+-Libs: -L${libdir} -lEGL
++Libs: -L${libdir}/arm-linux-gnueabihf/tegra-egl -L${libdir} -lEGL
+ Libs.private: -lm -lpthread -ldl
+ Cflags: -I${includedir}
+diff --git a/usr/lib/pkgconfig/gl.pc b/usr/lib/pkgconfig/gl.pc
+index c753814..20876c7 100644
+--- a/usr/lib/pkgconfig/gl.pc
++++ b/usr/lib/pkgconfig/gl.pc
+@@ -7,7 +7,7 @@ Name: gl
+ Description: Mesa OpenGL library
+ Requires.private: libdrm >= 2.4.38 x11 xext xdamage xfixes x11-xcb xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8 xxf86vm
+ Version: 10.6.3
+-Libs: -L${libdir} -lGL
++Libs: -L${libdir}/arm-linux-gnueabihf/tegra -L${libdir} -lGL
+ Libs.private: -lm -lpthread -ldl
+ Cflags: -I${includedir}
+ glx_tls: yes
+diff --git a/usr/lib/pkgconfig/glesv1_cm.pc b/usr/lib/pkgconfig/glesv1_cm.pc
+index 0598afe..d7c36a5 100644
+--- a/usr/lib/pkgconfig/glesv1_cm.pc
++++ b/usr/lib/pkgconfig/glesv1_cm.pc
+@@ -7,6 +7,6 @@ Name: glesv1_cm
+ Description: Mesa OpenGL ES 1.1 CM library
+ Requires.private:
+ Version: 10.6.3
+-Libs: -L${libdir} -lGLESv1_CM
++Libs: -L${libdir}/arm-linux-gnueabihf/tegra-egl -L${libdir} -lGLESv1_CM
+ Libs.private: -lm -lpthread -ldl
+ Cflags: -I${includedir}
+diff --git a/usr/lib/pkgconfig/glesv2.pc b/usr/lib/pkgconfig/glesv2.pc
+index edd1b35..f06578b 100644
+--- a/usr/lib/pkgconfig/glesv2.pc
++++ b/usr/lib/pkgconfig/glesv2.pc
+@@ -7,6 +7,6 @@ Name: glesv2
+ Description: Mesa OpenGL ES 2.0 library
+ Requires.private:
+ Version: 10.6.3
+-Libs: -L${libdir} -lGLESv2
++Libs: -L${libdir}/arm-linux-gnueabihf/tegra-egl -L${libdir} -lGLESv2
+ Libs.private: -lm -lpthread -ldl
+ Cflags: -I${includedir}
diff --git a/recipes-graphics/mesa/mesa/tegra-path-add.pcp b/recipes-graphics/mesa/mesa/tegra-path-add.pcp
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/recipes-graphics/mesa/mesa/tegra-path-add.pcp
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 1a810be..0e10115 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -6,3 +6,15 @@ PACKAGECONFIG_remove_tegra = "egl gles"
PROVIDES_remove_tegra = "virtual/libgles1 virtual/libgles2 virtual/egl"
PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
+
+#####
+
+PACKAGE_ARCH_apalis-tk1 = "${MACHINE_ARCH}"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+DEPENDS_REMOVE = "linux-driver-package"
+
+DEPENDS_REMOVE_apalis-tk1 = ""
+
+DEPENDS_remove = "${DEPENDS_REMOVE}"