summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-06-23 00:26:13 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-06-30 13:28:28 +0200
commit6598c1f1a536b2b727ffb7cf9040f030f17791f6 (patch)
treead33dc71c30df2638cc70fe5820d882324224a34 /recipes-graphics
parent3965265c1f9e2244adb30d10cd2ada5da2777794 (diff)
mesa-glut: fix building on arm
Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa-glut/0001-mesa-glut-fix-building-on-arm.patch89
-rw-r--r--recipes-graphics/mesa/mesa-glut_%.bbappend3
2 files changed, 92 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa-glut/0001-mesa-glut-fix-building-on-arm.patch b/recipes-graphics/mesa/mesa-glut/0001-mesa-glut-fix-building-on-arm.patch
new file mode 100644
index 0000000..3068af1
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-glut/0001-mesa-glut-fix-building-on-arm.patch
@@ -0,0 +1,89 @@
+From 051b05b30dc0fce0585ee16d1d1a7f6f959794a6 Mon Sep 17 00:00:00 2001
+From: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+Date: Tue, 14 Jun 2016 14:55:48 +0200
+Subject: [PATCH] mesa-glut: fix building on arm
+
+Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+---
+ bin/mklib | 30 ------------------------------
+ configure.ac | 9 ---------
+ 2 files changed, 39 deletions(-)
+
+diff --git a/bin/mklib b/bin/mklib
+index 2c7ed38..e29a404 100755
+--- a/bin/mklib
++++ b/bin/mklib
+@@ -330,14 +330,6 @@ case $ARCH in
+ ;;
+ esac
+
+- # Check if objects are 32-bit and we're running in 64-bit
+- # environment. If so, pass -m32 flag to linker.
+- set ${OBJECTS}
+- ABI32=`file $1 | grep 32-bit`
+- if [ "${ABI32}" -a `uname -m` = "x86_64" ] ; then
+- OPTS="-m32 ${OPTS}"
+- fi
+-
+ if [ "${ALTOPTS}" ] ; then
+ OPTS=${ALTOPTS}
+ fi
+@@ -387,17 +379,6 @@ case $ARCH in
+ # exptmp is removed below
+ fi
+
+- # Check if objects are 32-bit and we're running in 64-bit
+- # environment. If so, pass -m32 flag to linker.
+- set ${OBJECTS}
+- ABI32=`file $1 | grep 32-bit`
+- if [ "${ABI32}" -a `uname -m` = "x86_64" ] ; then
+- OPTS="-m32 ${OPTS}"
+- fi
+- if [ "${ALTOPTS}" ] ; then
+- OPTS=${ALTOPTS}
+- fi
+-
+ if [ x${PATCH} = "x" ] ; then
+ VERSION="${MAJOR}.${MINOR}"
+ else
+@@ -457,17 +438,6 @@ case $ARCH in
+ if [ ${LINK} = "ld" -o ${LINK} = "cc" -o ${LINK} = "CC" ] ; then
+ # SunOS tools, -G to make shared libs
+ OPTS="-G"
+- else
+- # gcc linker
+- # Check if objects are 32-bit and we're running in 64-bit
+- # environment. If so, pass -m32 flag to linker.
+- set ${OBJECTS}
+- ABI32=`file $1 | grep 32-bit`
+- if [ "${ABI32}" ] ; then
+- OPTS="-m32 -shared -Wl,-Bdynamic"
+- else
+- OPTS="-m64 -shared -Wl,-Bdynamic"
+- fi
+ fi
+
+ # If using Sun C++ compiler, need to tell it not to add runpaths
+diff --git a/configure.ac b/configure.ac
+index d42b5c6..af40093 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -204,15 +204,6 @@ AC_ARG_ENABLE([32-bit],
+ [enable_32bit="$enableval"],
+ [enable_32bit=auto]
+ )
+-if test "x$enable_32bit" = xyes; then
+- if test "x$GCC" = xyes; then
+- CFLAGS="$CFLAGS -m32"
+- ARCH_FLAGS="$ARCH_FLAGS -m32"
+- fi
+- if test "x$GXX" = xyes; then
+- CXXFLAGS="$CXXFLAGS -m32"
+- fi
+-fi
+ AC_ARG_ENABLE([64-bit],
+ [AS_HELP_STRING([--enable-64-bit],
+ [build 64-bit libraries @<:@default=auto@:>@])],
+--
+2.5.5
+
diff --git a/recipes-graphics/mesa/mesa-glut_%.bbappend b/recipes-graphics/mesa/mesa-glut_%.bbappend
new file mode 100644
index 0000000..06e17bf
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-glut_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/mesa-glut:"
+
+SRC_URI_append_arm = " file://0001-mesa-glut-fix-building-on-arm.patch"