summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-12-01 17:43:41 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 12:03:36 +0100
commit683839964d64e2b3b60bd5f3c791bd7f691d6f06 (patch)
tree363d5a79ea13d7e7b3efcffc4e8acad5bf93ca00 /recipes-graphics
parent16ccaddd806fec102cd01d2f74c9a7ccba498dd3 (diff)
mesa_%.bbappend: use soc family instead of machine override
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index dc45496..3fdda76 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,3 +1,4 @@
+# tegra2, tegra3
# we use binary only EGL, GL ES1, GL ES2 drivers (package trdx-nv-binaries)
# adapted from meta-fsl-arm/recipes-graphics/mesa/
# FIXME: We may need to disable EGL, GL ES1 and GL ES2
@@ -8,16 +9,17 @@ PROVIDES_remove_tegra = "virtual/libgles1 virtual/libgles2 virtual/egl"
PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
#####
+# tegra tk1
-PACKAGE_ARCH_apalis-tk1 = "${MACHINE_ARCH}"
+PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
DEPENDS_REMOVE = "linux-driver-package"
-DEPENDS_REMOVE_apalis-tk1 = ""
+DEPENDS_REMOVE_tegra124 = ""
DEPENDS_remove = "${DEPENDS_REMOVE}"
# until meta-jetson-tk1 adds it through its bbappend:
-DEPENDS_append_apalis-tk1 = "linux-driver-package " \ No newline at end of file
+DEPENDS_append_tegra124= " linux-driver-package "