summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-08-26 15:25:08 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-08-26 15:25:08 +0200
commiteacfc89bb87d171c3087fcaf520d8968b8020e31 (patch)
treec29b1a9aeae80aee03b614a2d0516ff23511673d /recipes-graphics
parentd1a88bb643be16cb2c976121f5470ec4f9debbf5 (diff)
xserver: enable xinerame for apalis-t30 platform
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
new file mode 100644
index 0000000..6bf44ff
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -0,0 +1,23 @@
+# When Apalis T30 is used with a external NV graphics card, the binary
+# only driver fails (the dynamic linker can not resolve all symbols),
+# when xinerama is disabled in the X server
+
+# adapted from meta-fsl-arm/recipes-graphics/mesa/
+python __anonymous () {
+ import re
+
+ cur_machine = d.getVar('MACHINE', True)
+ if cur_machine == 'apalis-t30':
+ # Remove --disable-xinerama from EXTRA_OECONF
+ extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
+ take_out = ['--disable-xinerama']
+ new_extra_oeconf = []
+ for i in extra_oeconf:
+ if i not in take_out:
+ new_extra_oeconf.append(i)
+
+ d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
+
+ # We are now machine specific
+ d.setVar('PACKAGE_ARCH', d.getVar('MACHINE_ARCH'))
+}