summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-11-18 15:18:51 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-12-08 02:20:27 +0100
commit54fcd0df1d3a1cc439d347bb7fd48fb92d68c454 (patch)
treefe817479e0a5223dda08912df9a05507c511f0bb /recipes-graphics
parente4de5cfe2832c04670ac154fa5ae02fa53c75c39 (diff)
eglinfo-x11: add bbappend for tegra
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/eglinfo/eglinfo-x11_%.bbappend13
-rw-r--r--recipes-graphics/eglinfo/files/eglinfo.patch15
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
new file mode 100644
index 0000000..f3eb4fd
--- /dev/null
+++ b/recipes-graphics/eglinfo/eglinfo-x11_%.bbappend
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+PACKAGE_ARCH_tegra = "${MACHINE_ARCH}"
+
+# Set Tegra specific dependencies and device type
+DEPENDS_tegra += "virtual/libgles2"
+EGLINFO_DEVICE_tegra = "generic"
+
+SRCREV = "223817ee37988042db7873cfb5b2e899dfe35c10"
+
+SRC_URI_append_tegra = " \
+ file://eglinfo.patch \
+"
diff --git a/recipes-graphics/eglinfo/files/eglinfo.patch b/recipes-graphics/eglinfo/files/eglinfo.patch
new file mode 100644
index 0000000..54cae6f
--- /dev/null
+++ b/recipes-graphics/eglinfo/files/eglinfo.patch
@@ -0,0 +1,15 @@
+diff -Naur git.orig/src/glapi_stats.cpp git/src/glapi_stats.cpp
+--- git.orig/src/glapi_stats.cpp 2014-11-18 14:45:09.249549002 +0100
++++ git/src/glapi_stats.cpp 2014-11-18 14:45:47.869736011 +0100
+diff -Naur git.orig/src/platform_x11_generic.cpp git/src/platform_x11_generic.cpp
+--- git.orig/src/platform_x11_generic.cpp 2014-11-18 14:45:09.252549095 +0100
++++ git/src/platform_x11_generic.cpp 2014-11-18 14:45:57.578034399 +0100
+@@ -91,7 +91,7 @@
+ if (m_egl_native_window)
+ XDestroyWindow(
+ reinterpret_cast < Display* > (m_native_display.get_egl_native_display())
+- , reinterpret_cast < Window > (m_egl_native_window)
++ , reinterpret_cast < Window > ((long unsigned int)m_egl_native_window)
+ );
+ }
+