summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-05-17 11:09:41 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-05-28 12:29:05 +0200
commitd13caaba2d90f856b944ebde44967b679d3eb3a9 (patch)
tree417d262852123f10c03838f81bc51bda9c2c3a03 /recipes-graphics
parent7a56c4b0ae2a656cde85ab8b369e6bc2969ca91c (diff)
apalis-tk1: drop machine
The downstream kernel gets to old to be used with the new zeus userspace components. Drop the machine. Related-to: ELB-2733 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/drm/libdrm_%.bbappend1
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend14
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/apalis-tk1/xorg.conf0
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend1
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch63
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch41
-rwxr-xr-xrecipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch25
-rwxr-xr-xrecipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb61
8 files changed, 0 insertions, 206 deletions
diff --git a/recipes-graphics/drm/libdrm_%.bbappend b/recipes-graphics/drm/libdrm_%.bbappend
index 01a9340..556cd85 100644
--- a/recipes-graphics/drm/libdrm_%.bbappend
+++ b/recipes-graphics/drm/libdrm_%.bbappend
@@ -1,5 +1,4 @@
PACKAGES += " ${PN}-tegra"
FILES_${PN}-tegra = "${libdir}/libdrm_tegra.so.*"
-PACKAGECONFIG_append_tegra124 = " tegra"
PACKAGECONFIG_append_tegra124m = " tegra"
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index b3f960f..7b44575 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,18 +1,4 @@
#####
-# tegra tk1
-
-PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
-
-PROVIDES_remove_tegra124 = "virtual/egl virtual/libgl virtual/libgles1 virtual/libgles2"
-
-do_install_append_tegra124 () {
- rm ${D}${libdir}/libEGL.so*
- rm ${D}${libdir}/libGL.so*
- rm ${D}${libdir}/libGLESv1*.so*
- rm ${D}${libdir}/libGLESv2.so*
-}
-
-#####
## Tegra TK1 mainline kernel
PACKAGECONFIG_append_tegra124m = " dri3 egl gles gallium gbm "
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/apalis-tk1/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/apalis-tk1/xorg.conf
deleted file mode 100644
index e69de29..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config/apalis-tk1/xorg.conf
+++ /dev/null
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
deleted file mode 100644
index 3feb3b1..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/xserver-xf86-config:"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch
deleted file mode 100644
index da9a4f2..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xorg/0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 2ba9510721b7a76cb7fe507449fa0ac997a4cce3 Mon Sep 17 00:00:00 2001
-From: Olivier Fourdan <ofourdan@redhat.com>
-Date: Mon, 1 Jul 2019 13:20:39 +0200
-Subject: [PATCH] compiler.h: Do not include sys/io.h on ARM with glibc
-
-<sys/io.h> on ARM hasn't worked for a long, long time, so it was removed
-it from glibc upstream.
-
-Remove the include to avoid a compilation failure on ARM with glibc.
-
-Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
-Closes: https://gitlab.freedesktop.org/xorg/xserver/issues/840
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Backport [https://gitlab.freedesktop.org/xorg/xserver/commit/fe4cd0e7f5c58fa94db36326aadc1bd4e6d73eba]
----
- hw/xfree86/common/compiler.h | 30 ------------------------------
- 1 file changed, 30 deletions(-)
-
-diff --git a/hw/xfree86/common/compiler.h b/hw/xfree86/common/compiler.h
-index 7144c6a..2b2008b 100644
---- a/hw/xfree86/common/compiler.h
-+++ b/hw/xfree86/common/compiler.h
-@@ -758,36 +758,6 @@ inl(unsigned short port)
- return xf86ReadMmio32Le((void *) ioBase, port);
- }
-
--#elif defined(__arm__) && defined(__linux__)
--
--/* for Linux on ARM, we use the LIBC inx/outx routines */
--/* note that the appropriate setup via "ioperm" needs to be done */
--/* *before* any inx/outx is done. */
--
--#include <sys/io.h>
--
--static __inline__ void
--xf_outb(unsigned short port, unsigned char val)
--{
-- outb(val, port);
--}
--
--static __inline__ void
--xf_outw(unsigned short port, unsigned short val)
--{
-- outw(val, port);
--}
--
--static __inline__ void
--xf_outl(unsigned short port, unsigned int val)
--{
-- outl(val, port);
--}
--
--#define outb xf_outb
--#define outw xf_outw
--#define outl xf_outl
--
- #elif defined(__nds32__)
-
- /*
---
-2.22.0
-
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch
deleted file mode 100644
index 87a3112..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From ee80095e03efcb6ff62983939c3f7c49c291f12e Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Wed, 19 Sep 2018 20:37:47 +0000
-Subject: [PATCH] sysmacros.h: follow changed include files
-
-minor/major is no longer provided by sys/types.h.
-explicitely include sysmacros.h where needed.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- hw/xfree86/common/xf86Xinput.c | 1 +
- hw/xfree86/os-support/linux/lnx_init.c | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/hw/xfree86/common/xf86Xinput.c b/hw/xfree86/common/xf86Xinput.c
-index 1fb5b16..4fc5a65 100644
---- a/hw/xfree86/common/xf86Xinput.c
-+++ b/hw/xfree86/common/xf86Xinput.c
-@@ -82,6 +82,7 @@
- #include <stdarg.h>
- #include <stdint.h> /* for int64_t */
- #include <sys/types.h>
-+#include <sys/sysmacros.h>
- #include <sys/stat.h>
- #include <unistd.h>
- #ifdef HAVE_SYS_MKDEV_H
-diff --git a/hw/xfree86/os-support/linux/lnx_init.c b/hw/xfree86/os-support/linux/lnx_init.c
-index 4acaf33..ceae0f1 100644
---- a/hw/xfree86/os-support/linux/lnx_init.c
-+++ b/hw/xfree86/os-support/linux/lnx_init.c
-@@ -37,6 +37,7 @@
- #include "xf86_OSlib.h"
-
- #include <sys/stat.h>
-+#include <sys/sysmacros.h>
-
- #ifndef K_OFF
- #define K_OFF 0x4
---
-2.13.6
-
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch b/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
deleted file mode 100755
index ec0eea6..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xorg/macro_tweak.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-This is the revised version of files/macro_tweak.patch for
-xorg-server 1.8.99.904 and newer.
-
-Upstream-Status: Pending
-
-Signed-off-by: Yu Ke <ke.yu@intel.com>
-
-diff --git a/xorg-server.m4 b/xorg-server.m4
-index bdecf62..040fdb8 100644
---- a/xorg-server.m4
-+++ b/xorg-server.m4
-@@ -28,10 +28,12 @@ dnl
- # Checks for the $1 define in xorg-server.h (from the sdk). If it
- # is defined, then add $1 to $REQUIRED_MODULES.
-
-+m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
-+
- AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
- AC_REQUIRE([PKG_PROG_PKG_CONFIG])
- SAVE_CFLAGS="$CFLAGS"
-- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
-+ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include "xorg-server.h"
- #if !defined $1
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
deleted file mode 100755
index 5e26b33..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
+++ /dev/null
@@ -1,61 +0,0 @@
-# always latest and greatest.
-
-require recipes-graphics/xorg-xserver/xserver-xorg.inc
-
-COMPATIBLE_MACHINE = "(tegra124)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-PE = "99"
-
-DEPENDS_append = " libxfont"
-
-SRC_URI[md5sum] = "1509a9daae713895e7f5bcba8bcc05b2"
-SRC_URI[sha256sum] = "0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457"
-
-SRC_URI += " \
- file://0001-sysmacros.h-follow-changed-include-files.patch \
- file://0001-compiler.h-Do-not-include-sys-io.h-on-ARM-with-glibc.patch \
-"
-
-# These extensions are now integrated into the server, so declare the migration
-# path for in-place upgrades.
-
-RREPLACES_${PN} = "${PN}-extension-dri \
- ${PN}-extension-dri2 \
- ${PN}-extension-record \
- ${PN}-extension-extmod \
- ${PN}-extension-dbe \
- "
-RPROVIDES_${PN} = "${PN}-extension-dri \
- ${PN}-extension-dri2 \
- ${PN}-extension-record \
- ${PN}-extension-extmod \
- ${PN}-extension-dbe \
- "
-RCONFLICTS_${PN} = "${PN}-extension-dri \
- ${PN}-extension-dri2 \
- ${PN}-extension-record \
- ${PN}-extension-extmod \
- ${PN}-extension-dbe \
- "
-
-# The NVidia driver needs xinerama enabled.
-
-# override setting from xserver-xorg.inc which only applies to version 1.18
-# remove systemd:
-#| checking for PIXMAN... yes
-#| checking for SYSTEMD_DAEMON... no
-#| configure: error: systemd support requested but no library has been found
-#| ERROR: Function failed: do_configure (log file is located at /build/krm/oe-core_V2.6.2/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/xserver-xorg/2_1.17.2-r0/temp/log.do_configure.2158)
-
-# provide dga to prevent runtime error
-# X: symbol lookup error: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: DGAInit
-
-PACKAGECONFIG ?= "dga dri2 udev xinerama ${XORG_CRYPTO} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri', '', d)} \
- ${@bb.utils.contains("DISTRO_FEATURES", "opengl wayland", "xwayland", "", d)} \
-"
-
-# provided by xf86-input-evdev_2.10.0
-do_install_append () {
- rm -f ${D}/usr/share/X11/xorg.conf.d/10-evdev.conf
-}