summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-05-01 10:29:47 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-20 16:56:31 +0100
commit6098482ee7540c21c014c27a716b3c79111ea793 (patch)
tree40a39b219658173b68c6313d88dfc99be14cfb41 /recipes-graphics
parentf1f7df50535c947fff45b854e6d00201b172f251 (diff)
mesa: tk1 mainline: forward port patches to 17.0.2
0001-gallium-add-renderonly-library.patch: added upstream 0004-gallium-add-tegra-support.patch, 0008-remove-dependency-on-libdrm_tegra.patch fix patch conflicts Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa/0001-gallium-add-renderonly-library.patch365
-rw-r--r--recipes-graphics/mesa/mesa/0004-gallium-add-tegra-support.patch72
-rw-r--r--recipes-graphics/mesa/mesa/0008-remove-dependency-on-libdrm_tegra.patch19
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend1
4 files changed, 48 insertions, 409 deletions
diff --git a/recipes-graphics/mesa/mesa/0001-gallium-add-renderonly-library.patch b/recipes-graphics/mesa/mesa/0001-gallium-add-renderonly-library.patch
deleted file mode 100644
index 884f59b..0000000
--- a/recipes-graphics/mesa/mesa/0001-gallium-add-renderonly-library.patch
+++ /dev/null
@@ -1,365 +0,0 @@
-From f8bf6404b0133a355a58c72fb4381943a0022959 Mon Sep 17 00:00:00 2001
-From: Christian Gmeiner <christian.gmeiner@gmail.com>
-Date: Sun, 27 Nov 2016 22:27:18 +0100
-Subject: [PATCH 1/8] gallium: add renderonly library
-
-This a very lightweight library to add basic support for
-renderonly GPUs. It does all the magic regarding in/exporting
-buffers etc. This library will likely break android support and
-hopefully will get replaced with a better solution based on gbm2.
-
-Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
----
- src/gallium/Automake.inc | 5 +
- src/gallium/auxiliary/Makefile.am | 10 ++
- src/gallium/auxiliary/Makefile.sources | 4 +
- src/gallium/auxiliary/renderonly/renderonly.c | 199 ++++++++++++++++++++++++++
- src/gallium/auxiliary/renderonly/renderonly.h | 81 +++++++++++
- 5 files changed, 299 insertions(+)
- create mode 100644 src/gallium/auxiliary/renderonly/renderonly.c
- create mode 100644 src/gallium/auxiliary/renderonly/renderonly.h
-
-diff --git a/src/gallium/Automake.inc b/src/gallium/Automake.inc
-index 6fe2e22..6aadcb9 100644
---- a/src/gallium/Automake.inc
-+++ b/src/gallium/Automake.inc
-@@ -50,6 +50,11 @@ GALLIUM_COMMON_LIB_DEPS = \
- $(PTHREAD_LIBS) \
- $(DLOPEN_LIBS)
-
-+if HAVE_LIBDRM
-+GALLIUM_COMMON_LIB_DEPS += \
-+ $(LIBDRM_LIBS)
-+endif
-+
- GALLIUM_WINSYS_CFLAGS = \
- -I$(top_srcdir)/src \
- -I$(top_srcdir)/include \
-diff --git a/src/gallium/auxiliary/Makefile.am b/src/gallium/auxiliary/Makefile.am
-index 4a4a4fb..6b63cf1 100644
---- a/src/gallium/auxiliary/Makefile.am
-+++ b/src/gallium/auxiliary/Makefile.am
-@@ -20,6 +20,16 @@ libgallium_la_SOURCES = \
- $(NIR_SOURCES) \
- $(GENERATED_SOURCES)
-
-+if HAVE_LIBDRM
-+
-+AM_CFLAGS += \
-+ $(LIBDRM_CFLAGS)
-+
-+libgallium_la_SOURCES += \
-+ $(RENDERONLY_SOURCES)
-+
-+endif
-+
- if HAVE_MESA_LLVM
-
- AM_CFLAGS += \
-diff --git a/src/gallium/auxiliary/Makefile.sources b/src/gallium/auxiliary/Makefile.sources
-index 5d4fe30..8d3e4a9 100644
---- a/src/gallium/auxiliary/Makefile.sources
-+++ b/src/gallium/auxiliary/Makefile.sources
-@@ -435,3 +435,7 @@ GALLIVM_SOURCES := \
- draw/draw_llvm_sample.c \
- draw/draw_pt_fetch_shade_pipeline_llvm.c \
- draw/draw_vs_llvm.c
-+
-+RENDERONLY_SOURCES := \
-+ renderonly/renderonly.c \
-+ renderonly/renderonly.h
-diff --git a/src/gallium/auxiliary/renderonly/renderonly.c b/src/gallium/auxiliary/renderonly/renderonly.c
-new file mode 100644
-index 0000000..c4ea784
---- /dev/null
-+++ b/src/gallium/auxiliary/renderonly/renderonly.c
-@@ -0,0 +1,199 @@
-+/*
-+ * Copyright (C) 2016 Christian Gmeiner <christian.gmeiner@gmail.com>
-+ *
-+ * Permission is hereby granted, free of charge, to any person obtaining a
-+ * copy of this software and associated documentation files (the "Software"),
-+ * to deal in the Software without restriction, including without limitation
-+ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
-+ * and/or sell copies of the Software, and to permit persons to whom the
-+ * Software is furnished to do so, subject to the following conditions:
-+ *
-+ * The above copyright notice and this permission notice (including the next
-+ * paragraph) shall be included in all copies or substantial portions of the
-+ * Software.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-+ * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-+ * SOFTWARE.
-+ *
-+ * Authors:
-+ * Christian Gmeiner <christian.gmeiner@gmail.com>
-+ */
-+
-+#include "renderonly/renderonly.h"
-+
-+#include <errno.h>
-+#include <fcntl.h>
-+#include <stdio.h>
-+#include <sys/ioctl.h>
-+#include <xf86drm.h>
-+
-+#include "state_tracker/drm_driver.h"
-+#include "pipe/p_screen.h"
-+#include "util/u_memory.h"
-+
-+struct pipe_screen *
-+renderonly_screen_create(int fd, const struct renderonly_ops *ops, void *priv)
-+{
-+ struct renderonly *ro;
-+
-+ ro = CALLOC_STRUCT(renderonly);
-+ if (!ro)
-+ return NULL;
-+
-+ ro->kms_fd = fd;
-+ ro->ops = ops;
-+ ro->priv = priv;
-+
-+ ro->screen = ops->create(ro);
-+ if (!ro->screen)
-+ goto cleanup;
-+
-+ return ro->screen;
-+
-+cleanup:
-+ FREE(ro);
-+
-+ return NULL;
-+}
-+
-+static bool
-+use_kms_bumb_buffer(struct renderonly_scanout *scanout,
-+ struct pipe_resource *rsc, struct renderonly *ro)
-+{
-+ struct winsys_handle handle;
-+ int prime_fd, err;
-+ struct drm_mode_create_dumb create_dumb = {
-+ .width = rsc->width0,
-+ .height = rsc->height0,
-+ .bpp = 32,
-+ };
-+ struct drm_mode_destroy_dumb destroy_dumb = { };
-+
-+ /* create dumb buffer at scanout GPU */
-+ err = ioctl(ro->kms_fd, DRM_IOCTL_MODE_CREATE_DUMB, &create_dumb);
-+ if (err < 0) {
-+ fprintf(stderr, "DRM_IOCTL_MODE_CREATE_DUMB failed: %s\n",
-+ strerror(errno));
-+ return false;
-+ }
-+
-+ scanout->handle = create_dumb.handle;
-+ scanout->stride = create_dumb.pitch;
-+
-+ /* export dumb buffer */
-+ err = drmPrimeHandleToFD(ro->kms_fd, create_dumb.handle, O_CLOEXEC,
-+ &prime_fd);
-+ if (err < 0) {
-+ fprintf(stderr, "failed to export dumb buffer: %s\n", strerror(errno));
-+ goto out_free_dumb;
-+ }
-+
-+ /* import dumb buffer */
-+ handle.type = DRM_API_HANDLE_TYPE_FD;
-+ handle.handle = prime_fd;
-+ handle.stride = create_dumb.pitch;
-+
-+ scanout->prime = ro->screen->resource_from_handle(ro->screen, rsc,
-+ &handle, PIPE_HANDLE_USAGE_READ_WRITE);
-+
-+ if (!scanout->prime) {
-+ fprintf(stderr, "failed to create resource_from_handle: %s\n", strerror(errno));
-+ goto out_free_dumb;
-+ }
-+
-+ return true;
-+
-+out_free_dumb:
-+ destroy_dumb.handle = scanout->handle;
-+ ioctl(ro->kms_fd, DRM_IOCTL_MODE_DESTROY_DUMB, &destroy_dumb);
-+
-+ return false;
-+}
-+
-+static bool
-+import_gpu_scanout(struct renderonly_scanout *scanout,
-+ struct pipe_resource *rsc, struct renderonly *ro)
-+{
-+ struct pipe_screen *screen = ro->screen;
-+ boolean status;
-+ int fd, err;
-+ struct winsys_handle handle = {
-+ .type = DRM_API_HANDLE_TYPE_FD
-+ };
-+
-+ status = screen->resource_get_handle(screen, rsc, &handle,
-+ PIPE_HANDLE_USAGE_READ_WRITE);
-+ if (!status)
-+ return false;
-+
-+ scanout->stride = handle.stride;
-+ fd = handle.handle;
-+
-+ err = drmPrimeFDToHandle(ro->kms_fd, fd, &scanout->handle);
-+ close(fd);
-+
-+ if (err < 0) {
-+ fprintf(stderr, "drmPrimeFDToHandle() failed: %s\n", strerror(errno));
-+ return false;
-+ }
-+
-+ if (ro->ops->tiling) {
-+ err = ro->ops->tiling(ro->kms_fd, scanout->handle);
-+ if (err < 0) {
-+ fprintf(stderr, "failed to set tiling parameters: %s\n", strerror(errno));
-+ close(scanout->handle);
-+ return false;
-+ }
-+ }
-+
-+ return true;
-+}
-+
-+struct renderonly_scanout *
-+renderonly_scanout_for_resource(struct pipe_resource *rsc, struct renderonly *ro)
-+{
-+ struct renderonly_scanout *scanout;
-+ bool ret;
-+
-+ scanout = CALLOC_STRUCT(renderonly_scanout);
-+ if (!scanout)
-+ return NULL;
-+
-+ if (ro->ops->intermediate_rendering)
-+ ret = use_kms_bumb_buffer(scanout, rsc, ro);
-+ else
-+ ret = import_gpu_scanout(scanout, rsc, ro);
-+
-+ if (!ret) {
-+ FREE(scanout);
-+ scanout = NULL;
-+ }
-+
-+ return scanout;
-+}
-+
-+struct renderonly_scanout *
-+renderonly_scanout_for_prime(struct pipe_resource *rsc, struct renderonly *ro)
-+{
-+ struct renderonly_scanout *scanout;
-+
-+ scanout = CALLOC_STRUCT(renderonly_scanout);
-+ if (!scanout)
-+ return NULL;
-+
-+ scanout->prime = rsc;
-+
-+ return scanout;
-+}
-+
-+void
-+renderonly_scanout_destroy(struct renderonly_scanout *scanout)
-+{
-+ close(scanout->handle);
-+ FREE(scanout);
-+}
-diff --git a/src/gallium/auxiliary/renderonly/renderonly.h b/src/gallium/auxiliary/renderonly/renderonly.h
-new file mode 100644
-index 0000000..5a98992
---- /dev/null
-+++ b/src/gallium/auxiliary/renderonly/renderonly.h
-@@ -0,0 +1,81 @@
-+/*
-+ * Copyright (C) 2016 Christian Gmeiner <christian.gmeiner@gmail.com>
-+ *
-+ * Permission is hereby granted, free of charge, to any person obtaining a
-+ * copy of this software and associated documentation files (the "Software"),
-+ * to deal in the Software without restriction, including without limitation
-+ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
-+ * and/or sell copies of the Software, and to permit persons to whom the
-+ * Software is furnished to do so, subject to the following conditions:
-+ *
-+ * The above copyright notice and this permission notice (including the next
-+ * paragraph) shall be included in all copies or substantial portions of the
-+ * Software.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-+ * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-+ * SOFTWARE.
-+ *
-+ * Authors:
-+ * Christian Gmeiner <christian.gmeiner@gmail.com>
-+ */
-+
-+#ifndef RENDERONLY_H
-+#define RENDERONLY_H
-+
-+#include <stdint.h>
-+#include "state_tracker/drm_driver.h"
-+#include "pipe/p_state.h"
-+
-+struct renderonly;
-+
-+struct renderonly_ops {
-+ struct pipe_screen *(*create)(struct renderonly *ctx);
-+ int (*tiling)(int fd, uint32_t handle);
-+ bool intermediate_rendering;
-+};
-+
-+struct renderonly {
-+ int kms_fd;
-+ const struct renderonly_ops *ops;
-+ struct pipe_screen *screen;
-+ void *priv;
-+};
-+
-+struct pipe_screen *
-+renderonly_screen_create(int fd, const struct renderonly_ops *ops, void *priv);
-+
-+struct renderonly_scanout {
-+ uint32_t handle;
-+ uint32_t stride;
-+
-+ struct pipe_resource *prime;
-+};
-+
-+struct renderonly_scanout *
-+renderonly_scanout_for_resource(struct pipe_resource *rsc, struct renderonly *ro);
-+
-+struct renderonly_scanout *
-+renderonly_scanout_for_prime(struct pipe_resource *rsc, struct renderonly *ro);
-+
-+void
-+renderonly_scanout_destroy(struct renderonly_scanout *scanout);
-+
-+static inline boolean
-+renderonly_get_handle(struct renderonly_scanout *scanout,
-+ struct winsys_handle *handle)
-+{
-+ if (!scanout)
-+ return FALSE;
-+
-+ handle->handle = scanout->handle;
-+ handle->stride = scanout->stride;
-+
-+ return TRUE;
-+}
-+
-+#endif /* RENDERONLY_H_ */
---
-2.9.3
-
diff --git a/recipes-graphics/mesa/mesa/0004-gallium-add-tegra-support.patch b/recipes-graphics/mesa/mesa/0004-gallium-add-tegra-support.patch
index 536d6cd..022c7f0 100644
--- a/recipes-graphics/mesa/mesa/0004-gallium-add-tegra-support.patch
+++ b/recipes-graphics/mesa/mesa/0004-gallium-add-tegra-support.patch
@@ -1,15 +1,18 @@
-From 430452494ff5f3454290cb0c80f9d1dbd072ecff Mon Sep 17 00:00:00 2001
+From b1f2a37552e3ff244e3c79b609c66a63c109915a Mon Sep 17 00:00:00 2001
From: Christian Gmeiner <christian.gmeiner@gmail.com>
Date: Sun, 21 Aug 2016 22:10:12 +0200
-Subject: [PATCH 4/8] gallium: add tegra support
+Subject: [PATCH 1/4] gallium: add tegra support
Signed-off-by: Christian Gmeiner <christian.gmeiner@gmail.com>
[acourbot@nvidia.com: port to latest branch]
Signed-off-by: Alexandre Courbot <acourbot@nvidia.com>
+
+forward port to mesa 17.0.2
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
---
configure.ac | 13 ++++++-
src/gallium/Makefile.am | 4 +++
- .../auxiliary/pipe-loader/pipe_loader_drm.c | 5 +++
+ .../auxiliary/pipe-loader/pipe_loader_drm.c | 6 ++++
src/gallium/auxiliary/target-helpers/drm_helper.h | 23 ++++++++++++
.../auxiliary/target-helpers/drm_helper_public.h | 3 ++
src/gallium/drivers/nouveau/nouveau_buffer.c | 3 ++
@@ -28,7 +31,7 @@ Signed-off-by: Alexandre Courbot <acourbot@nvidia.com>
src/gallium/winsys/tegra/drm/Makefile.sources | 3 ++
src/gallium/winsys/tegra/drm/tegra_drm_public.h | 8 +++++
src/gallium/winsys/tegra/drm/tegra_drm_winsys.c | 41 ++++++++++++++++++++++
- 21 files changed, 235 insertions(+), 3 deletions(-)
+ 21 files changed, 236 insertions(+), 3 deletions(-)
create mode 100644 src/gallium/drivers/tegra/Automake.inc
create mode 100644 src/gallium/drivers/tegra/Makefile.am
create mode 100644 src/gallium/winsys/tegra/drm/Android.mk
@@ -38,27 +41,27 @@ Signed-off-by: Alexandre Courbot <acourbot@nvidia.com>
create mode 100644 src/gallium/winsys/tegra/drm/tegra_drm_winsys.c
diff --git a/configure.ac b/configure.ac
-index c0f81ce..3d288e8 100644
+index ac110e8..f7f94ee 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -77,6 +77,7 @@ LIBDRM_NOUVEAU_REQUIRED=2.4.66
+@@ -74,6 +74,7 @@ LIBDRM_INTEL_REQUIRED=2.4.61
LIBDRM_NVVIEUX_REQUIRED=2.4.66
LIBDRM_NOUVEAU_REQUIRED=2.4.66
- LIBDRM_FREEDRENO_REQUIRED=2.4.67
+ LIBDRM_FREEDRENO_REQUIRED=2.4.74
+LIBDRM_TEGRA_REQUIRED=2.4.68
+ LIBDRM_VC4_REQUIRED=2.4.69
+ LIBDRM_ETNAVIV_REQUIRED=2.4.74
DRI2PROTO_REQUIRED=2.6
- DRI3PROTO_REQUIRED=1.0
- PRESENTPROTO_REQUIRED=1.0
-@@ -1021,7 +1022,7 @@ GALLIUM_DRIVERS_DEFAULT="r300,r600,svga,swrast"
+@@ -1228,7 +1229,7 @@ GALLIUM_DRIVERS_DEFAULT="r300,r600,svga,swrast"
AC_ARG_WITH([gallium-drivers],
[AS_HELP_STRING([--with-gallium-drivers@<:@=DIRS...@:>@],
[comma delimited Gallium drivers list, e.g.
-- "i915,ilo,nouveau,r300,r600,radeonsi,freedreno,svga,swrast,vc4,virgl"
-+ "i915,ilo,nouveau,r300,r600,radeonsi,freedreno,svga,swrast,vc4,virgl,tegra"
+- "i915,ilo,nouveau,r300,r600,radeonsi,freedreno,svga,swrast,vc4,virgl,etnaviv,imx"
++ "i915,ilo,nouveau,r300,r600,radeonsi,freedreno,svga,swrast,vc4,virgl,etnaviv,imx,tegra"
@<:@default=r300,r600,svga,swrast@:>@])],
[with_gallium_drivers="$withval"],
[with_gallium_drivers="$GALLIUM_DRIVERS_DEFAULT"])
-@@ -2491,6 +2492,13 @@ if test -n "$with_gallium_drivers"; then
+@@ -2391,6 +2392,13 @@ if test -n "$with_gallium_drivers"; then
require_libdrm "virgl"
require_basic_egl "virgl"
;;
@@ -72,7 +75,7 @@ index c0f81ce..3d288e8 100644
*)
AC_MSG_ERROR([Unknown Gallium driver: $driver])
;;
-@@ -2582,6 +2590,7 @@ AM_CONDITIONAL(HAVE_GALLIUM_VC4, test "x$HAVE_GALLIUM_VC4" = xyes)
+@@ -2491,6 +2499,7 @@ AM_CONDITIONAL(HAVE_GALLIUM_SWRAST, test "x$HAVE_GALLIUM_SOFTPIPE" = xyes -o \
"x$HAVE_GALLIUM_SWR" = xyes)
AM_CONDITIONAL(HAVE_GALLIUM_VC4, test "x$HAVE_GALLIUM_VC4" = xyes)
AM_CONDITIONAL(HAVE_GALLIUM_VIRGL, test "x$HAVE_GALLIUM_VIRGL" = xyes)
@@ -80,7 +83,7 @@ index c0f81ce..3d288e8 100644
AM_CONDITIONAL(HAVE_GALLIUM_STATIC_TARGETS, test "x$enable_shared_pipe_drivers" = xno)
-@@ -2732,6 +2741,7 @@ AC_CONFIG_FILES([Makefile
+@@ -2639,6 +2648,7 @@ AC_CONFIG_FILES([Makefile
src/gallium/drivers/imx/Makefile
src/gallium/drivers/vc4/Makefile
src/gallium/drivers/virgl/Makefile
@@ -88,7 +91,7 @@ index c0f81ce..3d288e8 100644
src/gallium/state_trackers/clover/Makefile
src/gallium/state_trackers/dri/Makefile
src/gallium/state_trackers/glx/xlib/Makefile
-@@ -2776,6 +2786,7 @@ AC_CONFIG_FILES([Makefile
+@@ -2683,6 +2693,7 @@ AC_CONFIG_FILES([Makefile
src/gallium/winsys/vc4/drm/Makefile
src/gallium/winsys/virgl/drm/Makefile
src/gallium/winsys/virgl/vtest/Makefile
@@ -112,30 +115,29 @@ index f910f31..0f887d2 100644
SUBDIRS += winsys/sw/null
diff --git a/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c b/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c
-index 6c89fe5..ff1166c 100644
+index 6c89fe5..a08d00d 100644
--- a/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c
+++ b/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c
-@@ -163,6 +163,12 @@ static const struct drm_driver_descriptor driver_descriptors[] = {
- .create_screen = pipe_vc4_create_screen,
+@@ -155,6 +155,11 @@ static const struct drm_driver_descriptor driver_descriptors[] = {
.configuration = configuration_query,
},
-+ {
-+ .name = "tegra",
+ {
+ .driver_name = "tegra",
+ .create_screen = pipe_tegra_create_screen,
+ .configuration = configuration_query,
+ },
- };
- #endif
-
++ {
+ .driver_name = "etnaviv",
+ .create_screen = pipe_etna_create_screen,
+ .configuration = configuration_query,
diff --git a/src/gallium/auxiliary/target-helpers/drm_helper.h b/src/gallium/auxiliary/target-helpers/drm_helper.h
-index fbb4ce4..22932d3 100644
+index f847b17..ae641b9 100644
--- a/src/gallium/auxiliary/target-helpers/drm_helper.h
+++ b/src/gallium/auxiliary/target-helpers/drm_helper.h
-@@ -312,4 +312,27 @@ pipe_imx_drm_create_screen(int fd)
-
+@@ -313,4 +313,27 @@ pipe_imx_drm_create_screen(int fd)
#endif
+
+#ifdef GALLIUM_TEGRA
+#include "tegra/drm/tegra_drm_public.h"
+
@@ -298,12 +300,12 @@ index 0000000..30f4689
+
+libtegra_la_SOURCES =
diff --git a/src/gallium/targets/dri/Makefile.am b/src/gallium/targets/dri/Makefile.am
-index 06ade45..ed412d7 100644
+index bca747f..4236da1 100644
--- a/src/gallium/targets/dri/Makefile.am
+++ b/src/gallium/targets/dri/Makefile.am
-@@ -91,6 +91,8 @@ include $(top_srcdir)/src/gallium/drivers/vc4/Automake.inc
-
- include $(top_srcdir)/src/gallium/drivers/virgl/Automake.inc
+@@ -94,6 +94,8 @@ include $(top_srcdir)/src/gallium/drivers/virgl/Automake.inc
+ include $(top_srcdir)/src/gallium/drivers/etnaviv/Automake.inc
+ include $(top_srcdir)/src/gallium/drivers/imx/Automake.inc
+include $(top_srcdir)/src/gallium/drivers/tegra/Automake.inc
+
@@ -311,13 +313,13 @@ index 06ade45..ed412d7 100644
include $(top_srcdir)/src/gallium/drivers/llvmpipe/Automake.inc
include $(top_srcdir)/src/gallium/drivers/swr/Automake.inc
diff --git a/src/gallium/targets/dri/target.c b/src/gallium/targets/dri/target.c
-index 01532e2..126cadf 100644
+index 441a27f..5e4db62 100644
--- a/src/gallium/targets/dri/target.c
+++ b/src/gallium/targets/dri/target.c
-@@ -162,3 +162,14 @@ PUBLIC const __DRIextension **__driDriverGetExtensions_i965(void)
+@@ -181,3 +181,14 @@ PUBLIC const __DRIextension **__driDriverGetExtensions_etnaviv(void)
+ return galliumdrm_driver_extensions;
}
#endif
- #endif
+
+#if defined(GALLIUM_TEGRA)
+
@@ -363,7 +365,7 @@ index cc9dfa7..acbd3fe 100644
+}
diff --git a/src/gallium/winsys/tegra/drm/Android.mk b/src/gallium/winsys/tegra/drm/Android.mk
new file mode 100644
-index 0000000..a48dca48
+index 0000000..a48dca4
--- /dev/null
+++ b/src/gallium/winsys/tegra/drm/Android.mk
@@ -0,0 +1,33 @@
diff --git a/recipes-graphics/mesa/mesa/0008-remove-dependency-on-libdrm_tegra.patch b/recipes-graphics/mesa/mesa/0008-remove-dependency-on-libdrm_tegra.patch
index 0b6d6e9..b197b93 100644
--- a/recipes-graphics/mesa/mesa/0008-remove-dependency-on-libdrm_tegra.patch
+++ b/recipes-graphics/mesa/mesa/0008-remove-dependency-on-libdrm_tegra.patch
@@ -1,28 +1,31 @@
-From d2716d25609865bb31bb270ee2fdac3dec5047c6 Mon Sep 17 00:00:00 2001
+From b91f178edf3ba6969120a8ad2f5a7a4d330e2b64 Mon Sep 17 00:00:00 2001
From: Alexandre Courbot <acourbot@nvidia.com>
Date: Tue, 20 Dec 2016 15:20:20 +0900
-Subject: [PATCH 8/8] remove dependency on libdrm_tegra
+Subject: [PATCH 4/4] remove dependency on libdrm_tegra
Functions provided by this library are not required as we perform ioctls
directly.
+
+Forward port to mesa 17.0.2
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
---
configure.ac | 2 --
src/gallium/winsys/tegra/drm/Makefile.am | 2 +-
2 files changed, 1 insertion(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 8a7d833..7df9674 100644
+index f7f94ee..4ce5d37 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -77,7 +77,6 @@ LIBDRM_NOUVEAU_REQUIRED=2.4.66
+@@ -74,7 +74,6 @@ LIBDRM_INTEL_REQUIRED=2.4.61
LIBDRM_NVVIEUX_REQUIRED=2.4.66
LIBDRM_NOUVEAU_REQUIRED=2.4.66
- LIBDRM_FREEDRENO_REQUIRED=2.4.67
+ LIBDRM_FREEDRENO_REQUIRED=2.4.74
-LIBDRM_TEGRA_REQUIRED=2.4.68
+ LIBDRM_VC4_REQUIRED=2.4.69
+ LIBDRM_ETNAVIV_REQUIRED=2.4.74
DRI2PROTO_REQUIRED=2.6
- DRI3PROTO_REQUIRED=1.0
- PRESENTPROTO_REQUIRED=1.0
-@@ -2493,7 +2492,6 @@ if test -n "$with_gallium_drivers"; then
+@@ -2393,7 +2392,6 @@ if test -n "$with_gallium_drivers"; then
require_basic_egl "virgl"
;;
xtegra)
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index ac56148..d56760a 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -32,7 +32,6 @@ DRIDRIVERS_tegra124m = " "
GALLIUMDRIVERS_tegra124m = "tegra"
SRC_URI_append_tegra124m = " \
- file://0001-gallium-add-renderonly-library.patch \
file://0004-gallium-add-tegra-support.patch \
file://0005-tegra-open-card1-instead-of-renderD128.patch \
file://0006-HACK-make-DRI-work-under-X.patch \