summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-09-29 22:30:42 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-09-29 23:08:21 +0200
commit8263c26d4eedaf903d8f47e583c025aba50de2de (patch)
treed190c8a6004671dc1dcb4519e374c65d9f2d97c8 /recipes-graphics
parente48613aece9a1bef83888028aab75b8c36cda0ed (diff)
linux-driver-package, mesa: rework the recipe
Recent OE adds additional shared object checks which errors out on the way the binary Tegra drivers are injected. Rework the recipes, so that - mesa no longer PROVIDE any OpenGL shared objects and the binaries. - linux-driver-package now depends on mesa to install development headers - linux-driver-package PROVIDE and RPROVIDE the OpenGL shared objects. - linux-driver-package drops the additional arm-linux-gnueabihf/tegra path to the *.so* files. - the apalis-tk1 machine PREFERS linux-driver-package as the OpenGL provider. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa/0001-pkg-config-files-add-tegra-paths.patch81
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend14
2 files changed, 9 insertions, 86 deletions
diff --git a/recipes-graphics/mesa/mesa/0001-pkg-config-files-add-tegra-paths.patch b/recipes-graphics/mesa/mesa/0001-pkg-config-files-add-tegra-paths.patch
deleted file mode 100644
index b657b3e..0000000
--- a/recipes-graphics/mesa/mesa/0001-pkg-config-files-add-tegra-paths.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From e0e65da315173902b909627ac3067463ab5c8710 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Sat, 7 Sep 2019 13:17:21 +0000
-Subject: [PATCH] pkg config files: add tegra paths
-
-Add the paths to the tegra specific libraries.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- src/egl/meson.build | 1 +
- src/mapi/es1api/meson.build | 3 +-
- src/mapi/es2api/meson.build | 3 +-
- src/meson.build | 2 +-
- 4 files changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/src/egl/meson.build b/src/egl/meson.build
-index 3a0fd01..48e0b2a 100644
---- a/src/egl/meson.build
-+++ b/src/egl/meson.build
-@@ -181,6 +181,7 @@ if with_glvnd
- else
- _egl = libegl
- endif
-+_egl = ' -L=${libdir}/arm-linux-gnueabihf/tegra-egl -L${libdir} -lEGL'
-
- pkg.generate(
- name : 'egl',
-diff --git a/src/mapi/es1api/meson.build b/src/mapi/es1api/meson.build
-index 53bdc16..c042fe2 100644
---- a/src/mapi/es1api/meson.build
-+++ b/src/mapi/es1api/meson.build
-@@ -43,12 +43,13 @@ libglesv1_cm = shared_library(
- install : true,
- )
-
-+_lib_tegra_gl1 = '-L=${libdir}/arm-linux-gnueabihf/tegra-egl -L${libdir} -lGLESv1_CM'
- pkg.generate(
- name : 'glesv1_cm',
- filebase : 'glesv1_cm',
- description : 'Mesa OpenGL ES 1.1 CM library',
- version : meson.project_version(),
-- libraries : libglesv1_cm,
-+ libraries : _lib_tegra_gl1,
- libraries_private : gl_priv_libs,
- )
-
-diff --git a/src/mapi/es2api/meson.build b/src/mapi/es2api/meson.build
-index d374bd8..9c56933 100644
---- a/src/mapi/es2api/meson.build
-+++ b/src/mapi/es2api/meson.build
-@@ -43,12 +43,13 @@ libgles2 = shared_library(
- install : true,
- )
-
-+_lib_tegra_gl2 = '-L=${libdir}/arm-linux-gnueabihf/tegra-egl -L${libdir} -lGLESv2'
- pkg.generate(
- name : 'glesv2',
- filebase : 'glesv2',
- description : 'Mesa OpenGL ES 2.0 library',
- version : meson.project_version(),
-- libraries : libgles2,
-+ libraries : _lib_tegra_gl2,
- libraries_private : gl_priv_libs,
- )
-
-diff --git a/src/meson.build b/src/meson.build
-index 6d04b5f..691811d 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -107,7 +107,7 @@ if with_glx != 'disabled'
- else
- _gl = libgl
- endif
--
-+ _gl = '-L=${libdir}/arm-linux-gnueabihf/tegra -L${libdir} -lGL'
- pkg.generate(
- name : 'gl',
- description : 'Mesa OpenGL Library',
---
-2.20.1
-
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index c34c789..b3f960f 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,13 +1,17 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
#####
# tegra tk1
-DEPENDS_append_tegra124= " linux-driver-package"
-SRC_URI_append_tegra124 = " file://0001-pkg-config-files-add-tegra-paths.patch"
-
PACKAGE_ARCH_tegra124 = "${MACHINE_ARCH}"
+PROVIDES_remove_tegra124 = "virtual/egl virtual/libgl virtual/libgles1 virtual/libgles2"
+
+do_install_append_tegra124 () {
+ rm ${D}${libdir}/libEGL.so*
+ rm ${D}${libdir}/libGL.so*
+ rm ${D}${libdir}/libGLESv1*.so*
+ rm ${D}${libdir}/libGLESv2.so*
+}
+
#####
## Tegra TK1 mainline kernel