summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-10-22 15:05:49 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 12:03:36 +0100
commita5ca867f1522d5e315f61e5427aa7ecb68bcfb22 (patch)
treea75f72517a8b83318380467a709f54ea475a5e4e /recipes-kernel
parent7dda99405d97667bb14d655a3a1b0db600db99ac (diff)
linux-toradex_git: update to latest next
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex_git.bb27
1 files changed, 7 insertions, 20 deletions
diff --git a/recipes-kernel/linux/linux-toradex_git.bb b/recipes-kernel/linux/linux-toradex_git.bb
index 18a9d3b..370c438 100644
--- a/recipes-kernel/linux/linux-toradex_git.bb
+++ b/recipes-kernel/linux/linux-toradex_git.bb
@@ -4,12 +4,12 @@ require recipes-kernel/linux/linux-toradex.inc
LINUX_VERSION ?= "3.1.10"
LOCALVERSION = "-${PR}"
-SRCREV = "d2f03874e7b3c7c173dc6977f8df5232515ad282"
-PR = "V2.6.1b1"
+SRCREV = "7e628fdb597e82e877ef10d22352a79f0a411221"
+PR = "v2.7b1"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
-SRCBRANCH = "tegra"
+SRCBRANCH = "tegra-next"
SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=${SRCBRANCH}"
COMPATIBLE_MACHINE = "(apalis-t30|colibri-pxa|colibri-t20|colibri-t30)"
@@ -28,7 +28,7 @@ do_configure_prepend () {
#assume its called ${MACHINE}_defconfig, but with '_' instead of '-'
DEFCONFIG="`echo ${MACHINE} | sed -e 's/\-/\_/g' -e 's/$/_defconfig/'`"
- cd ${S}
+ pushd ${S}
export KBUILD_OUTPUT=${B}
oe_runmake $DEFCONFIG
@@ -42,23 +42,10 @@ do_configure_prepend () {
#Add GIT revision to the local version
head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
printf "%s%s" +g $head > ${S}/.scmversion
-}
-kernel_do_compile() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- export CC="`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`"
- oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
- if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
- gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
- fi
+ popd
}
-do_compile_kernelmodules() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- export CC="`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`"
- if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
- oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
- else
- bbnote "no modules to compile"
- fi
+do_uboot_mkimage_prepend () {
+ cd ${B}
}