summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-09-22 21:48:01 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 12:03:24 +0100
commit701725b55ac4f8f40afa9703a71ae4af65193366 (patch)
treee24d79fb0816de8a2f89066d84c7e99524e35d4a /recipes-multimedia
parent94bdf86fd977dc71bae118e36e5626acf564a073 (diff)
libgstomx: update to 21.5.0
The patch fixes the following compilation error: ../../gstomx1_src/gst-omx1/omx/gstomxvideoenc.c:2443:7: note: in expansion of macro 'NVX_INDEX_CONFIG_VIDEO_ENCODE_TEMPORALTRADEOFF' NVX_INDEX_CONFIG_VIDEO_ENCODE_TEMPORALTRADEOFF, &eIndex); ^ In file included from ../../gstomx1_src/gst-omx1/omx/gstomxvideoenc.h:29:0, from ../../gstomx1_src/gst-omx1/omx/gstomxvideoenc.c:30: ../../gstomx1_src/gst-omx1/omx/gstomx.h:384:15: note: expected 'gpointer {aka void *}' but argument is of type 'const char *' Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libgstomx/files/gstomx.patch12
-rw-r--r--recipes-multimedia/libgstomx/libgstomx_21.5.0.bb42
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-multimedia/libgstomx/files/gstomx.patch b/recipes-multimedia/libgstomx/files/gstomx.patch
new file mode 100644
index 0000000..9e5a702
--- /dev/null
+++ b/recipes-multimedia/libgstomx/files/gstomx.patch
@@ -0,0 +1,12 @@
+diff -Naur a/omx/gstomxvideoenc.c b/omx/gstomxvideoenc.c
+--- a/omx/gstomxvideoenc.c 2016-06-08 06:17:32.000000000 +0200
++++ b/omx/gstomxvideoenc.c 2017-01-08 23:54:18.217242233 +0100
+@@ -2440,7 +2440,7 @@
+
+ err =
+ gst_omx_component_get_index (self->enc,
+- NVX_INDEX_CONFIG_VIDEO_ENCODE_TEMPORALTRADEOFF, &eIndex);
++ (char *) NVX_INDEX_CONFIG_VIDEO_ENCODE_TEMPORALTRADEOFF, &eIndex);
+ if (err != OMX_ErrorNone) {
+ return FALSE;
+ }
diff --git a/recipes-multimedia/libgstomx/libgstomx_21.5.0.bb b/recipes-multimedia/libgstomx/libgstomx_21.5.0.bb
new file mode 100644
index 0000000..cef62da
--- /dev/null
+++ b/recipes-multimedia/libgstomx/libgstomx_21.5.0.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "NVIDIA Linux Driver Packages"
+HOMEPAGE = "https://developer.nvidia.com/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = " \
+ http://developer.download.nvidia.com/embedded/L4T/r21_Release_v5.0/source/gstomx1_src.tbz2 \
+ file://gstomx.patch \
+"
+
+SRC_URI[md5sum] = "d5714a9533b210b30ef0e97e28ebc77d"
+SRC_URI[sha256sum] = "b1c62a41467f2ff6661a3ba7d0e30e85e7ed126005f67b39ff6ebf2d704fd222"
+
+DEPENDS += " libgstnvegl libffi glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base libpcre libxml2 zlib "
+DEPENDS += " virtual/egl virtual/mesa virtual/libgles2 wayland gdbm drm "
+
+S = "${WORKDIR}/gstomx1_src/gst-omx1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --with-omx-target=tegra --disable-static-plugins"
+
+CXXFLAGS += " -I${S}/omx/openmax "
+CFLAGS += " -I${S}/omx/openmax "
+
+do_configure_prepend() {
+ export NOCONFIGURE="true"
+ export GST_EGL_LIBS="-lgstnvegl-1.0 -lEGL -lX11 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0"
+ export GST_EGL_CFLAGS="-I${STAGING_INCDIR}/libdrm "
+# export GST_EGL_CFLAGS="-pthread -I${STAGING_INCDIR}/gstreamer-1.0 -I${STAGING_INCDIR}/libdrm -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
+}
+
+FILES_${PN}-dbg = " \
+ /usr/src/debug/* \
+ /usr/lib/gstreamer-1.0/.debug/* \
+ /usr/lib/.debug/* \
+"
+
+FILES_${PN} = " \
+ /usr/lib/gstreamer-1.0/libgstomx.la \
+ /usr/lib/gstreamer-1.0/libgstomx.so \
+ "