summaryrefslogtreecommitdiff
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2019-01-23 15:50:26 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2019-03-04 14:58:11 +0100
commitec413939657c0cd4bcb660c52c527cb7c0b0f6f5 (patch)
tree8a8ca019548c95eb6e0c1f5066d0e46e62e079b8 /recipes-multimedia
parent9f4378d25ccdae1eaab77c5e72c983fbe1de4e8c (diff)
libgstnvegl, libgstomx-0.10: update to L4T R21.7
Looks like those two we never actually updated to building off from R21.7 sources. This commit fixes that now. Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libgstnvegl/libgstnvegl_21.7.0.bb (renamed from recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb)21
-rw-r--r--recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb (renamed from recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.5.0.bb)17
2 files changed, 26 insertions, 12 deletions
diff --git a/recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb b/recipes-multimedia/libgstnvegl/libgstnvegl_21.7.0.bb
index 7ae88d4..5645510 100644
--- a/recipes-multimedia/libgstnvegl/libgstnvegl_21.5.0.bb
+++ b/recipes-multimedia/libgstnvegl/libgstnvegl_21.7.0.bb
@@ -4,14 +4,14 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d"
SRC_URI = " \
- http://developer.download.nvidia.com/embedded/L4T/r21_Release_v5.0/source/gstegl_src.tbz2 \
+ https://developer.download.nvidia.com/embedded/L4T/r21_Release_v7.0/r21.7.0-sources.tbz2 \
file://0001-rename-gstegl-to-gstnvegl.patch \
file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
file://0001-pkg-config-files-fix-qa-error.patch \
"
-
-SRC_URI[md5sum] = "8a08b88f2faa807d94d1939ddcb93b22"
-SRC_URI[sha256sum] = "f3ccf2dec5c283b1f4141609a4316bae1258b35181e2448264ae21754d8bdaed"
+
+SRC_URI[md5sum] = "620d0979ffbbc8cbe8cb36faacee386b"
+SRC_URI[sha256sum] = "4523ce03e18d2507a180a0b67e3ef136d4b73837f48063146c471fe575282440"
S = "${WORKDIR}/gstegl_src/gst-egl"
@@ -20,8 +20,16 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--disable-nls --disable-static-plugins --enable-introspection=no"
-DEPENDS += " libffi glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base libpcre libxml2 zlib "
-DEPENDS += " virtual/egl virtual/mesa virtual/libgles2 wayland gdbm drm "
+DEPENDS += " libffi glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base libpcre libxml2 zlib \
+ virtual/egl virtual/mesa virtual/libgles2 wayland gdbm drm tar-native"
+
+nvidia_unpack() {
+ cd "${WORKDIR}"
+ # NVIDIA now packages packages in one big package!
+ tar xjf gstegl_src.tbz2
+}
+
+do_unpack[postfuncs] += "nvidia_unpack"
FILES_${PN}-dbg = " \
/usr/src/debug/* \
@@ -36,4 +44,3 @@ FILES_${PN} = " \
/usr/lib/libgstnvegl-1.0.so.0 \
/usr/lib/libgstnvegl-1.0.so.0.203.0 \
"
-
diff --git a/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.5.0.bb b/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb
index 0ed0cfe..897c01b 100644
--- a/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.5.0.bb
+++ b/recipes-multimedia/libgstomx-0.10/libgstomx-0.10_21.7.0.bb
@@ -4,16 +4,16 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
SRC_URI = " \
- http://developer.download.nvidia.com/embedded/L4T/r21_Release_v5.0/source/gstomx_src.tbz2 \
+ https://developer.download.nvidia.com/embedded/L4T/r21_Release_v7.0/r21.7.0-sources.tbz2 \
file://0001-fix-gstomx-compilation-issues.patch \
file://0001-configure-don-t-use-gst-photography-even-if-it-is-in.patch \
"
-SRC_URI[md5sum] = "457764edbcbe7239f93f6e1284d66b17"
-SRC_URI[sha256sum] = "586b95c8c56ef0b7527dc0f7006e0eccd12a7da9613606cc766cf8d85b0f0a23"
+SRC_URI[md5sum] = "620d0979ffbbc8cbe8cb36faacee386b"
+SRC_URI[sha256sum] = "4523ce03e18d2507a180a0b67e3ef136d4b73837f48063146c471fe575282440"
-DEPENDS += " libgstnvegl libffi glib-2.0 gstreamer gst-plugins-base libpcre libxml2 zlib "
-DEPENDS += " virtual/egl virtual/mesa virtual/libgles2 gdbm drm "
+DEPENDS += " libgstnvegl libffi glib-2.0 gstreamer gst-plugins-base libpcre libxml2 zlib \
+ virtual/egl virtual/mesa virtual/libgles2 gdbm drm tar-native"
S = "${WORKDIR}/gstomx_src/gst-openmax"
@@ -24,6 +24,13 @@ EXTRA_OECONF = " --enable-tegra --enable-eglimage --enable-experimental --disabl
CXXFLAGS += " -DTEGRA_ARCH_124 -I${S}/omx/openmax -I${WORKDIR}/gstomx_src/nv_headers -Wl,--no-undefined "
CFLAGS += " -DTEGRA_ARCH_124 -I${S}/omx/openmax -I${WORKDIR}/gstomx_src/nv_headers -Wl,--no-undefined "
+nvidia_unpack() {
+ cd "${WORKDIR}"
+ # NVIDIA now packages packages in one big package!
+ tar xjf gstomx_src.tbz2
+}
+
+do_unpack[postfuncs] += "nvidia_unpack"
do_configure_prepend() {
export LIBS="-lEGL -lGLESv2 -lX11 -ldl -lgstreamer-0.10 "