summaryrefslogtreecommitdiff
path: root/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:16:51 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:16:51 +0100
commit0e6a4e47d8abbf656a0a4f37ff6be8256522faf8 (patch)
treeaab1c18e5cd91dcf0afd36c03dca9ef0fd307d75 /recipes-support/libcryptopp/libcryptopp_5.6.2.bb
parenta961fa995d1ba264957d5d3d04b5fea083d20157 (diff)
Add libcryptopp recipe
Diffstat (limited to 'recipes-support/libcryptopp/libcryptopp_5.6.2.bb')
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
new file mode 100644
index 0000000..25b1b69
--- /dev/null
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "A free C++ class library of cryptographic schemes"
+HOMEPAGE = "http://www.cryptopp.com/wiki/Main_Page"
+BUGTRACKER = "http://sourceforge.net/apps/trac/cryptopp/"
+SECTION = "libs"
+
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://License.txt;md5=15bb91b85c60bac932e0a3f550bad6a3"
+
+BBCLASSEXTEND = "native nativesdk"
+
+PR = "r1"
+
+PVSHORT = "${@'${PV}'.replace('.','')}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/cryptopp/${PV}/cryptopp${PVSHORT}.zip \
+ file://makefile_fix_destdir.patch \
+ "
+SRC_URI[md5sum] = "7ed022585698df48e65ce9218f6c6a67"
+SRC_URI[sha256sum] = "5cbfd2fcb4a6b3aab35902e2e0f3b59d9171fee12b3fc2b363e1801dfec53574"
+
+#S = "${WORKDIR}/libcryptopp-${PV}"
+S = "${WORKDIR}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--libdir=${base_libdir}"
+
+do_compile() {
+ sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
+ export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
+ oe_runmake -f GNUmakefile
+ oe_runmake libcryptopp.so
+}
+