summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:16:51 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-10-30 15:16:51 +0100
commit0e6a4e47d8abbf656a0a4f37ff6be8256522faf8 (patch)
treeaab1c18e5cd91dcf0afd36c03dca9ef0fd307d75 /recipes-support
parenta961fa995d1ba264957d5d3d04b5fea083d20157 (diff)
Add libcryptopp recipe
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libcryptopp/libcryptopp-5.6.2/makefile_fix_destdir.patch30
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.2.bb33
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp-5.6.2/makefile_fix_destdir.patch b/recipes-support/libcryptopp/libcryptopp-5.6.2/makefile_fix_destdir.patch
new file mode 100644
index 0000000..9d57fe3
--- /dev/null
+++ b/recipes-support/libcryptopp/libcryptopp-5.6.2/makefile_fix_destdir.patch
@@ -0,0 +1,30 @@
+diff -Nurd libcryptopp2/GNUmakefile libcryptopp/GNUmakefile
+--- libcryptopp2/GNUmakefile 2013-02-20 15:30:52.000000000 +0100
++++ libcryptopp/GNUmakefile 2013-12-01 20:58:53.774735203 +0100
+@@ -148,17 +148,17 @@
+ -$(RM) cryptest.exe libcryptopp.a libcryptopp.so $(LIBOBJS) $(TESTOBJS) cryptopp.dll libcryptopp.dll.a libcryptopp.import.a cryptest.import.exe dlltest.exe $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTI MPORTOBJS) $(DLLTESTOBJS)
+
+ install:
+- $(MKDIR) -p $(PREFIX)/include/cryptopp $(PREFIX)/lib $(PREFIX)/bin
+- -$(CP) *.h $(PREFIX)/include/cryptopp
+- -$(CP) *.a $(PREFIX)/lib
+- -$(CP) *.so $(PREFIX)/lib
+- -$(CP) *.exe $(PREFIX)/bin
++ $(MKDIR) -p $(DESTDIR)$(PREFIX)/include/cryptopp $(DESTDIR)$(PREFIX)/lib $(DESTDIR)$(PREFIX)/bin
++ -$(CP) *.h $(DESTDIR)$(PREFIX)/include/cryptopp
++ -$(CP) *.a $(DESTDIR)$(PREFIX)/lib
++ -$(CP) *.so $(DESTDIR)$(PREFIX)/lib
++ -$(CP) *.exe $(DESTDIR)$(PREFIX)/bin
+
+ remove:
+- -$(RM) -rf $(PREFIX)/include/cryptopp
+- -$(RM) $(PREFIX)/lib/libcryptopp.a
+- -$(RM) $(PREFIX)/lib/libcryptopp.so
+- -$(RM) $(PREFIX)/bin/cryptest.exe
++ -$(RM) -rf $(DESTDIR)$(PREFIX)/include/cryptopp
++ -$(RM) $(DESTDIR)$(PREFIX)/lib/libcryptopp.a
++ -$(RM) $(DESTDIR)$(PREFIX)/lib/libcryptopp.so
++ -$(RM) $(DESTDIR)$(PREFIX)/bin/cryptest.exe
+
+ libcryptopp.a: $(LIBOBJS)
+ $(AR) $(ARFLAGS) $@ $(LIBOBJS)
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
new file mode 100644
index 0000000..25b1b69
--- /dev/null
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "A free C++ class library of cryptographic schemes"
+HOMEPAGE = "http://www.cryptopp.com/wiki/Main_Page"
+BUGTRACKER = "http://sourceforge.net/apps/trac/cryptopp/"
+SECTION = "libs"
+
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://License.txt;md5=15bb91b85c60bac932e0a3f550bad6a3"
+
+BBCLASSEXTEND = "native nativesdk"
+
+PR = "r1"
+
+PVSHORT = "${@'${PV}'.replace('.','')}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/cryptopp/${PV}/cryptopp${PVSHORT}.zip \
+ file://makefile_fix_destdir.patch \
+ "
+SRC_URI[md5sum] = "7ed022585698df48e65ce9218f6c6a67"
+SRC_URI[sha256sum] = "5cbfd2fcb4a6b3aab35902e2e0f3b59d9171fee12b3fc2b363e1801dfec53574"
+
+#S = "${WORKDIR}/libcryptopp-${PV}"
+S = "${WORKDIR}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--libdir=${base_libdir}"
+
+do_compile() {
+ sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
+ export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
+ oe_runmake -f GNUmakefile
+ oe_runmake libcryptopp.so
+}
+