summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-06-08 14:33:08 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2016-06-30 13:28:27 +0200
commit0fa90ef5f7b1fd23b3a94fe66701c8807bb0df74 (patch)
tree34088051edc3729cad11a8f72c6833b6ce7623ef /recipes-support
parent5c4656fd2d4e57a003dc6e839fb6337c5063ddf1 (diff)
libcryptopp: update to latest 5.6.3
Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch39
-rw-r--r--recipes-support/libcryptopp/libcryptopp-5.6.3/makefile_fix_destdir.patch (renamed from recipes-support/libcryptopp/libcryptopp-5.6.2/makefile_fix_destdir.patch)0
-rw-r--r--recipes-support/libcryptopp/libcryptopp_5.6.3.bb (renamed from recipes-support/libcryptopp/libcryptopp_5.6.2.bb)12
3 files changed, 45 insertions, 6 deletions
diff --git a/recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch b/recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch
new file mode 100644
index 0000000..d69e12d
--- /dev/null
+++ b/recipes-support/libcryptopp/libcryptopp-5.6.3/0001-Fix-cross-compilation.patch
@@ -0,0 +1,39 @@
+From 1306eabf258f0e9ce8586b7816406a21683d529d Mon Sep 17 00:00:00 2001
+From: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+Date: Wed, 8 Jun 2016 14:23:29 +0200
+Subject: [PATCH] Fix cross compilation
+
+Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+---
+ GNUmakefile | 15 ---------------
+ 1 file changed, 15 deletions(-)
+
+diff --git a/GNUmakefile b/GNUmakefile
+index 3bc76a4..f71d990 100755
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -73,21 +73,6 @@ ifneq ($(IS_X86_64),0)
+ endif
+ endif
+
+-# Guard use of -march=native
+-ifeq ($(GCC_COMPILER),0)
+- CXXFLAGS += -march=native
+-else ifneq ($(GCC42_OR_LATER),0)
+- CXXFLAGS += -march=native
+-else
+- # GCC 3.3 and "unknown option -march="
+- # GCC 4.1 compiler crash with -march=native.
+- ifneq ($(IS_X86_64),0)
+- CXXFLAGS += -m64
+- else
+- CXXFLAGS += -m32
+- endif # X86/X32/X64
+-endif
+-
+ # Aligned access required at -O3 for GCC due to vectorization (circa 08/2008). Expect other compilers to do the same.
+ UNALIGNED_ACCESS := $(shell $(EGREP) -c "^[[:space:]]*//[[:space:]]*\#[[:space:]]*define[[:space:]]*CRYPTOPP_NO_UNALIGNED_DATA_ACCESS" config.h)
+ ifeq ($(findstring -O3,$(CXXFLAGS)),-O3)
+--
+2.5.5
+
diff --git a/recipes-support/libcryptopp/libcryptopp-5.6.2/makefile_fix_destdir.patch b/recipes-support/libcryptopp/libcryptopp-5.6.3/makefile_fix_destdir.patch
index 9d57fe3..9d57fe3 100644
--- a/recipes-support/libcryptopp/libcryptopp-5.6.2/makefile_fix_destdir.patch
+++ b/recipes-support/libcryptopp/libcryptopp-5.6.3/makefile_fix_destdir.patch
diff --git a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb b/recipes-support/libcryptopp/libcryptopp_5.6.3.bb
index ad9e10b..03d24ba 100644
--- a/recipes-support/libcryptopp/libcryptopp_5.6.2.bb
+++ b/recipes-support/libcryptopp/libcryptopp_5.6.3.bb
@@ -4,18 +4,18 @@ BUGTRACKER = "http://sourceforge.net/apps/trac/cryptopp/"
SECTION = "libs"
LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://License.txt;md5=15bb91b85c60bac932e0a3f550bad6a3"
+LIC_FILES_CHKSUM = "file://License.txt;md5=48e7e415ea7fcc35278d8e7dc8e70b5d"
BBCLASSEXTEND = "native nativesdk"
PR = "r1"
PVSHORT = "${@'${PV}'.replace('.','')}"
-SRC_URI = "${SOURCEFORGE_MIRROR}/cryptopp/${PV}/cryptopp${PVSHORT}.zip;subdir=libcryptopp-${PV} \
- file://makefile_fix_destdir.patch \
- "
-SRC_URI[md5sum] = "7ed022585698df48e65ce9218f6c6a67"
-SRC_URI[sha256sum] = "5cbfd2fcb4a6b3aab35902e2e0f3b59d9171fee12b3fc2b363e1801dfec53574"
+SRC_URI = "https://sourceforge.net/projects/cryptopp/files/cryptopp/5.6.3/cryptopp563.zip;subdir=libcryptopp-${PV} \
+ file://0001-Fix-cross-compilation.patch \
+ "
+SRC_URI[md5sum] = "3c5b70e2ec98b7a24988734446242d07"
+SRC_URI[sha256sum] = "9390670a14170dd0f48a6b6b06f74269ef4b056d4718a1a329f6f6069dc957c9"
inherit autotools-brokensep pkgconfig